summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-09-03 00:29:35 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-09-03 00:29:35 +0000
commit49918896d4c557f113dc66cea46e71aee0395f38 (patch)
tree3bb01135355d22828c1d7b991685daa53deb3ff1 /media-sound
parentRemoving versions that have known security issues, bug #140495. (diff)
downloadhistorical-49918896d4c557f113dc66cea46e71aee0395f38.tar.gz
historical-49918896d4c557f113dc66cea46e71aee0395f38.tar.bz2
historical-49918896d4c557f113dc66cea46e71aee0395f38.zip
Version bump.
Package-Manager: portage-2.1.1_rc1-r2
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/alsa-driver/ChangeLog8
-rw-r--r--media-sound/alsa-driver/alsa-driver-1.0.13_rc1.ebuild179
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-1.0.13_rc13
-rw-r--r--media-sound/alsa-headers/ChangeLog8
-rw-r--r--media-sound/alsa-headers/alsa-headers-1.0.13_rc1.ebuild44
-rw-r--r--media-sound/alsa-headers/files/digest-alsa-headers-1.0.13_rc13
-rw-r--r--media-sound/alsa-utils/ChangeLog8
-rw-r--r--media-sound/alsa-utils/alsa-utils-1.0.13_rc1.ebuild84
-rw-r--r--media-sound/alsa-utils/files/digest-alsa-utils-1.0.13_rc13
9 files changed, 337 insertions, 3 deletions
diff --git a/media-sound/alsa-driver/ChangeLog b/media-sound/alsa-driver/ChangeLog
index ced8c247bac5..fcd68675bcca 100644
--- a/media-sound/alsa-driver/ChangeLog
+++ b/media-sound/alsa-driver/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/alsa-driver
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.222 2006/08/31 09:09:49 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.223 2006/09/03 00:29:35 flameeyes Exp $
+
+*alsa-driver-1.0.13_rc1 (03 Sep 2006)
+
+ 03 Sep 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +alsa-driver-1.0.13_rc1.ebuild:
+ Version bump.
*alsa-driver-1.0.12 (31 Aug 2006)
diff --git a/media-sound/alsa-driver/alsa-driver-1.0.13_rc1.ebuild b/media-sound/alsa-driver/alsa-driver-1.0.13_rc1.ebuild
new file mode 100644
index 000000000000..38be9f9ad65a
--- /dev/null
+++ b/media-sound/alsa-driver/alsa-driver-1.0.13_rc1.ebuild
@@ -0,0 +1,179 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.13_rc1.ebuild,v 1.1 2006/09/03 00:29:35 flameeyes Exp $
+
+inherit linux-mod flag-o-matic eutils multilib
+
+MY_P="${P/_rc/rc}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/driver/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="oss doc debug"
+
+RDEPEND="virtual/modutils
+ ~media-sound/alsa-headers-${PV}
+ !media-sound/snd-aoa"
+DEPEND="${RDEPEND}
+ virtual/linux-sources
+ sparc? ( >=sys-devel/autoconf-2.50 )
+ sys-apps/debianutils"
+
+PROVIDE="virtual/alsa"
+
+pkg_setup() {
+ # By default, drivers for all supported cards will be compiled.
+ # If you want to only compile for specific card(s), set ALSA_CARDS
+ # environment to a space-separated list of drivers that you want to build.
+ # For example:
+ #
+ # env ALSA_CARDS='emu10k1 intel8x0 ens1370' emerge alsa-driver
+ #
+ ALSA_CARDS=${ALSA_CARDS:-all}
+
+ # Which drivers need PNP
+ local PNP_DRIVERS="interwave interwave-stb"
+
+ CONFIG_CHECK="SOUND"
+ SND_ERROR="ALSA is already compiled into the kernel."
+ SOUND_ERROR="Your kernel doesn't have sound support enabled."
+ SOUND_PRIME_ERROR="Your kernel is configured to use the deprecated OSS drivers. Please disable them and re-emerge alsa-driver."
+ PNP_ERROR="Some of the drivers you selected require PNP in your kernel (${PNP_DRIVERS}). Either enable PNP in your kernel or trim which drivers get compiled using ALSA_CARDS in /etc/make.conf."
+
+ if [[ "${ALSA_CARDS}" == "all" ]]; then
+
+ # Ignore PNP checks for ppc architecture, as PNP can't be enabled there.
+ if [[ ${ARCH} != "ppc" ]]; then
+ CONFIG_CHECK="${CONFIG_CHECK} PNP"
+ fi
+ else
+ for pnpdriver in ${PNP_DRIVERS}; do
+ hasq ${pnpdriver} ${ALSA_CARDS} && CONFIG_CHECK="${CONFIG_CHECK} PNP"
+ done
+ fi
+
+ linux-mod_pkg_setup
+
+ if [[ ${PROFILE_ARCH} == "sparc64" ]] ; then
+ export CBUILD=${CBUILD-${CHOST}}
+ export CHOST="sparc64-unknown-linux-gnu"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-1.0.10_rc1-include.patch"
+
+ epatch "${FILESDIR}/${PN}-mcp55.patch"
+
+ if kernel_is ge 2 6 17 ; then
+ # These are needed for some drivers to build with kernel 2.6.17
+ # until a refreshed release of alsa-driver is done
+ epatch "${FILESDIR}/${PN}-1.0.11-kernel-2.6.17.patch"
+
+ # asihpi driver is broken, skip it until upstream releases something
+ # working.
+ sed -i -e 's:asihpi/::' "${S}/pci/Makefile"
+ fi
+
+ convert_to_m "${S}/Makefile"
+ sed -i -e 's:\(.*depmod\):#\1:' "${S}/Makefile"
+}
+
+src_compile() {
+ local myABI=${ABI:-${DEFAULT_ABI}}
+
+ # Should fix bug #46901
+ is-flag "-malign-double" && filter-flags "-fomit-frame-pointer"
+ append-flags "-I${KV_DIR}/arch/$(tc-arch-kernel)/include"
+
+ econf $(use_with oss) \
+ $(use_with debug debug full) \
+ --with-kernel="${KV_DIR}" \
+ --with-build="${KV_OUT_DIR}" \
+ --with-isapnp=yes \
+ --with-sequencer=yes \
+ --with-cards="${ALSA_CARDS}" || die "econf failed"
+
+ # linux-mod_src_compile doesn't work well with alsa
+
+ ARCH=$(tc-arch-kernel)
+ ABI=${KERNEL_ABI}
+ emake LDFLAGS="$(raw-ldflags)" HOSTCC=$(tc-getBUILD_CC) CC=$(tc-getCC) || die "Make Failed"
+ ARCH=$(tc-arch)
+ ABI=${myABI}
+
+ if use doc;
+ then
+ ebegin "Building Documentation"
+ cd ${S}/scripts
+ emake || die Failed making docs in ${S}/scripts
+
+ cd ${S}/doc/DocBook
+ emake || die Failed making docs in ${S}/doc/DocBook
+ eend $?
+ fi
+}
+
+
+src_install() {
+ emake DESTDIR=${D} install-modules || die "make install failed"
+
+ dodoc CARDS-STATUS FAQ README WARNING TODO
+
+ if use doc; then
+ docinto doc
+ dodoc doc/*
+ rm ${D}/usr/share/doc/${PF}/doc/Makefile.gz
+
+ docinto DocBook
+ dodoc doc/DocBook/*
+ rm ${D}/usr/share/doc/${PF}/DocBook/Makefile.gz
+
+ docinto Documentation
+ dodoc sound/Documentation/*
+ fi
+
+ if kernel_is 2 6; then
+ # mv the drivers somewhere they won't be killed by the kernel's make modules_install
+ mv ${D}/lib/modules/${KV_FULL}/kernel/sound ${D}/lib/modules/${KV_FULL}/${PN}
+ rmdir ${D}/lib/modules/${KV_FULL}/kernel &> /dev/null
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ einfo "The alsasound initscript and modules.d/alsa have now moved to alsa-utils"
+ einfo
+ einfo "Also, remember that all mixer channels will be MUTED by default."
+ einfo "Use the 'alsamixer' program to unmute them."
+ einfo
+ einfo "Version 1.0.3 and above should work with version 2.6 kernels."
+ einfo "If you experience problems, please report bugs to http://bugs.gentoo.org."
+ einfo
+
+ linux-mod_pkg_postinst
+
+ einfo "Check out the ALSA installation guide availible at the following URL:"
+ einfo "http://www.gentoo.org/doc/en/alsa-guide.xml"
+
+ if kernel_is 2 6 && [ -e ${ROOT}/lib/modules/${KV_FULL}/kernel/sound ]; then
+ # Cleanup if they had older alsa installed
+ for file in $(find ${ROOT}/lib/modules/${KV_FULL}/${PN} -type f); do
+ rm -f ${file//${KV_FULL}\/${PN}/${KV_FULL}\/kernel\/sound}
+ done
+
+ for dir in $(find ${ROOT}/lib/modules/${KV_FULL}/kernel/sound -type d | tac); do
+ rmdir ${dir} &> /dev/null
+ done
+ fi
+}
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-1.0.13_rc1 b/media-sound/alsa-driver/files/digest-alsa-driver-1.0.13_rc1
new file mode 100644
index 000000000000..e2cffbb7961c
--- /dev/null
+++ b/media-sound/alsa-driver/files/digest-alsa-driver-1.0.13_rc1
@@ -0,0 +1,3 @@
+MD5 216d1f6d5ab30057d06d73a98ddfbd25 alsa-driver-1.0.13rc1.tar.bz2 2404085
+RMD160 0ded870cc7465362715e6aae2cac57dd316e3983 alsa-driver-1.0.13rc1.tar.bz2 2404085
+SHA256 34163951302f608d87dd05c71680a5bfacbb0d639f1f2f7604dd50d41926b6b4 alsa-driver-1.0.13rc1.tar.bz2 2404085
diff --git a/media-sound/alsa-headers/ChangeLog b/media-sound/alsa-headers/ChangeLog
index a0b1f76da63d..ed6855d50cae 100644
--- a/media-sound/alsa-headers/ChangeLog
+++ b/media-sound/alsa-headers/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/alsa-headers
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-headers/ChangeLog,v 1.83 2006/08/31 09:09:30 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-headers/ChangeLog,v 1.84 2006/09/03 00:29:29 flameeyes Exp $
+
+*alsa-headers-1.0.13_rc1 (03 Sep 2006)
+
+ 03 Sep 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +alsa-headers-1.0.13_rc1.ebuild:
+ Version bump.
*alsa-headers-1.0.12 (31 Aug 2006)
diff --git a/media-sound/alsa-headers/alsa-headers-1.0.13_rc1.ebuild b/media-sound/alsa-headers/alsa-headers-1.0.13_rc1.ebuild
new file mode 100644
index 000000000000..c75135e98dfb
--- /dev/null
+++ b/media-sound/alsa-headers/alsa-headers-1.0.13_rc1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-headers/alsa-headers-1.0.13_rc1.ebuild,v 1.1 2006/09/03 00:29:29 flameeyes Exp $
+
+inherit eutils
+
+MY_PN=${PN/headers/driver}
+MY_P="${MY_PN}-${PV/_rc/rc}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Header files for Advanced Linux Sound Architecture kernel modules"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/driver/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+
+# Remove the sound symlink workaround...
+pkg_setup() {
+ if [[ -L "${ROOT}/usr/include/sound" ]]; then
+ rm "${ROOT}/usr/include/sound"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-1.0.6a-user.patch"
+}
+
+src_compile() {
+ einfo "No compilation neccessary"
+}
+
+src_install() {
+ cd "${S}/alsa-kernel/include"
+ insinto /usr/include/sound
+ doins *.h || die "include failed"
+}
diff --git a/media-sound/alsa-headers/files/digest-alsa-headers-1.0.13_rc1 b/media-sound/alsa-headers/files/digest-alsa-headers-1.0.13_rc1
new file mode 100644
index 000000000000..e2cffbb7961c
--- /dev/null
+++ b/media-sound/alsa-headers/files/digest-alsa-headers-1.0.13_rc1
@@ -0,0 +1,3 @@
+MD5 216d1f6d5ab30057d06d73a98ddfbd25 alsa-driver-1.0.13rc1.tar.bz2 2404085
+RMD160 0ded870cc7465362715e6aae2cac57dd316e3983 alsa-driver-1.0.13rc1.tar.bz2 2404085
+SHA256 34163951302f608d87dd05c71680a5bfacbb0d639f1f2f7604dd50d41926b6b4 alsa-driver-1.0.13rc1.tar.bz2 2404085
diff --git a/media-sound/alsa-utils/ChangeLog b/media-sound/alsa-utils/ChangeLog
index 13685d1c7add..ce76b69a3003 100644
--- a/media-sound/alsa-utils/ChangeLog
+++ b/media-sound/alsa-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/alsa-utils
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.155 2006/08/31 10:00:25 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.156 2006/09/03 00:29:35 flameeyes Exp $
+
+*alsa-utils-1.0.13_rc1 (03 Sep 2006)
+
+ 03 Sep 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +alsa-utils-1.0.13_rc1.ebuild:
+ Version bump.
31 Aug 2006; Diego Pettenò <flameeyes@gentoo.org>
alsa-utils-1.0.12.ebuild:
diff --git a/media-sound/alsa-utils/alsa-utils-1.0.13_rc1.ebuild b/media-sound/alsa-utils/alsa-utils-1.0.13_rc1.ebuild
new file mode 100644
index 000000000000..e1706957b71b
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-1.0.13_rc1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-1.0.13_rc1.ebuild,v 1.1 2006/09/03 00:29:35 flameeyes Exp $
+
+inherit eutils autotools
+
+MY_P="${P/_rc/rc}"
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/utils/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.9"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="nls"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ dev-util/dialog
+ >=media-libs/alsa-lib-1.0.12"
+RDEPEND="${DEPEND}
+ sys-apps/pciutils"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-1.0.11_rc2-nls.patch"
+ epatch "${FILESDIR}/${PN}-1.0.11_rc5-alsaconf-redirect.patch"
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ local ALSA_UTILS_DOCS="ChangeLog README TODO
+ seq/aconnect/README.aconnect
+ seq/aseqnet/README.aseqnet"
+
+ emake DESTDIR="${D}" install || die "Installation Failed"
+
+ dodoc ${ALSA_UTILS_DOCS}
+ newdoc alsamixer/README README.alsamixer
+
+ newconfd "${FILESDIR}/alsasound.confd" alsasound
+ insinto /etc/modules.d
+ newins "${FILESDIR}/alsa-modules.conf-rc" alsa
+ newinitd "${FILESDIR}/alsasound-1.0.10_rc2" alsasound
+}
+
+pkg_postinst() {
+ echo
+ einfo "The alsasound initscript is now provided by alsa-utils"
+ einfo "instead of alsa-driver for compatibility with kernel-sources"
+ einfo "which provide ALSA internally."
+ echo
+ einfo "To take advantage of this, and automate the process of"
+ einfo "loading and unloading the ALSA sound drivers as well as"
+ einfo "storing and restoring sound-card mixer levels you should"
+ einfo "add alsasound to the boot runlevel. You can do this as"
+ einfo "root like so:"
+ einfo " # rc-update add alsasound boot"
+ echo
+ einfo "You will also need to edit the file /etc/modules.d/alsa"
+ einfo "and run modules-update. You can do this like so:"
+ einfo " # nano -w /etc/modules.d/alsa && modules-update"
+ echo
+
+ if use sparc; then
+ ewarn "Old versions of alsa-drivers had a broken snd-ioctl32 module"
+ ewarn "which causes sparc64 machines to lockup on such tasks as"
+ ewarn "changing the volume. Because of this, it is VERY important"
+ ewarn "that you do not use the snd-ioctl32 modules contained in"
+ ewarn "development-sources or <=gentoo-dev-sources-2.6.7-r14. Doing so"
+ ewarn "may result in an unbootable system if you start alsasound at boot."
+ fi
+}
diff --git a/media-sound/alsa-utils/files/digest-alsa-utils-1.0.13_rc1 b/media-sound/alsa-utils/files/digest-alsa-utils-1.0.13_rc1
new file mode 100644
index 000000000000..8547b60487ca
--- /dev/null
+++ b/media-sound/alsa-utils/files/digest-alsa-utils-1.0.13_rc1
@@ -0,0 +1,3 @@
+MD5 0c3e00233753c86097b393e3e8ccd584 alsa-utils-1.0.13rc1.tar.bz2 980950
+RMD160 d3f07239099e968f477726df04df7ebc6513d891 alsa-utils-1.0.13rc1.tar.bz2 980950
+SHA256 e0d6514362bf77c383a66211fe1fd21e3c68bf5f0ee7dc15cb41c55460d6d649 alsa-utils-1.0.13rc1.tar.bz2 980950