summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-08-16 02:46:46 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-08-16 02:46:46 +0000
commit3abf0ab213db5d269c7117b5f74db688d465bdb0 (patch)
treec92e80f6824df81d19bebcc1de38f8f59803268f /media-sound
parentAdding sparc/sparc64 keywords (diff)
downloadhistorical-3abf0ab213db5d269c7117b5f74db688d465bdb0.tar.gz
historical-3abf0ab213db5d269c7117b5f74db688d465bdb0.tar.bz2
historical-3abf0ab213db5d269c7117b5f74db688d465bdb0.zip
Update to _rc3.
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/alsa-driver/ChangeLog9
-rw-r--r--media-sound/alsa-driver/alsa-driver-0.9.0_rc3.ebuild89
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-0.9.0_rc31
-rw-r--r--media-sound/alsa-utils/ChangeLog9
-rw-r--r--media-sound/alsa-utils/alsa-utils-0.9.0_rc3.ebuild32
-rw-r--r--media-sound/alsa-utils/files/digest-alsa-utils-0.9.0_rc31
6 files changed, 139 insertions, 2 deletions
diff --git a/media-sound/alsa-driver/ChangeLog b/media-sound/alsa-driver/ChangeLog
index 6baed810be02..fa30973d8d60 100644
--- a/media-sound/alsa-driver/ChangeLog
+++ b/media-sound/alsa-driver/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/alsa-driver
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.13 2002/06/20 20:36:26 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.14 2002/08/16 02:46:46 agenkin Exp $
+
+*alsa-driver-0.9.0_rc3 (15 Aug 2002)
+
+ 15 Aug 2002; Arcady Genkin <agenkin@thpoon.com>
+ alsa-driver-0.9.0_rc3.ebuild :
+
+ Quick update to version 0.9.0rc3.
*alsa-driver-0.9.0_rc2 (20 Jun 2002)
diff --git a/media-sound/alsa-driver/alsa-driver-0.9.0_rc3.ebuild b/media-sound/alsa-driver/alsa-driver-0.9.0_rc3.ebuild
new file mode 100644
index 000000000000..562713119390
--- /dev/null
+++ b/media-sound/alsa-driver/alsa-driver-0.9.0_rc3.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-0.9.0_rc3.ebuild,v 1.1 2002/08/16 02:42:11 agenkin Exp $
+
+DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
+HOMEPAGE="http://www.alsa-project.org/"
+LICENSE="GPL"
+
+# By default, drivers for all supported cards will be compiled.
+# If you want to only compile for specific card(s), set ALSA_CARDS
+# environment variable accordingly
+[ x${ALSA_CARDS} = x ] && ALSA_CARDS=all
+
+# Need the baselayout 1.7.9 or newer for the init script to work correctly.
+DEPEND="sys-devel/autoconf
+ virtual/glibc
+ >=sys-apps/portage-1.9.10
+ >=sys-apps/baselayout-1.7.9"
+RDEPEND="${DEPEND}"
+PROVIDE="virtual/alsa"
+
+SLOT="0.9"
+KEYWORDS="x86 ppc"
+
+SRC_URI="ftp://ftp.alsa-project.org/pub/driver/${P/_rc/rc}.tar.bz2"
+S=${WORKDIR}/${P/_rc/rc}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Some *broken* Gentoo packages install stuff in /etc/rc.d/init.d
+ # instead of /etc/init.d. However, this causes alsa's installer
+ # to do the same foolish thing. This *hack* inibits the problem.
+ # I filed a bug report about this with the ALSA people:
+ # http://sourceforge.net/tracker/?func=detail&aid=551668&group_id=27464&atid=390601
+ # Arcady Genkin <agenkin@thpoon.com>
+ sed -e 's:/etc/rc.d/init.d:/etc/init.d:' < Makefile > Makefile.hacked
+ mv Makefile.hacked Makefile
+
+ if [ ${ARCH} = "ppc" ]
+ then patch -p1 < ${FILESDIR}/alsa-driver-0.9.0rc1-ppc.patch || die "Patching failed"
+ fi
+}
+
+
+src_compile() {
+ # Portage should determine the version of the kernel sources
+ check_KV
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --with-kernel="${ROOT}usr/src/linux" \
+ --with-isapnp=yes \
+ --with-sequencer=yes \
+ --with-oss=yes \
+ --with-cards=${ALSA_CARDS} \
+ || die "./configure failed"
+
+ emake || die "Parallel Make Failed"
+}
+
+
+src_install () {
+ dodir /usr/include/sound
+ dodir /etc/init.d
+ make DESTDIR=${D} install || die
+
+ dodoc CARDS-STATUS COPYING FAQ INSTALL README WARNING TODO doc/*
+
+ insinto /etc/modules.d
+ newins ${FILESDIR}/alsa-modules.conf alsa
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/alsasound
+}
+
+pkg_postinst () {
+ if [ "${ROOT}" = / ]
+ then
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+ fi
+
+ einfo
+ einfo "You might want to edit file /etc/modules.d/alsa according to your"
+ einfo "hardware configuration."
+ einfo
+ einfo "If you are going to be using the 'alsasound' init script, make sure"
+ einfo "that you add it to the 'boot' runlevel (not 'default')."
+ einfo
+}
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-0.9.0_rc3 b/media-sound/alsa-driver/files/digest-alsa-driver-0.9.0_rc3
new file mode 100644
index 000000000000..c80d11621017
--- /dev/null
+++ b/media-sound/alsa-driver/files/digest-alsa-driver-0.9.0_rc3
@@ -0,0 +1 @@
+MD5 0bcce65bbc76dc292b0b0fc4ced324e5 alsa-driver-0.9.0rc3.tar.bz2 1393198
diff --git a/media-sound/alsa-utils/ChangeLog b/media-sound/alsa-utils/ChangeLog
index 43075adcfc9f..cb42179b6700 100644
--- a/media-sound/alsa-utils/ChangeLog
+++ b/media-sound/alsa-utils/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/alsa-utils
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.5 2002/06/20 20:37:18 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.6 2002/08/16 02:45:47 agenkin Exp $
+
+*alsa-utils-0.9.0_rc3 (15 Aug 2002)
+
+ 20 Jun 2002; Arcady Genkin <agenkin@thpoon.com>
+ alsa-utils-0.9.0_rc3.ebuild :
+
+ Quick update to version 0.9.0rc3.
*alsa-utils-0.9.0_rc2 (20 Jun 2002)
diff --git a/media-sound/alsa-utils/alsa-utils-0.9.0_rc3.ebuild b/media-sound/alsa-utils/alsa-utils-0.9.0_rc3.ebuild
new file mode 100644
index 000000000000..8be1d081bb74
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-0.9.0_rc3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-0.9.0_rc3.ebuild,v 1.1 2002/08/16 02:43:04 agenkin Exp $
+
+S=${WORKDIR}/${P/_rc/rc}
+DESCRIPTION="Advanced Linux Sound Architecture Utils"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="ftp://ftp.alsa-project.org/pub/utils/${P/_rc/rc}.tar.bz2"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ ~media-libs/alsa-lib-0.9.0_rc3"
+
+SLOT="0.9"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+src_compile() {
+
+ econf || die "./configure failed"
+ emake || die "Parallel Make Failed"
+}
+
+src_install() {
+ local ALSA_UTILS_DOCS="COPYING ChangeLog README TODO
+ seq/aconnect/README.aconnect
+ seq/aseqnet/README.aseqnet"
+
+ make DESTDIR=${D} install || die "Installation Failed"
+
+ dodoc ${ALSA_UTILS_DOCS}
+ newdoc alsamixer/README README.alsamixer
+}
diff --git a/media-sound/alsa-utils/files/digest-alsa-utils-0.9.0_rc3 b/media-sound/alsa-utils/files/digest-alsa-utils-0.9.0_rc3
new file mode 100644
index 000000000000..ac7d82547e8d
--- /dev/null
+++ b/media-sound/alsa-utils/files/digest-alsa-utils-0.9.0_rc3
@@ -0,0 +1 @@
+MD5 db6c946ba8978054bac1c236f34fa8bd alsa-utils-0.9.0rc3.tar.bz2 86601