summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNguyen Thai Ngoc Duy <pclouds@gentoo.org>2006-12-03 03:29:47 +0000
committerNguyen Thai Ngoc Duy <pclouds@gentoo.org>2006-12-03 03:29:47 +0000
commit36359d3360cc1df62d5d402af1a53dd8ad65f96f (patch)
treeddb5389d6c0caa5505210fb3b366109af9b7086f /media-sound
parentarm/ia64/s390/sh stable (diff)
downloadhistorical-36359d3360cc1df62d5d402af1a53dd8ad65f96f.tar.gz
historical-36359d3360cc1df62d5d402af1a53dd8ad65f96f.tar.bz2
historical-36359d3360cc1df62d5d402af1a53dd8ad65f96f.zip
Fixed #155152. Patch contributed by Alessandro Di Marco <dmr@gmx.it>
Package-Manager: portage-2.1.1
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/lastfm-ripper/ChangeLog9
-rw-r--r--media-sound/lastfm-ripper/files/URL-Handling-fix.patch2
-rw-r--r--media-sound/lastfm-ripper/files/digest-lastfm-ripper-1.2.1-r33
-rw-r--r--media-sound/lastfm-ripper/lastfm-ripper-1.2.1-r3.ebuild31
4 files changed, 43 insertions, 2 deletions
diff --git a/media-sound/lastfm-ripper/ChangeLog b/media-sound/lastfm-ripper/ChangeLog
index e08325895a25..cc81c7996f37 100644
--- a/media-sound/lastfm-ripper/ChangeLog
+++ b/media-sound/lastfm-ripper/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/lastfm-ripper
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfm-ripper/ChangeLog,v 1.4 2006/11/09 01:24:02 pclouds Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfm-ripper/ChangeLog,v 1.5 2006/12/03 03:29:47 pclouds Exp $
+
+*lastfm-ripper-1.2.1-r3 (03 Dec 2006)
+
+ 03 Dec 2006; Nguyễn Thái Ngọc Duy <pclouds@gentoo.org>
+ files/URL-Handling-fix.patch, -lastfm-ripper-1.2.1-r2.ebuild,
+ +lastfm-ripper-1.2.1-r3.ebuild:
+ Fixed #155152. Patch contributed by Alessandro Di Marco <dmr@gmx.it>
*lastfm-ripper-1.2.1-r2 (09 Nov 2006)
diff --git a/media-sound/lastfm-ripper/files/URL-Handling-fix.patch b/media-sound/lastfm-ripper/files/URL-Handling-fix.patch
index bf4965906d14..130855b4b1bf 100644
--- a/media-sound/lastfm-ripper/files/URL-Handling-fix.patch
+++ b/media-sound/lastfm-ripper/files/URL-Handling-fix.patch
@@ -5,7 +5,7 @@
elsif (!$streaming)
{
+ # from http://piglet.uccs.edu/~cs301/perl/re.htm
-+ $mp3_host=~m|(\w+)://([^/:]+)(:\d+)?/(.*)|;
++ $stream_url=~m|(\w+)://([^/:]+)(:\d+)?/(.*)|;
+ $mp3_host = $2;
+ $mp3_url= "/".$4;
+ debug("mp3_host=$mp3_host, mp3_url=$mp3_url\n");
diff --git a/media-sound/lastfm-ripper/files/digest-lastfm-ripper-1.2.1-r3 b/media-sound/lastfm-ripper/files/digest-lastfm-ripper-1.2.1-r3
new file mode 100644
index 000000000000..ad8a1ec5f94a
--- /dev/null
+++ b/media-sound/lastfm-ripper/files/digest-lastfm-ripper-1.2.1-r3
@@ -0,0 +1,3 @@
+MD5 e719e44ceb8b5ea6ac49c872a0d18872 last.fm-ripper-1.2.1.tar.gz 5659
+RMD160 ca93737fd4d56f6587a85cf0b2aaa796e632819a last.fm-ripper-1.2.1.tar.gz 5659
+SHA256 a63f4f6f3eb795b47c71328ec4e3ee99aca2d9a15ee4914163a60cb84c6ce6bd last.fm-ripper-1.2.1.tar.gz 5659
diff --git a/media-sound/lastfm-ripper/lastfm-ripper-1.2.1-r3.ebuild b/media-sound/lastfm-ripper/lastfm-ripper-1.2.1-r3.ebuild
new file mode 100644
index 000000000000..4e3c16e1bfc1
--- /dev/null
+++ b/media-sound/lastfm-ripper/lastfm-ripper-1.2.1-r3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfm-ripper/lastfm-ripper-1.2.1-r3.ebuild,v 1.1 2006/12/03 03:29:47 pclouds Exp $
+
+inherit perl-module eutils
+
+DESCRIPTION="save last.fm radio to mp3 files"
+HOMEPAGE="http://search.cpan.org/src/JOCHEN/last.fm-ripper-1.2/README"
+SRC_URI="mirror://cpan/authors/id/J/JO/JOCHEN/last.fm-ripper-${PV}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="amazon tagwriting minimal"
+
+DEPEND="perl-core/Getopt-Long
+ perl-core/Digest-MD5
+ !minimal? ( dev-perl/Term-ReadPassword )
+ tagwriting? ( dev-perl/MP3-Tag )
+ amazon? ( dev-perl/MP3-Tag dev-perl/Net-Amazon )"
+
+S="${WORKDIR}/last.fm-ripper-${PV}"
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/UnescapedVariableFix.patch
+ epatch ${FILESDIR}/CoverOutputDirectoryFix.patch
+ epatch ${FILESDIR}/HandleSlashCharFix.patch
+ epatch ${FILESDIR}/URL-Handling-fix.patch
+}