summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-12-06 17:02:31 +0000
committerDan Armak <danarmak@gentoo.org>2002-12-06 17:02:31 +0000
commitbb4a13367dfce9c36118eef352f815020c83b31b (patch)
treea6c2c68a3d498bb456d9668e9d45d8c157022d25 /media-sound/zinf
parentrepoman (diff)
downloadhistorical-bb4a13367dfce9c36118eef352f815020c83b31b.tar.gz
historical-bb4a13367dfce9c36118eef352f815020c83b31b.tar.bz2
historical-bb4a13367dfce9c36118eef352f815020c83b31b.zip
new version - but see #9675 and changelog
Diffstat (limited to 'media-sound/zinf')
-rw-r--r--media-sound/zinf/ChangeLog11
-rw-r--r--media-sound/zinf/files/digest-zinf-2.2.11
-rw-r--r--media-sound/zinf/zinf-2.2.1.ebuild78
3 files changed, 88 insertions, 2 deletions
diff --git a/media-sound/zinf/ChangeLog b/media-sound/zinf/ChangeLog
index b8436830c1fa..06c78ec12ef4 100644
--- a/media-sound/zinf/ChangeLog
+++ b/media-sound/zinf/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/zinf
-# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/zinf/ChangeLog,v 1.3 2002/09/11 20:50:47 gerk Exp $
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/zinf/ChangeLog,v 1.4 2002/12/06 17:02:31 danarmak Exp $
+
+*zinf-2.2.1 (06 Dec 2002)
+
+ 06 Dec 2002; Dan Armak <danarmak@gentoo.org> ChangeLog :
+
+ A new version. See bug #9675. I have disabled arts support (which seems
+ broken) and alsa support (which is only for alsa 0.5.x).
13 Jul 2002; Dan Armak <danarmak@gentoo.org> ChangeLog :
diff --git a/media-sound/zinf/files/digest-zinf-2.2.1 b/media-sound/zinf/files/digest-zinf-2.2.1
new file mode 100644
index 000000000000..e85e1f276767
--- /dev/null
+++ b/media-sound/zinf/files/digest-zinf-2.2.1
@@ -0,0 +1 @@
+MD5 62d603f89341a0e788451498138b962e zinf-2.2.1.tar.gz 2236502
diff --git a/media-sound/zinf/zinf-2.2.1.ebuild b/media-sound/zinf/zinf-2.2.1.ebuild
new file mode 100644
index 000000000000..7b4bdccd1ee4
--- /dev/null
+++ b/media-sound/zinf/zinf-2.2.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/zinf/zinf-2.2.1.ebuild,v 1.1 2002/12/06 17:02:31 danarmak Exp $
+
+IUSE="esd X gtk oggvorbis gnome"
+
+inherit kde-functions
+
+S=${WORKDIR}/${P}
+DESCRIPTION="An extremely full-featured mp3/vorbis/cd player with ALSA support, previously called FreeAmp"
+SRC_URI="http://telia.dl.sourceforge.net/sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.zinf.org/"
+
+RDEPEND="=dev-libs/glib-1.2*
+ =x11-libs/gtk+-1.2*
+ sys-libs/zlib
+ >=sys-libs/ncurses-5.2
+ =media-libs/freetype-1*
+ >=media-libs/musicbrainz-1.0.1
+ X? ( virtual/x11 )
+ esd? ( media-sound/esound )
+ gtk? ( >=media-libs/gdk-pixbuf-0.8 )
+ gnome? ( gnome-base/ORBit )
+ oggvorbis? ( media-libs/libvorbis )"
+ #arts? ( kde-base/arts ) # doesn't work anymore? see bug #9675
+ #alsa? ( media-libs/alsa-lib ) # it only supports alsa 0.5.x, so support disabled
+
+DEPEND="$RDEPEND x86? ( dev-lang/nasm )
+sys-devel/perl"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+# Unfortunately you can't selectively build a lot of the features. Therefore
+# this whole package is essentially a judgement call. However, I've made the
+# DEPEND in a strategic manner to ensure that your USE variable is respected
+# when the knobs are *set*.
+
+src_unpack() {
+
+ unpack ${A}
+
+# if [ "`use arts`" ]; then
+# cd ${S}/io/arts/src
+# cp artspmo.cpp 1
+# sed -e 's:artsc/artsc.h:artsc.h:g' 1 > artspmo.cpp
+# fi
+
+}
+
+src_compile() {
+
+ set-kdedir 3
+
+ local myconf
+ #use alsa ||
+ myconf="${myconf} --disable-alsa"
+ use esd || myconf="${myconf} --disable-esd"
+# use arts && export ARTSCCONFIG="$KDEDIR/bin/artsc-config" && myconf="${myconf} --with-extra-includes=${KDEDIR}/include --enable-arts" || \
+ myconf="$myconf --disable-arts"
+
+ ./configure --prefix=/usr --host=${CHOST} ${myconf} || die
+ make || die
+# use arts && ( CPATH=${KDEDIR}/include/artsc:${S}/io/arts/include make -f Makefile-plugins plugins/arts.pmo || die )
+
+}
+
+src_install() {
+
+ into /usr ; dobin zinf
+ exeinto /usr/lib/zinf/plugins ; doexe plugins/*
+ insinto /usr/share/zinf/themes ; doins themes/*
+ dodir /usr/share/zinf/fonts
+
+ dodoc AUTHORS CHANGES COPYING NEWS README README.linux
+
+}