summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-12-28 15:03:19 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-12-28 15:03:19 +0000
commit98405a77a8a9e7ff51c347be3f8f3ae025496302 (patch)
tree5d7c4cabeb11d1bf7fe992cfc82c7847b79b7cf3 /media-sound/qarecord/qarecord-0.5.0.ebuild
parentFilter new slots of ecj-3.5 reported in bug #295678. (diff)
downloadhistorical-98405a77a8a9e7ff51c347be3f8f3ae025496302.tar.gz
historical-98405a77a8a9e7ff51c347be3f8f3ae025496302.tar.bz2
historical-98405a77a8a9e7ff51c347be3f8f3ae025496302.zip
Initial commit.
Package-Manager: portage-2.2_rc61/cvs/Linux x86_64
Diffstat (limited to 'media-sound/qarecord/qarecord-0.5.0.ebuild')
-rw-r--r--media-sound/qarecord/qarecord-0.5.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-sound/qarecord/qarecord-0.5.0.ebuild b/media-sound/qarecord/qarecord-0.5.0.ebuild
new file mode 100644
index 000000000000..f8484ae6626a
--- /dev/null
+++ b/media-sound/qarecord/qarecord-0.5.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qarecord/qarecord-0.5.0.ebuild,v 1.1 2009/12/28 15:03:19 ssuominen Exp $
+
+EAPI=2
+inherit flag-o-matic multilib
+
+DESCRIPTION="A simple harddisk recorder writing from an input audio stream to a .wav file"
+HOMEPAGE="http://alsamodular.sourceforge.net/"
+SRC_URI="mirror://sourceforge/alsamodular/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/qt-gui:4
+ media-sound/jack-audio-connection-kit
+ media-libs/alsa-lib"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ append-ldflags -L/usr/$(get_libdir)/qt4
+ econf \
+ --disable-dependency-tracking
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+}