summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-01-05 22:34:26 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-01-05 22:34:26 +0000
commitdfba304a9d52aff1065fffceffc34379a6f3a7aa (patch)
treee1ba6d981b70d4d54cddccdd4c47b2ddaf09d1bf /media-sound/mp3info/mp3info-0.8.5a.ebuild
parentVersion bump. Bug #158505. Thanks Ali Polatel (diff)
downloadhistorical-dfba304a9d52aff1065fffceffc34379a6f3a7aa.tar.gz
historical-dfba304a9d52aff1065fffceffc34379a6f3a7aa.tar.bz2
historical-dfba304a9d52aff1065fffceffc34379a6f3a7aa.zip
Version bump, bug #159817
Package-Manager: portage-2.1.2_rc4-r6
Diffstat (limited to 'media-sound/mp3info/mp3info-0.8.5a.ebuild')
-rw-r--r--media-sound/mp3info/mp3info-0.8.5a.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-sound/mp3info/mp3info-0.8.5a.ebuild b/media-sound/mp3info/mp3info-0.8.5a.ebuild
new file mode 100644
index 000000000000..d4ef7dbd255f
--- /dev/null
+++ b/media-sound/mp3info/mp3info-0.8.5a.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3info/mp3info-0.8.5a.ebuild,v 1.1 2007/01/05 22:34:26 aballier Exp $
+
+inherit eutils toolchain-funcs
+
+IUSE="gtk"
+
+DESCRIPTION="An MP3 technical info viewer and ID3 1.x tag editor"
+SRC_URI="http://ibiblio.org/pub/linux/apps/sound/mp3-utils/${PN}/${P}.tgz"
+HOMEPAGE="http://ibiblio.org/mp3info/"
+
+RDEPEND="gtk? ( >=x11-libs/gtk+-2.6.10 )
+ sys-libs/ncurses"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch "${FILESDIR}/${P}-ldflags.patch"
+}
+
+src_compile() {
+ emake mp3info CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die
+ if use gtk; then
+ emake gmp3info CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "gtk mp3info failed"
+ fi
+}
+
+src_install() {
+ dobin mp3info
+ use gtk && dobin gmp3info
+
+ dodoc ChangeLog README
+ doman mp3info.1
+}