summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-02-27 01:11:41 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-02-27 01:11:41 +0000
commitaa8d208657db90d267ccae2e907a564fc9dd41b4 (patch)
tree1dc91a5de18f185bce0ed86ecb12a3b4c3251fbc /media-sound/dbmeasure
parentBump, changed ikvm dep to ikvm-bin until ikvm is fixed (diff)
downloadhistorical-aa8d208657db90d267ccae2e907a564fc9dd41b4.tar.gz
historical-aa8d208657db90d267ccae2e907a564fc9dd41b4.tar.bz2
historical-aa8d208657db90d267ccae2e907a564fc9dd41b4.zip
Initial commit. Ebuild by myself.
Package-Manager: portage-2.2_rc63/cvs/Linux x86_64
Diffstat (limited to 'media-sound/dbmeasure')
-rw-r--r--media-sound/dbmeasure/ChangeLog10
-rw-r--r--media-sound/dbmeasure/Manifest4
-rw-r--r--media-sound/dbmeasure/dbmeasure-0.0.20100217.ebuild41
-rw-r--r--media-sound/dbmeasure/metadata.xml8
4 files changed, 63 insertions, 0 deletions
diff --git a/media-sound/dbmeasure/ChangeLog b/media-sound/dbmeasure/ChangeLog
new file mode 100644
index 000000000000..0f294957a42c
--- /dev/null
+++ b/media-sound/dbmeasure/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-sound/dbmeasure
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/dbmeasure/ChangeLog,v 1.1 2010/02/27 01:11:41 robbat2 Exp $
+
+*dbmeasure-0.0.20100217 (27 Feb 2010)
+
+ 27 Feb 2010; Robin H. Johnson <robbat2@gentoo.org>
+ +dbmeasure-0.0.20100217.ebuild, +metadata.xml:
+ Initial commit. Ebuild by myself.
+
diff --git a/media-sound/dbmeasure/Manifest b/media-sound/dbmeasure/Manifest
new file mode 100644
index 000000000000..c8b0a23b4d82
--- /dev/null
+++ b/media-sound/dbmeasure/Manifest
@@ -0,0 +1,4 @@
+DIST dbmeasure-0.0.20100217-ed8105083ab72f9afac9d18b7563fbc3d6c1c925.tar.gz 6647 RMD160 0bd3455d20a15b5e3d9708bdfb1d00daf4cc5f9d SHA1 b40d531f3bdab317236d283ffb2ff50fa0d1d649 SHA256 8258db8cee11ca6da051033a6bc0db4c556deede712e31ebc02c72c64160c8d9
+EBUILD dbmeasure-0.0.20100217.ebuild 1104 RMD160 24a429cc10afd3135db595b030c249b2445d5c57 SHA1 12846a03ebd2bdd3392f7299a86246abdc5e1d92 SHA256 4f12957ce52fa9deb0d9c4692fbd3b3415b48576da885ea485f92f8f2fd90791
+MISC ChangeLog 394 RMD160 1537687f7c131d2414cdd8e440936b9caf5c4286 SHA1 4a697c2886fb5f580b9f23a04dacc87fcc02d56f SHA256 974ed89f67f2d552baa239739fa15e274ebc83534f14d3e391051156b9c211fa
+MISC metadata.xml 223 RMD160 ffa99612cf27469c417944deed0e0c9155e64331 SHA1 607c637402dd253406aa6ee684471a702c5d1a99 SHA256 d6bb9ba68629616062b4433ab3b8fb01dfcafae5bb47804d9e06cdd6c66daa44
diff --git a/media-sound/dbmeasure/dbmeasure-0.0.20100217.ebuild b/media-sound/dbmeasure/dbmeasure-0.0.20100217.ebuild
new file mode 100644
index 000000000000..6a691413c599
--- /dev/null
+++ b/media-sound/dbmeasure/dbmeasure-0.0.20100217.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/dbmeasure/dbmeasure-0.0.20100217.ebuild,v 1.1 2010/02/27 01:11:41 robbat2 Exp $
+
+EAPI=3
+GIT_COMMITID="ed8105083ab72f9afac9d18b7563fbc3d6c1c925"
+MY_PV="${PV}-${GIT_COMMITID}"
+MY_P="${PN}-${MY_PV}"
+
+inherit flag-o-matic
+
+DESCRIPTION="ALSA Volume Control Attenuation Measurement Tool"
+HOMEPAGE="http://pulseaudio.org/wiki/BadDecibel"
+SRC_URI="http://git.0pointer.de/?p=${PN}.git;a=snapshot;h=${GIT_COMMITID};sf=tgz -> ${MY_P}.tar.gz"
+
+LICENSE="BSD" # need to confirm w/ upstream
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/alsa-lib"
+DEPEND="media-sound/alsa-headers
+ dev-util/pkgconfig
+ ${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ # We drop the -g for debug output but we keep the -O0, as we don't want GCC
+ # to optimize out some critical math.
+ strip-flags
+ sed -i \
+ -e '/^CFLAGS/s,=,+=,g' \
+ -e '/^CFLAGS/s,-g,,g' \
+ Makefile || die "Failed to fix makefile"
+}
+
+src_install() {
+ dobin dbverify dbmeasure
+ dodoc README
+}
diff --git a/media-sound/dbmeasure/metadata.xml b/media-sound/dbmeasure/metadata.xml
new file mode 100644
index 000000000000..5d9f5be9d49d
--- /dev/null
+++ b/media-sound/dbmeasure/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>robbat2@gentoo.org</email>
+</maintainer>
+</pkgmetadata>