summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-04-17 18:02:12 +0000
committerMarinus Schraal <foser@gentoo.org>2003-04-17 18:02:12 +0000
commitb3868fac9e13a8e8cf9dbde3767611a6e96e1bc3 (patch)
tree9a0cc8dd0dcacdafe9528e3f5fda544561f7ace7 /media-libs
parentstable on alpha (diff)
downloadhistorical-b3868fac9e13a8e8cf9dbde3767611a6e96e1bc3.tar.gz
historical-b3868fac9e13a8e8cf9dbde3767611a6e96e1bc3.tar.bz2
historical-b3868fac9e13a8e8cf9dbde3767611a6e96e1bc3.zip
2.2 prerelease
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/fontconfig/ChangeLog7
-rw-r--r--media-libs/fontconfig/files/digest-fontconfig-2.1.941
-rw-r--r--media-libs/fontconfig/fontconfig-2.1.94.ebuild90
3 files changed, 97 insertions, 1 deletions
diff --git a/media-libs/fontconfig/ChangeLog b/media-libs/fontconfig/ChangeLog
index bb53cd64f5d9..e442b0ca7cea 100644
--- a/media-libs/fontconfig/ChangeLog
+++ b/media-libs/fontconfig/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/fontconfig
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/ChangeLog,v 1.23 2003/04/08 15:29:44 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/ChangeLog,v 1.24 2003/04/17 18:02:12 foser Exp $
+
+*fontconfig-2.1.94 (17 Apr 2003)
+
+ 17 Apr 2003; foser <foser@gentoo.org> fontconfig-2.1.94.ebuild :
+ Pre 2.2 release, supports Bitstream Vera fonts
08 Apr 2003; Martin Schlemmer <azarah@gentoo.org> fontconfig-2.1-r1.ebuild :
Mark stable for x86 and mips. It has been in testing for long, and stable
diff --git a/media-libs/fontconfig/files/digest-fontconfig-2.1.94 b/media-libs/fontconfig/files/digest-fontconfig-2.1.94
new file mode 100644
index 000000000000..8fba4752ac4c
--- /dev/null
+++ b/media-libs/fontconfig/files/digest-fontconfig-2.1.94
@@ -0,0 +1 @@
+MD5 f8941aa333e418aa99a6fa4813f333d3 fontconfig-2.1.94.tar.gz 603590
diff --git a/media-libs/fontconfig/fontconfig-2.1.94.ebuild b/media-libs/fontconfig/fontconfig-2.1.94.ebuild
new file mode 100644
index 000000000000..8e36e67eb089
--- /dev/null
+++ b/media-libs/fontconfig/fontconfig-2.1.94.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/fontconfig-2.1.94.ebuild,v 1.1 2003/04/17 18:02:12 foser Exp $
+
+inherit debug eutils
+
+DESCRIPTION="A library for configuring and customizing font access."
+SRC_URI="http://fontconfig.org/release/${P}.tar.gz"
+HOMEPAGE="http://fontconfig.org/"
+
+LICENSE="fontconfig"
+SLOT="1.0"
+KEYWORDS="~x86 ~alpha ~ppc ~sparc ~mips ~hppa ~arm"
+
+# Seems like patches in freetype-2.1.2-r2 fixes bug #10028
+DEPEND=">=media-libs/freetype-2.1.2-r2
+ >=dev-libs/expat-1.95.3
+ >=sys-apps/ed-0.2"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ local PPREFIX="${FILESDIR}/patch/${PN}"
+
+ # Some patches from Redhat
+ epatch ${PPREFIX}-2.1-slighthint.patch
+
+ # The date can be troublesome
+ mv configure configure.old
+ sed -e "s:\`date\`::" configure.old > configure
+ chmod +x configure
+}
+
+src_compile() {
+ # FIXME : docs do not work
+ econf --disable-docs \
+ --x-includes=/usr/X11R6/include \
+ --x-libraries=/usr/X11R6/lib \
+ --with-default-fonts=/usr/X11R6/lib/X11/fonts/Type1 || die
+
+ # this triggers sandbox, we do this ourselves
+ mv Makefile Makefile.old
+ sed -e "s:fc-cache/fc-cache -f -v:sleep 0:" Makefile.old > Makefile
+
+ emake || die
+
+ # remove Luxi TTF fonts from the list, the Type1 are much better
+ mv fonts.conf fonts.conf.old
+ sed -e "s:<dir>/usr/X11R6/lib/X11/fonts/TTF</dir>::" fonts.conf.old > fonts.conf
+}
+
+src_install() {
+ einstall confdir=${D}/etc/fonts \
+ datadir=${D}/usr/share || die
+
+ insinto /etc/fonts
+ doins ${S}/fonts.conf
+ newins ${S}/fonts.conf fonts.conf.new
+
+ cd ${S}
+
+ mv fc-cache/fc-cache.man fc-cache/fc-cache.1
+ mv fc-list/fc-list.man fc-list/fc-list.1
+ mv src/fontconfig.man src/fontconfig.3
+ for x in fc-cache/fc-cache.1 fc-list/fc-list.1 src/fontconfig.3
+ do
+ doman ${x}
+ done
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ # Changes should be made to /etc/fonts/local.conf, and as we had
+ # too much problems with broken fonts.conf, we force update it ...
+ # <azarah@gentoo.org> (11 Dec 2002)
+ ewarn "Please make fontconfig related changes to /etc/fonts/local.conf,"
+ ewarn "and NOT to /etc/fonts/fonts.conf, as it will be replaced!"
+ mv -f ${ROOT}/etc/fonts/fonts.conf.new ${ROOT}/etc/fonts/fonts.conf
+ rm -f ${ROOT}/etc/fonts/._cfg????_fonts.conf
+
+ if [ "${ROOT}" = "/" ]
+ then
+ echo
+ einfo "Creating font cache..."
+ HOME="/root" /usr/bin/fc-cache -f
+ fi
+}
+