summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-10-29 17:31:20 +0000
committerMike Frysinger <vapier@gentoo.org>2002-10-29 17:31:20 +0000
commitb27dace38f6b3258382a9edfe2b42b7af0ceed91 (patch)
tree8c23619b2e994658af61549cdf9ca81c41effef6 /media-libs
parentChanged KEYWORDS="x86" to KEYWORDS="~x86". (diff)
downloadhistorical-b27dace38f6b3258382a9edfe2b42b7af0ceed91.tar.gz
historical-b27dace38f6b3258382a9edfe2b42b7af0ceed91.tar.bz2
historical-b27dace38f6b3258382a9edfe2b42b7af0ceed91.zip
Fix for #9793
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/pdflib/ChangeLog9
-rw-r--r--media-libs/pdflib/pdflib-4.0.1-r3.ebuild16
2 files changed, 13 insertions, 12 deletions
diff --git a/media-libs/pdflib/ChangeLog b/media-libs/pdflib/ChangeLog
index 0f1df00a0629..3cfd6049f671 100644
--- a/media-libs/pdflib/ChangeLog
+++ b/media-libs/pdflib/ChangeLog
@@ -1,24 +1,24 @@
# ChangeLog for media-libs/pdflib
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-libs/pdflib/ChangeLog,v 1.6 2002/09/07 17:33:27 owen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/pdflib/ChangeLog,v 1.7 2002/10/29 17:31:20 vapier Exp $
*pdflib-4.0.1-r3 (3 Apr 2002)
+ 28 Oct 2002; Mike Frysinger <vapier@gentoo.org> :
+ Links libpng against zlib and libstdc++ to fix #9793
+
7 Sep 2002; Owen Stampflee <owen@gentoo.org> :
Added PPC to KEYWORDS.
14 Aug 2002; Seemant Kulleen <seemant@genoo.org> pdflib-4.0.1-r1.ebuild :
-
Added libpng as a dependency. Closes bug #6480 by bar4ka@bol.com.br
(bar4ka)
08 Aug 2002; Seemant Kulleen <seemant@gentoo.org> pdflib-4.0.1-r3.ebuild :
-
Added "--with-zlib" configure flag. Closes bug #6205 by sponge80@msn.com
(Nicholas)
7 Aug 2002; Ryan Phillips <rphillips@gentoo.org> :
-
Changed package to use system libpng. PHP doesn't like being
linked to two separate places.
@@ -36,7 +36,6 @@
*pdflib-4.0.1-r2 (1 Feb 2002)
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
Added initial ChangeLog which should be updated whenever the package is
updated in any way. This changelog is targetted to users. This means that the
comments should well explained and written in clean English. The details about
diff --git a/media-libs/pdflib/pdflib-4.0.1-r3.ebuild b/media-libs/pdflib/pdflib-4.0.1-r3.ebuild
index b29847c23ea7..a2a7c4936c87 100644
--- a/media-libs/pdflib/pdflib-4.0.1-r3.ebuild
+++ b/media-libs/pdflib/pdflib-4.0.1-r3.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/pdflib/pdflib-4.0.1-r3.ebuild,v 1.10 2002/10/05 05:39:15 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/pdflib/pdflib-4.0.1-r3.ebuild,v 1.11 2002/10/29 17:31:20 vapier Exp $
IUSE="python tcltk java perl"
S=${WORKDIR}/${P}
DESCRIPTION="A library for generating PDF on the fly"
SRC_URI="http://www.pdflib.com/pdflib/download/${P}.tar.gz"
-HOMEPAGE="http://www.pdflib.com"
+HOMEPAGE="http://www.pdflib.com/"
SLOT="4"
LICENSE="Aladdin"
@@ -17,11 +17,10 @@ DEPEND="tcltk? ( >=dev-lang/tk-8.2 )
perl? ( >=sys-devel/perl-5.1 )
python? ( >=dev-lang/python-2.0 )
java? ( >=virtual/jdk-1.3 )
- media-libs/libpng"
-
+ media-libs/libpng
+ sys-libs/zlib"
src_compile() {
-
# fix sandbox violations
# NOTE: the basic theory is to not compile pdflib.java during
# src_compile() or src_install(), but rather in pkg_postinstall(),
@@ -51,18 +50,21 @@ src_compile() {
&& myconf="${myconf} --with-java=${JAVA_HOME}" \
|| myconf="${myconf} --with-java=no"
+ # libpng-1.2.5 needs to be linked against stdc++ and zlib
+ cp configure configure.old
+ sed -e 's:-lpng:-lpng -lz -lstdc++:' configure.old > configure
+
econf \
--enable-cxx \
--disable-php \
--with-pnglib \
--with-zlib \
${myconf} || die
-
+
emake || die
}
src_install() {
-
# fix sandbox violations
# NB: do this *after* build, otherwise we will get linker problems.
# all we basically do here is modify the install path for Makefiles that