summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-05-07 06:13:11 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-05-07 06:13:11 +0000
commit74f6ea3ec1a4e6dca57305dba0b0a2091400bd63 (patch)
treef65e4f834d4b348980775b774fa4ef50ffb09975 /media-libs
parentAdd missing patch, Big ooops (diff)
downloadhistorical-74f6ea3ec1a4e6dca57305dba0b0a2091400bd63.tar.gz
historical-74f6ea3ec1a4e6dca57305dba0b0a2091400bd63.tar.bz2
historical-74f6ea3ec1a4e6dca57305dba0b0a2091400bd63.zip
use emake; tidy; fix HOMEPAGE (bug #50289)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/qhull/ChangeLog5
-rw-r--r--media-libs/qhull/Manifest4
-rw-r--r--media-libs/qhull/qhull-3.1-r1.ebuild72
3 files changed, 42 insertions, 39 deletions
diff --git a/media-libs/qhull/ChangeLog b/media-libs/qhull/ChangeLog
index bd4a7b8f28cb..a5b89301e348 100644
--- a/media-libs/qhull/ChangeLog
+++ b/media-libs/qhull/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-libs/qhull
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/qhull/ChangeLog,v 1.10 2004/05/07 05:34:08 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/qhull/ChangeLog,v 1.11 2004/05/07 06:13:11 mr_bones_ Exp $
+
+ 06 May 2004; Michael Sterrett <mr_bones_@gentoo.org> qhull-3.1-r1.ebuild:
+ use emake; tidy; fix HOMEPAGE (bug #50289)
06 May 2004; Michael Sterrett <mr_bones_@gentoo.org> qhull-3.1.ebuild:
clean older ebuild
diff --git a/media-libs/qhull/Manifest b/media-libs/qhull/Manifest
index a76bfcb39be4..bbc2140a45cf 100644
--- a/media-libs/qhull/Manifest
+++ b/media-libs/qhull/Manifest
@@ -1,3 +1,3 @@
-MD5 8ad3718139f099e129de028efc513e3e ChangeLog 1805
-MD5 74de38d07f7e2d28dd08a81cee3d406f qhull-3.1-r1.ebuild 1387
+MD5 340108ad395d048f1e198acba1b4b408 ChangeLog 1927
+MD5 987f73255d442bc9fbe6ac6731b90bd7 qhull-3.1-r1.ebuild 1538
MD5 9b2354326e097e633a3488a6a22fe7c9 files/digest-qhull-3.1-r1 57
diff --git a/media-libs/qhull/qhull-3.1-r1.ebuild b/media-libs/qhull/qhull-3.1-r1.ebuild
index 078d7066124c..a289c2113e1f 100644
--- a/media-libs/qhull/qhull-3.1-r1.ebuild
+++ b/media-libs/qhull/qhull-3.1-r1.ebuild
@@ -1,62 +1,62 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/qhull/qhull-3.1-r1.ebuild,v 1.5 2004/04/12 22:55:11 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/qhull/qhull-3.1-r1.ebuild,v 1.6 2004/05/07 06:13:11 mr_bones_ Exp $
-IUSE=""
-
-S=${WORKDIR}/qhull3.1
+MY_P="${PN}${PV}"
DESCRIPTION="Geometry library"
-SRC_URI="http://www.geom.umn.edu/software/qhull/qhull3.1.tgz"
-HOMEPAGE="http://www.geom.umn.edu/software/qhull/"
+HOMEPAGE="http://www.qhull.org"
+SRC_URI="http://www.geom.umn.edu/software/qhull/${MY_P}.tgz"
SLOT="0"
LICENSE="BSD"
KEYWORDS="x86 sparc ~ppc ~amd64"
+IUSE=""
-DEPEND=""
+RDEPEND="virtual/glibc"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
-src_compile() {
- cd src
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/src
+ mv Makefile.txt Makefile
# This echo statement appends a new build target to the exisiting Makefile
# for an additional shared library; originally added to support octave-forge
echo 'libqhull.so: $(OBJS)
- c++ -shared -Xlinker -soname -Xlinker $@ -o libqhull.so $(OBJS)' >> Makefile.txt
- # This line now specifies the build targets, including the target added on
- # the previous line
- make -f Makefile.txt all libqhull.so
-
+ c++ -shared -Xlinker -soname -Xlinker $@ -o libqhull.so $(OBJS)' >> Makefile
+
+ # the newly compiled programs will be run during the build. seems
+ # easiest to statically link.
+ sed -i \
+ -e 's/-lqhull/libqhull.a/' \
+ -e '/^all:/ s/$/ libqhull.so/' Makefile \
+ || die "sed Makefile failed"
}
-src_install () {
+src_compile() {
+ cd src
+ emake CCOPTS1="${CFLAGS}" || die "emake failed"
+}
+src_install() {
cd src
- dolib libqhull.a
- # This line installs the extra shared lib compiled with the target added
- # above
- dolib.so libqhull.so
- dobin qconvex
- dobin qdelaunay
- dobin qhalf
- dobin qhull
- dobin qvoronoi
- dobin rbox
-
- dodir /usr/include/qhull
+ dolib libqhull.a || die "dolib failed"
+ dolib.so libqhull.so || die "dolib.so failed"
+ dobin qconvex qdelaunay qhalf qhull qvoronoi rbox || die "dobin failed"
+
insinto /usr/include/qhull
doins *.h
cd ${S}
dodoc Announce.txt COPYING.txt File_id.diz README.txt REGISTER.txt
-
cd html
-
- rename .htm .html *.htm
- rename .man .1 *.man
-
- dohtml -a html,gif *
-
- doman *.1
-
+ dohtml *
dodoc *.txt
+ for m in *man
+ do
+ newman ${m} ${m/.man/.1}
+ done
}