summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-05 01:24:54 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-05 01:24:54 +0000
commit4d807f831ee70671aa4b83f887d74e1be87fdfdc (patch)
tree9964e486bac8de7838207151328e25719392d6fb /media-libs
parentcleanup and arm love (diff)
downloadhistorical-4d807f831ee70671aa4b83f887d74e1be87fdfdc.tar.gz
historical-4d807f831ee70671aa4b83f887d74e1be87fdfdc.tar.bz2
historical-4d807f831ee70671aa4b83f887d74e1be87fdfdc.zip
Version bump with build fix by Sergey S. Stasyuk #100690.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libfpx/ChangeLog10
-rw-r--r--media-libs/libfpx/files/digest-libfpx-1.2.0.121
-rw-r--r--media-libs/libfpx/files/libfpx-1.2.0.12-makefile.patch19
-rw-r--r--media-libs/libfpx/libfpx-1.2.0.12.ebuild33
4 files changed, 61 insertions, 2 deletions
diff --git a/media-libs/libfpx/ChangeLog b/media-libs/libfpx/ChangeLog
index a3ac7e2bc1c9..165dba88fc95 100644
--- a/media-libs/libfpx/ChangeLog
+++ b/media-libs/libfpx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libfpx
-# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libfpx/ChangeLog,v 1.13 2004/12/29 00:50:15 ciaranm Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libfpx/ChangeLog,v 1.14 2005/08/05 01:24:54 vapier Exp $
+
+*libfpx-1.2.0.12 (05 Aug 2005)
+
+ 05 Aug 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/libfpx-1.2.0.12-makefile.patch, +libfpx-1.2.0.12.ebuild:
+ Version bump with build fix by Sergey S. Stasyuk #100690.
29 Dec 2004; Ciaran McCreesh <ciaranm@gentoo.org> :
Change encoding to UTF-8 for GLEP 31 compliance
diff --git a/media-libs/libfpx/files/digest-libfpx-1.2.0.12 b/media-libs/libfpx/files/digest-libfpx-1.2.0.12
new file mode 100644
index 000000000000..6cdb105da79a
--- /dev/null
+++ b/media-libs/libfpx/files/digest-libfpx-1.2.0.12
@@ -0,0 +1 @@
+MD5 a82d33cc0ede71752802da0f410398b8 libfpx-1.2.0.12.tar.bz2 2301747
diff --git a/media-libs/libfpx/files/libfpx-1.2.0.12-makefile.patch b/media-libs/libfpx/files/libfpx-1.2.0.12-makefile.patch
new file mode 100644
index 000000000000..62638fae8f14
--- /dev/null
+++ b/media-libs/libfpx/files/libfpx-1.2.0.12-makefile.patch
@@ -0,0 +1,19 @@
+--- oless/Makefile.in
++++ oless/Makefile.in
+@@ -54,7 +54,7 @@
+ am_libOless_la_OBJECTS = ascii.lo cdocfile.lo chinst.lo dffuncs.lo \
+ dfiter.lo dfstream.lo difat.lo dir.lo dirp.lo docfile.lo \
+ entry.lo expdf.lo expiter.lo expst.lo fat.lo funcs.lo \
+- header.lo header.lo iter.lo mem.lo msf.lo msfiter.lo \
++ header.lo iter.lo mem.lo msf.lo msfiter.lo \
+ mstream.lo page.lo refilb.lo rexpdf.lo sstream.lo storage.lo \
+ time.lo vect.lo wchar.lo
+ libOless_la_OBJECTS = $(am_libOless_la_OBJECTS)
+@@ -76,7 +76,6 @@
+ h/vect.hxx \
+ h/vectfunc.hxx \
+ header.cxx \
+- header.cxx \
+ iter.cxx \
+ iter.hxx \
+ logfile.hxx \
diff --git a/media-libs/libfpx/libfpx-1.2.0.12.ebuild b/media-libs/libfpx/libfpx-1.2.0.12.ebuild
new file mode 100644
index 000000000000..43ff3122d597
--- /dev/null
+++ b/media-libs/libfpx/libfpx-1.2.0.12.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libfpx/libfpx-1.2.0.12.ebuild,v 1.1 2005/08/05 01:24:54 vapier Exp $
+
+inherit eutils
+
+### uncomment the right variables depending on if we have a patchlevel or not
+#MY_P=${PN}-${PV%.*}-${PV#*.*.*.}
+#MY_P2=${PN}-${PV%.*}
+MY_P=${PN}-${PV}
+MY_P2=${PN}-${PV}
+
+DESCRIPTION="A library for manipulating FlashPIX images"
+HOMEPAGE="http://www.i3a.org/"
+SRC_URI="ftp://ftp.imagemagick.org/pub/ImageMagick/delegates/${MY_P}.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P2}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc doc/*
+}