summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-05-01 23:03:41 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-05-01 23:03:41 +0000
commit44717a32bed0cdca3c1f66d070f65f6562e9f286 (patch)
tree8aa06c2c9decc5ddf0d389856a893a70ca49dc7c /media-libs
parentfirst revision of the dblink class; virtuals-related fixes (diff)
downloadhistorical-44717a32bed0cdca3c1f66d070f65f6562e9f286.tar.gz
historical-44717a32bed0cdca3c1f66d070f65f6562e9f286.tar.bz2
historical-44717a32bed0cdca3c1f66d070f65f6562e9f286.zip
*** empty log message ***
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/glu/glu-3.4.1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/media-libs/glu/glu-3.4.1.ebuild b/media-libs/glu/glu-3.4.1.ebuild
new file mode 100644
index 000000000000..85d01d526ad5
--- /dev/null
+++ b/media-libs/glu/glu-3.4.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/glu/glu-3.4.1.ebuild,v 1.1 2001/05/01 23:03:41 drobbins Exp $
+
+S=${WORKDIR}/Mesa-${PV}
+DESCRIPTION="OpenGL like graphic library for Linux, this package only contains the glu and glut parts"
+SRC_URI="http://download.sourceforge.net/mesa3d/MesaLib-${PV}.tar.bz2"
+HOMEPAGE="http://mesa3d.sourceforge.net/"
+
+DEPEND="virtual/glibc virtual/x11"
+
+PROVIDE="virtual/glu"
+
+src_compile() {
+
+ local myconf
+
+ if [ "`use mmx`" ]
+ then
+ myconf="--enable-mmx"
+ else
+ myconf="--disable-mmx"
+ fi
+
+ if [ "`use 3dnow`" ]
+ then
+ myconf="${myconf} --enable-3dnow"
+ else
+ myconf="${myconf} --disable-3dnow"
+ fi
+
+ if [ "`use sse`" ]
+ then
+ myconf="${myconf} --enable-sse"
+ else
+ myconf="${myconf} --disable-sse"
+ fi
+
+ myconf="${myconf} --with-x --without-glut --disable-ggi-fbdev --without-ggi"
+
+ try ./configure --prefix=/usr --sysconfdir=/etc/mesa --host=${CHOST} $myconf
+
+ try make
+}
+
+src_install () {
+ cd ${S}
+ try make DESTDIR=${D} install
+ cd ${D}/usr/lib
+
+ rm -f libGL.*
+ rm -f ../include/GL/gl.h
+ rm -f ../include/GL/glx.h
+ rm -f ../include/GL/osmesa.h
+
+ ln -s libGLU.so.1.1.030400 libMesaGLU.so.3
+
+ cd ${S}
+ dodoc docs/*
+}
+