summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-03-25 19:38:53 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-03-25 19:38:53 +0000
commit7c3043f05d95bafa76f3b3cc472b0a4bec69ef7c (patch)
tree37b9831e712797b1d3e3605e81430d1f75fdeda4 /media-libs/x264-svn/x264-svn-20070325.ebuild
parentStable on x86, security bug #170881. (diff)
downloadhistorical-7c3043f05d95bafa76f3b3cc472b0a4bec69ef7c.tar.gz
historical-7c3043f05d95bafa76f3b3cc472b0a4bec69ef7c.tar.bz2
historical-7c3043f05d95bafa76f3b3cc472b0a4bec69ef7c.zip
New snapshot
Package-Manager: portage-2.1.2.2
Diffstat (limited to 'media-libs/x264-svn/x264-svn-20070325.ebuild')
-rw-r--r--media-libs/x264-svn/x264-svn-20070325.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/media-libs/x264-svn/x264-svn-20070325.ebuild b/media-libs/x264-svn/x264-svn-20070325.ebuild
new file mode 100644
index 000000000000..6cd834b90add
--- /dev/null
+++ b/media-libs/x264-svn/x264-svn-20070325.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264-svn/x264-svn-20070325.ebuild,v 1.1 2007/03/25 19:38:52 aballier Exp $
+
+inherit multilib eutils toolchain-funcs
+
+IUSE="debug threads"
+
+DESCRIPTION="A free library for encoding X264/AVC streams."
+HOMEPAGE="http://developers.videolan.org/x264.html"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=""
+
+DEPEND="${RDEPEND}
+ amd64? ( >=dev-lang/yasm-0.6.0 )
+ x86? ( dev-lang/nasm )
+ x86-fbsd? ( dev-lang/nasm )"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-nostrip.patch"
+ epatch "${FILESDIR}/${P}-onlylib.patch"
+}
+
+src_compile() {
+ ./configure --prefix=/usr \
+ --libdir=/usr/$(get_libdir) \
+ --enable-pic --enable-shared \
+ "--extra-cflags=${CFLAGS}" \
+ "--extra-ldflags=${LDFLAGS}" \
+ "--extra-asflags=${ASFLAGS}" \
+ $(use_enable debug) \
+ $(use_enable threads pthread) \
+ --disable-mp4-output \
+ || die "configure failed"
+ emake CC="$(tc-getCC)" || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS
+}
+
+pkg_postinst() {
+ elog "Please note that this package now only installs"
+ elog "${PN} libraries. In order to have the encoder,"
+ elog "please emerge media-video/x264-svn-encoder"
+}