summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-02-23 10:02:21 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-02-23 10:02:21 +0000
commit8c42734fb3a31b79080fa25e596f28fa809de500 (patch)
tree209069355001508b44b42c007344a81d898dd347 /media-libs/tremor/tremor-0_pre20130223.ebuild
parentStable for sparc, wrt bug #458188 (diff)
downloadhistorical-8c42734fb3a31b79080fa25e596f28fa809de500.tar.gz
historical-8c42734fb3a31b79080fa25e596f28fa809de500.tar.bz2
historical-8c42734fb3a31b79080fa25e596f28fa809de500.zip
New snapshot; new USE flag "low-accuracy" to enable 32bit only multiply operations
Package-Manager: portage-2.2.0_alpha163/cvs/Linux x86_64 Manifest-Sign-Key: 0x4868F14D
Diffstat (limited to 'media-libs/tremor/tremor-0_pre20130223.ebuild')
-rw-r--r--media-libs/tremor/tremor-0_pre20130223.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-libs/tremor/tremor-0_pre20130223.ebuild b/media-libs/tremor/tremor-0_pre20130223.ebuild
new file mode 100644
index 000000000000..1ece19f82132
--- /dev/null
+++ b/media-libs/tremor/tremor-0_pre20130223.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tremor/tremor-0_pre20130223.ebuild,v 1.1 2013/02/23 10:02:17 ssuominen Exp $
+
+EAPI=5
+
+# svn export http://svn.xiph.org/trunk/Tremor tremor-${PV}
+
+inherit autotools eutils
+
+DESCRIPTION="A fixed-point version of the Ogg Vorbis decoder (also known as libvorbisidec)"
+HOMEPAGE="http://wiki.xiph.org/Tremor"
+SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+IUSE="low-accuracy static-libs"
+
+RDEPEND="media-libs/libogg:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="CHANGELOG README"
+
+src_prepare() {
+ sed -i -e '/CFLAGS/s:-O2::' configure.in || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable low-accuracy)
+}
+
+src_install() {
+ default
+ dohtml -r doc/*
+ prune_libtool_files
+}