summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-03 09:28:37 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-03 09:28:37 +0000
commitfbc2d4465f56e757a17e7ba586baf7b45ba8de6f (patch)
tree466c03c493df6d03d92f1a30e2cb09b88b49d934 /media-libs/speex
parentReplace libtoolize with eautoreconf so that it does not break with mis-versio... (diff)
downloadhistorical-fbc2d4465f56e757a17e7ba586baf7b45ba8de6f.tar.gz
historical-fbc2d4465f56e757a17e7ba586baf7b45ba8de6f.tar.bz2
historical-fbc2d4465f56e757a17e7ba586baf7b45ba8de6f.zip
Fix issues with parallel make.
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'media-libs/speex')
-rw-r--r--media-libs/speex/ChangeLog5
-rw-r--r--media-libs/speex/Manifest14
-rw-r--r--media-libs/speex/speex-1.1.11.1.ebuild27
3 files changed, 39 insertions, 7 deletions
diff --git a/media-libs/speex/ChangeLog b/media-libs/speex/ChangeLog
index cbfd0386a602..386e2a677975 100644
--- a/media-libs/speex/ChangeLog
+++ b/media-libs/speex/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-libs/speex
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/speex/ChangeLog,v 1.41 2006/01/03 03:31:33 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/speex/ChangeLog,v 1.42 2006/01/03 09:28:37 flameeyes Exp $
+
+ 03 Jan 2006; Diego Pettenò <flameeyes@gentoo.org> speex-1.1.11.1.ebuild:
+ Fix issues with parallel make.
*speex-1.1.11.1 (03 Jan 2006)
diff --git a/media-libs/speex/Manifest b/media-libs/speex/Manifest
index 2ae0dd5eff4d..df0722ff262b 100644
--- a/media-libs/speex/Manifest
+++ b/media-libs/speex/Manifest
@@ -1,4 +1,7 @@
-MD5 884ed1e846d8178bb473045ddd2e599c ChangeLog 5675
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 6839e349dfb0bbab3235525678df90d3 ChangeLog 5788
MD5 ba0dba31926ad8799962806a688b7594 files/digest-speex-1.0.2 63
MD5 e103df8cbfd726cbc56768dd2a813130 files/digest-speex-1.0.3 63
MD5 f6d80f2098d9630b178e1324d8745255 files/digest-speex-1.1.10 64
@@ -10,6 +13,13 @@ MD5 4e5a50f7aee667b932576ab7fdcfc85f metadata.xml 219
MD5 fa5d9248e3f54c1a596d57b192d49715 speex-1.0.2.ebuild 935
MD5 73f8070fe449bc710645a292d325f360 speex-1.0.3.ebuild 942
MD5 6caad76233a1bf92dba410c72c9da6d3 speex-1.1.10.ebuild 933
-MD5 4ad89945e533964542c568b30b1c82af speex-1.1.11.1.ebuild 738
+MD5 0261082119fbccc261bba7554348e606 speex-1.1.11.1.ebuild 1123
MD5 aa8b056df8d1a1d2a36d44cd721f0e82 speex-1.1.5.ebuild 963
MD5 6422153be85815565c22cb86fcbf4272 speex-1.1.7.ebuild 966
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDukPSAiZjviIA2XgRAufSAKDkhIUcLYN7TECPMaNsyJWYCV1LHwCgmWIy
+ZEe0DFoyD34heP/y46q2pBo=
+=eZc8
+-----END PGP SIGNATURE-----
diff --git a/media-libs/speex/speex-1.1.11.1.ebuild b/media-libs/speex/speex-1.1.11.1.ebuild
index 464a45d7d831..41e6c678715e 100644
--- a/media-libs/speex/speex-1.1.11.1.ebuild
+++ b/media-libs/speex/speex-1.1.11.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/speex/speex-1.1.11.1.ebuild,v 1.1 2006/01/03 03:31:33 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/speex/speex-1.1.11.1.ebuild,v 1.2 2006/01/03 09:28:37 flameeyes Exp $
-inherit eutils
+inherit eutils autotools libtool
DESCRIPTION="Speech encoding library"
HOMEPAGE="http://www.speex.org/"
@@ -13,8 +13,27 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
IUSE="ogg sse"
-DEPEND="virtual/libc
- ogg? ( >=media-libs/libogg-1.0 )"
+RDEPEND="ogg? ( >=media-libs/libogg-1.0 )"
+
+DEPEND="${RDEPEND}
+ sys-devel/autoconf
+ sys-devel/automake
+ sys-devel/libtool"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # This is needed to fix parallel make issues.
+ # As this changes the Makefile.am, need to rebuild autotools.
+ sed -i -e 's:\$(top_builddir)/libspeex/libspeex.la:libspeex.la:' \
+ ${S}/libspeex/Makefile.am
+
+ eautoreconf
+
+ # Better being safe
+ elibtoolize
+}
src_compile() {
# ogg autodetect only