summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2005-09-16 01:29:59 +0000
committerBrandon Low <lostlogic@gentoo.org>2005-09-16 01:29:59 +0000
commit8d21ed04ae53340fe95a93142cc7f78595dad7b9 (patch)
tree094a4f10e7746abb8c60c5b9110541be9faa4aa3 /media-libs/libvorbis/libvorbis-1.1.1.ebuild
parentstable on x86 (diff)
downloadhistorical-8d21ed04ae53340fe95a93142cc7f78595dad7b9.tar.gz
historical-8d21ed04ae53340fe95a93142cc7f78595dad7b9.tar.bz2
historical-8d21ed04ae53340fe95a93142cc7f78595dad7b9.zip
Bump, see changelog for details
Package-Manager: portage-1.589-cvs
Diffstat (limited to 'media-libs/libvorbis/libvorbis-1.1.1.ebuild')
-rw-r--r--media-libs/libvorbis/libvorbis-1.1.1.ebuild88
1 files changed, 88 insertions, 0 deletions
diff --git a/media-libs/libvorbis/libvorbis-1.1.1.ebuild b/media-libs/libvorbis/libvorbis-1.1.1.ebuild
new file mode 100644
index 000000000000..5f6df5c3fed3
--- /dev/null
+++ b/media-libs/libvorbis/libvorbis-1.1.1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvorbis/libvorbis-1.1.1.ebuild,v 1.1 2005/09/16 01:29:59 lostlogic Exp $
+
+inherit libtool flag-o-matic eutils toolchain-funcs
+
+DESCRIPTION="the Ogg Vorbis sound file format library"
+HOMEPAGE="http://www.xiph.org/ogg/vorbis/index.html"
+SRC_URI="http://downloads.xiph.org/releases/vorbis/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=media-libs/libogg-1.0"
+DEPEND="${RDEPEND}
+ sys-apps/sed"
+
+S=${WORKDIR}/${P/_*/}
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+
+ # Fix a gcc crash. With the new atexit patch to gcc, it
+ # seems it does not handle -mno-ieee-fp very well.
+ sed -i -e "s:-mno-ieee-fp::g" configure
+
+ # Fixes some strange sed-, libtool- and ranlib-errors on
+ # Mac OS X
+ if use ppc-macos; then
+ glibtoolize
+ else
+ elibtoolize
+ fi
+
+ epunt_cxx #74493
+}
+
+src_compile() {
+ # Cannot compile with sse2 support it would seem #36104
+ use x86 && [ $(gcc-major-version) -eq 3 ] && append-flags -mno-sse2
+ [ "`gcc-version`" == "3.4" ] && replace-flags -Os -O2
+
+ # take out -fomit-frame-pointer from CFLAGS if k6-2
+ is-flag -march=k6-3 && filter-flags -fomit-frame-pointer
+ is-flag -march=k6-2 && filter-flags -fomit-frame-pointer
+ is-flag -march=k6 && filter-flags -fomit-frame-pointer
+
+ # over optimization causes horrible audio artifacts #26463
+ filter-flags -march=pentium?
+
+ # gcc-3.4 and k6 with -ftracer causes code generation problems #49472
+ if [ $(gcc-major-version) -eq 3 -a $(gcc-minor-version) -eq 4 ];
+ then
+ is-flag -march=k6* && filter-flags -ftracer
+ is-flag -mtune=k6* && filter-flags -ftracer
+ fi
+
+ # gcc on hppa causes issues when assembling
+ use hppa && replace-flags -march=2.0 -march=1.0
+
+ # Make prelink work properly
+ append-flags -fPIC
+ append-ldflags -fPIC
+
+ econf || die
+ use ppc-macos && cd ${S} && sed -i -e 's/examples//' Makefile
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ if use ppc-macos; then
+ dosym /usr/$(get_libdir)/libvorbisfile.3.1.0.dylib /usr/$(get_libdir)/libvorbisfile.3.dylib
+ dosym /usr/$(get_libdir)/libvorbisenc.2.0.1.dylib /usr/$(get_libdir)/libvorbisenc.2.dylib
+ else
+ dosym /usr/$(get_libdir)/libvorbisfile.so.3.1.0 /usr/$(get_libdir)/libvorbisfile.so.3
+ dosym /usr/$(get_libdir)/libvorbisenc.so.2.0.1 /usr/$(get_libdir)/libvorbisenc.so.2
+ fi
+
+ rm -rf ${D}/usr/share/doc
+ dodoc AUTHORS README todo.txt
+ docinto txt
+ dodoc doc/*.txt
+ dohtml -r doc
+}