summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2006-12-10 16:15:43 +0000
committerChristian Faulhammer <fauli@gentoo.org>2006-12-10 16:15:43 +0000
commita03513f73650c2ee09618dc84289faaa5671b22f (patch)
treee9b10433860cc4a476d482b667d504467362031c /media-libs/libvisual/libvisual-0.2.0.ebuild
parentStable on alpha as per security bug #156693 (diff)
downloadhistorical-a03513f73650c2ee09618dc84289faaa5671b22f.tar.gz
historical-a03513f73650c2ee09618dc84289faaa5671b22f.tar.bz2
historical-a03513f73650c2ee09618dc84289faaa5671b22f.zip
force MMX on x86, to fix bug #146335
Package-Manager: portage-2.1.1-r2
Diffstat (limited to 'media-libs/libvisual/libvisual-0.2.0.ebuild')
-rw-r--r--media-libs/libvisual/libvisual-0.2.0.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/media-libs/libvisual/libvisual-0.2.0.ebuild b/media-libs/libvisual/libvisual-0.2.0.ebuild
index 254ba890f805..fcf7f7ecc560 100644
--- a/media-libs/libvisual/libvisual-0.2.0.ebuild
+++ b/media-libs/libvisual/libvisual-0.2.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libvisual/libvisual-0.2.0.ebuild,v 1.9 2006/02/24 23:53:38 geoman Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvisual/libvisual-0.2.0.ebuild,v 1.10 2006/12/10 16:15:43 opfer Exp $
-inherit eutils
+inherit eutils flag-o-matic
DESCRIPTION="Libvisual is an abstraction library that comes between applications and audio visualisation plugins."
HOMEPAGE="http://libvisual.sourceforge.net/"
@@ -23,6 +23,8 @@ src_unpack() {
}
src_compile() {
+ # force MMX on x86 to fix compilation, see bug 146335
+ use x86 && append-flags -mmmx
econf $(use_enable static) || die
emake || die
}