summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-02 08:06:17 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-02 08:06:17 +0000
commit9eb20ce631346d8e929b303ed9b1cc308f04572a (patch)
tree27e1889454b5caf5cadaca1db67e95e5a60c963d /media-libs/libtheora/libtheora-1.0_alpha7.ebuild
parentadd freealut dep; fix wrapper (bug #149589) (diff)
downloadhistorical-9eb20ce631346d8e929b303ed9b1cc308f04572a.tar.gz
historical-9eb20ce631346d8e929b303ed9b1cc308f04572a.tar.bz2
historical-9eb20ce631346d8e929b303ed9b1cc308f04572a.zip
Version bump, hoping it works.
Package-Manager: portage-2.1.2_pre2-r1
Diffstat (limited to 'media-libs/libtheora/libtheora-1.0_alpha7.ebuild')
-rw-r--r--media-libs/libtheora/libtheora-1.0_alpha7.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/media-libs/libtheora/libtheora-1.0_alpha7.ebuild b/media-libs/libtheora/libtheora-1.0_alpha7.ebuild
new file mode 100644
index 000000000000..b6b1f152850f
--- /dev/null
+++ b/media-libs/libtheora/libtheora-1.0_alpha7.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/libtheora-1.0_alpha7.ebuild,v 1.1 2006/10/02 08:06:17 flameeyes Exp $
+
+inherit flag-o-matic libtool autotools
+
+DESCRIPTION="The Theora Video Compression Codec"
+HOMEPAGE="http://www.theora.org/"
+SRC_URI="http://downloads.xiph.org/releases/theora/${P/_}.tar.bz2"
+
+LICENSE="xiph"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~hppa ia64 mips ppc ~ppc-macos ppc64 sh sparc x86 ~x86-fbsd"
+IUSE="encode doc examples"
+
+RDEPEND=">=media-libs/libogg-1.1.0
+ encode? ( >=media-libs/libvorbis-1.0.1 )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+S=${WORKDIR}/${P/_}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e 's:SUBDIRS = .*:SUBDIRS = lib include doc:' Makefile.am
+
+ elibtoolize
+
+ if use examples; then
+ # This creates a clean copy of examples sources
+ cp -R "${S}/examples" "${WORKDIR}"
+ rm -f "${WORKDIR}/examples/Makefile"*
+ fi
+}
+
+src_compile() {
+ # bug #75403, -O3 needs to be filtered to -O2
+ replace-flags -O3 -O2
+
+ use doc || export ac_cv_prog_HAVE_DOXYGEN="false"
+
+ econf \
+ $(use_enable encode) \
+ --enable-shared \
+ --disable-dependency-tracking \
+ || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ docdir="usr/share/doc/${PF}" \
+ install || die "make install failed"
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/examples"
+ doins "${WORKDIR}/examples/"*
+ fi
+
+ dodoc README
+}