summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-23 02:20:28 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-23 02:20:28 +0000
commit10730266fbc82184b205a5faaf5915c018717e76 (patch)
tree2af504f918c5acca4c563467666764bad5f695fc /media-libs/libsdl
parentadded missing mpeg dependency check (diff)
downloadhistorical-10730266fbc82184b205a5faaf5915c018717e76.tar.gz
historical-10730266fbc82184b205a5faaf5915c018717e76.tar.bz2
historical-10730266fbc82184b205a5faaf5915c018717e76.zip
arts dependency changed from kdelibs to arts
Diffstat (limited to 'media-libs/libsdl')
-rw-r--r--media-libs/libsdl/ChangeLog10
-rw-r--r--media-libs/libsdl/files/digest-libsdl-1.2.4-r21
-rw-r--r--media-libs/libsdl/libsdl-1.2.4-r2.ebuild95
3 files changed, 105 insertions, 1 deletions
diff --git a/media-libs/libsdl/ChangeLog b/media-libs/libsdl/ChangeLog
index 5d86dbea9145..c62c4ea96e54 100644
--- a/media-libs/libsdl/ChangeLog
+++ b/media-libs/libsdl/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-libs/libsdl
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.5 2002/04/19 20:54:29 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.6 2002/04/23 02:20:28 seemant Exp $
+
+*libsdl-1.2.4-r1 (22 Apr 2002)
+
+ 22 Apr 2002; Seemant Kulleen <seemant@gentoo.org> libsdl-1.2.4-r2.ebuild :
+
+ naz in #gentoo pointed out that since kde3 is the default kde, arts
+ dependency can now be on kde-base/arts instead of kdelibs, which reduces
+ code bloat immensely.
*libsdl-1.2.4-r1 (19 Apr 2002)
diff --git a/media-libs/libsdl/files/digest-libsdl-1.2.4-r2 b/media-libs/libsdl/files/digest-libsdl-1.2.4-r2
new file mode 100644
index 000000000000..d7cf1782b39d
--- /dev/null
+++ b/media-libs/libsdl/files/digest-libsdl-1.2.4-r2
@@ -0,0 +1 @@
+MD5 116c083aad99faae691c6ca8dcdf406d SDL-1.2.4.tar.gz 1806163
diff --git a/media-libs/libsdl/libsdl-1.2.4-r2.ebuild b/media-libs/libsdl/libsdl-1.2.4-r2.ebuild
new file mode 100644
index 000000000000..21af2b451607
--- /dev/null
+++ b/media-libs/libsdl/libsdl-1.2.4-r2.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Seemant Kulleen <seemant@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.4-r2.ebuild,v 1.1 2002/04/23 02:20:28 seemant Exp $
+
+S=${WORKDIR}/SDL-${PV}
+DESCRIPTION="Simple Direct Media Layer"
+SRC_URI="http://www.libsdl.org/release/SDL-${PV}.tar.gz"
+HOMEPAGE="http://www.libsdl.org/"
+
+RDEPEND=">=media-libs/audiofile-0.1.9
+ X? ( virtual/x11 )
+ esd? ( >=media-sound/esound-0.2.19 )
+ ggi? ( >=media-libs/libggi-2.0_beta3 )
+ nas? ( media-libs/nas )
+ alsa? ( media-libs/alsa-lib )
+ arts? ( kde-base/arts )
+ svga? ( >=media-libs/svgalib-1.4.2 )
+ opengl? ( virtual/opengl )
+ directfb? ( >=dev-libs/DirectFB-0.9.7 )"
+
+DEPEND="${RDEPEND}
+ dev-lang/nasm"
+
+
+src_compile() {
+ local myconf
+
+ use X \
+ && myconf="${myconf} --enable-video-x11" \
+ || myconf="${myconf} --disable-video-x11"
+
+ use xv \
+ && myconf="${myconf} --enable-video-x11-xv" \
+ || myconf="${myconf} --disable-video-x11-xv"
+
+ use esd \
+ && myconf="--enable-esd" \
+ || myconf="--disable-esd"
+
+ use ggi \
+ && myconf="${myconf} --enable-video-ggi" \
+ || myconf="${myconf} --disable-video-ggi"
+
+ use nas \
+ && myconf="${myconf} --enable-nas" \
+ || myconf="${myconf} --disable-nas"
+
+ use alsa \
+ && myconf="${myconf} --enable-alsa" \
+ || myconf="${myconf} --disable-alsa"
+
+ use arts \
+ && myconf="${myconf} --enable-arts" \
+ || myconf="${myconf} --disable-arts"
+
+ use svga \
+ && myconf="${myconf} --enable-video-svga" \
+ || myconf="${myconf} --disable-video-svga"
+
+ use aalib \
+ && myconf="${myconf} --enable-video-aalib" \
+ || myconf="${myconf} --disable-video-aalib"
+
+ use fbcon \
+ && myconf="${myconf} --enable-video-fbcon" \
+ || myconf="${myconf} --disable-video-fbcon"
+
+ use opengl \
+ && myconf="${myconf} --enable-video-opengl" \
+ || myconf="${myconf} --disable-video-opengl"
+
+ use directfb \
+ && myconf="${myconf} --enable-video-directfb" \
+ || myconf="${myconf} --disable-video-directfb"
+
+ ./configure \
+ --host=${CHOST} \
+ --enable-input-events \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ make \
+ DESTDIR=${D} \
+ install || die
+
+ preplib /usr
+ dodoc BUGS COPYING CREDITS README* TODO WhatsNew
+ dohtml -r ./
+}