summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-11-04 02:40:41 +0000
committerMike Frysinger <vapier@gentoo.org>2003-11-04 02:40:41 +0000
commitb353beb5c2c10a7707730ea6b26aa591d9c3a702 (patch)
treecdb4e1eae51aa144c6e1c7ed87f4a3387ea0c7bd /media-libs/libmpeg3/files
parentAdded ~sparc keyword. (diff)
downloadhistorical-b353beb5c2c10a7707730ea6b26aa591d9c3a702.tar.gz
historical-b353beb5c2c10a7707730ea6b26aa591d9c3a702.tar.bz2
historical-b353beb5c2c10a7707730ea6b26aa591d9c3a702.zip
a52 fixes #32533
Diffstat (limited to 'media-libs/libmpeg3/files')
-rw-r--r--media-libs/libmpeg3/files/1.5.2-gentoo-mpeg3split.patch61
-rw-r--r--media-libs/libmpeg3/files/1.5.2-gentoo-p1.patch53
-rw-r--r--media-libs/libmpeg3/files/1.5.2-gentoo-p2.patch119
-rw-r--r--media-libs/libmpeg3/files/1.5.2-largefile.patch11
-rw-r--r--media-libs/libmpeg3/files/1.5.2-proper-c.patch13
-rw-r--r--media-libs/libmpeg3/files/1.5.2-pthread.patch11
-rw-r--r--media-libs/libmpeg3/files/digest-libmpeg3-1.5.21
7 files changed, 269 insertions, 0 deletions
diff --git a/media-libs/libmpeg3/files/1.5.2-gentoo-mpeg3split.patch b/media-libs/libmpeg3/files/1.5.2-gentoo-mpeg3split.patch
new file mode 100644
index 000000000000..5412b61ee6a6
--- /dev/null
+++ b/media-libs/libmpeg3/files/1.5.2-gentoo-mpeg3split.patch
@@ -0,0 +1,61 @@
+--- Makefile.orig 2003-11-03 21:31:31.154535784 -0500
++++ Makefile 2003-11-03 21:32:32.385227304 -0500
+@@ -138,9 +138,8 @@
+
+
+ OUTPUT = $(OBJDIR)/libmpeg3.a
+-UTILS = $(OBJDIR)/mpeg3dump $(OBJDIR)/mpeg3toc $(OBJDIR)/mpeg3cat
+-
+-#$(OBJDIR)/mpeg3split
++SHAREDOUTPUT = $(OBJDIR)/libmpeg3.so
++UTILS = $(OBJDIR)/mpeg3dump $(OBJDIR)/mpeg3toc $(OBJDIR)/mpeg3cat $(OBJDIR)/mpeg3split
+
+
+ LIBS = -lm -lpthread
+@@ -152,13 +151,14 @@
+ $(shell echo $(OBJS) $(ASMOBJS) $(A52OBJS) $(NASMOBJS) > $(OBJDIR)/objs)
+ $(shell mkdir -p $(DIRS) )
+
+-all: $(OUTPUT) $(UTILS)
++all: $(OUTPUT) $(SHAREDOUTPUT) $(UTILS)
+
+
+ $(OUTPUT): $(OBJS) $(ASMOBJS) $(NASMOBJS) $(A52OBJS)
+ ar rcs $(OUTPUT) `cat $(OBJDIR)/objs`
+
+-
++$(SHAREDOUTPUT): $(OBJS) $(ASMOBJS) $(NASMOBJS)
++ gcc -shared -o $(SHAREDOUTPUT) $(OBJS) $(ASMOBJS) $(NASMOBJS) $(LIBS)
+
+ $(OBJDIR)/mpeg3dump: $(OUTPUT) mpeg3dump.c
+ $(CC) `cat $(OBJDIR)/c_flags` -o $(OBJDIR)/mpeg3dump mpeg3dump.c $(OUTPUT) $(LIBS)
+@@ -169,8 +169,8 @@
+ $(OBJDIR)/mpeg3cat: $(OUTPUT) mpeg3cat.c
+ $(CC) `cat $(OBJDIR)/c_flags` -o $(OBJDIR)/mpeg3cat mpeg3cat.c $(OUTPUT) $(LIBS)
+
+-#$(OBJDIR)/mpeg3split: $(OUTPUT)
+-# $(CC) `cat $(OBJDIR)/c_flags` -o $(OBJDIR)/mpeg3split mpeg3split.c $(OUTPUT) $(LIBS)
++$(OBJDIR)/mpeg3split: $(OUTPUT)
++ $(CC) `cat $(OBJDIR)/c_flags` -o $(OBJDIR)/mpeg3split mpeg3split.c $(OUTPUT) $(LIBS)
+
+ $(OBJDIR)/mpeg2qt: $(OUTPUT)
+ $(CC) `cat $(OBJDIR)/c_flags` -o $(OBJDIR)/mpeg2qt mpeg2qt.c \
+@@ -213,7 +213,7 @@
+ $(OBJDIR)/mpeg3demux.o: mpeg3demux.c
+ $(OBJDIR)/mpeg3ifo.o: mpeg3ifo.c
+ $(OBJDIR)/mpeg3io.o: mpeg3io.c
+-#$(OBJDIR)/mpeg3split.o: mpeg3split.c
++$(OBJDIR)/mpeg3split.o: mpeg3split.c
+ $(OBJDIR)/mpeg3title.o: mpeg3title.c
+ $(OBJDIR)/mpeg3toc.o: mpeg3toc.c
+ $(OBJDIR)/mpeg3toc3.o: mpeg3toc3.c
+--- mpeg3split.c.orig 2003-11-03 21:33:17.923304464 -0500
++++ mpeg3split.c 2003-11-03 21:33:36.419492616 -0500
+@@ -2,6 +2,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+
++#include "mpeg3private.h"
+ #include "mpeg3private.inc"
+
+ void copy_data(FILE *out, FILE *in, long bytes)
diff --git a/media-libs/libmpeg3/files/1.5.2-gentoo-p1.patch b/media-libs/libmpeg3/files/1.5.2-gentoo-p1.patch
new file mode 100644
index 000000000000..5a9013c6361e
--- /dev/null
+++ b/media-libs/libmpeg3/files/1.5.2-gentoo-p1.patch
@@ -0,0 +1,53 @@
+diff -urN libmpeg3.orig/Makefile libmpeg3/Makefile
+--- libmpeg3.orig/Makefile Wed Dec 26 07:40:52 2001
++++ libmpeg3/Makefile Mon Apr 15 13:54:22 2002
+@@ -105,6 +105,30 @@
+ $(OBJDIR)/video/vlc.o \
+ $(OBJDIR)/workarounds.o
+
++INSTALL_HEADERS = \
++ bitstream.h \
++ libmpeg3.h \
++ mpeg3atrack.h \
++ mpeg3css.h \
++ mpeg3demux.h \
++ mpeg3io.h \
++ mpeg3private.h \
++ mpeg3private.inc \
++ mpeg3protos.h \
++ mpeg3title.h \
++ mpeg3vtrack.h \
++ timecode.h \
++
++INSTALL_AHEADERS = \
++ audio/ac3.h \
++ audio/mpeg3audio.h \
++
++INSTALL_VHEADERS = \
++ video/idct.h \
++ video/slice.h \
++ video/mpeg3video.h
++
++
+ OUTPUT = $(OBJDIR)/libmpeg3.a
+ SHAREDOUTPUT = $(OBJDIR)/libmpeg3.so
+ UTILS = $(OBJDIR)/mpeg3dump $(OBJDIR)/mpeg3cat $(OBJDIR)/mpeg3toc $(OBJDIR)/mpeg3split
+@@ -148,7 +171,17 @@
+ util: $(UTILS)
+
+ install:
+- cp $(UTILS) /usr/bin
++ install -d $(DESTDIR)/bin
++ install -d $(DESTDIR)/include/libmpeg3
++ install -d $(DESTDIR)/include/libmpeg3/audio
++ install -d $(DESTDIR)/include/libmpeg3/video
++ install -d $(DESTDIR)/lib
++ install $(UTILS) $(DESTDIR)/bin
++ install -m 644 $(INSTALL_HEADERS) $(DESTDIR)/include/libmpeg3
++ install -m 644 $(INSTALL_AHEADERS) $(DESTDIR)/include/libmpeg3/audio
++ install -m 644 $(INSTALL_VHEADERS) $(DESTDIR)/include/libmpeg3/video
++ install -m 644 $(OUTPUT) $(DESTDIR)/lib
++ install -m 644 $(SHAREDOUTPUT) $(DESTDIR)/lib
+
+ clean:
+ rm -rf $(OBJDIR)
diff --git a/media-libs/libmpeg3/files/1.5.2-gentoo-p2.patch b/media-libs/libmpeg3/files/1.5.2-gentoo-p2.patch
new file mode 100644
index 000000000000..18e66dcca01b
--- /dev/null
+++ b/media-libs/libmpeg3/files/1.5.2-gentoo-p2.patch
@@ -0,0 +1,119 @@
+diff -urN libmpeg3.orig/bitstream.h libmpeg3/bitstream.h
+--- libmpeg3.orig/bitstream.h Fri Dec 21 14:00:01 2001
++++ libmpeg3/bitstream.h Mon Apr 15 14:13:12 2002
+@@ -1,7 +1,7 @@
+ #ifndef BITSTREAM_H
+ #define BITSTREAM_H
+
+-#include "mpeg3demux.h"
++#include <libmpeg3/mpeg3demux.h>
+ #include <sys/types.h>
+
+ // next bit in forward direction
+diff -urN libmpeg3.orig/libmpeg3.h libmpeg3/libmpeg3.h
+--- libmpeg3.orig/libmpeg3.h Fri Dec 21 10:48:14 2001
++++ libmpeg3/libmpeg3.h Mon Apr 15 14:13:12 2002
+@@ -5,7 +5,7 @@
+ extern "C" {
+ #endif
+
+-#include "mpeg3private.h"
++#include <libmpeg3/mpeg3private.h>
+
+
+ /* Supported color models for mpeg3_read_frame */
+diff -urN libmpeg3.orig/mpeg3css.h libmpeg3/mpeg3css.h
+--- libmpeg3.orig/mpeg3css.h Sun Sep 30 20:18:31 2001
++++ libmpeg3/mpeg3css.h Mon Apr 15 14:13:12 2002
+@@ -2,7 +2,7 @@
+ #define MPEG3CSS_H
+
+
+-#include "mpeg3private.inc"
++#include <libmpeg3/mpeg3private.inc>
+
+ struct mpeg3_block
+ {
+diff -urN libmpeg3.orig/mpeg3demux.h libmpeg3/mpeg3demux.h
+--- libmpeg3.orig/mpeg3demux.h Fri Dec 21 14:02:21 2001
++++ libmpeg3/mpeg3demux.h Mon Apr 15 14:13:12 2002
+@@ -1,7 +1,7 @@
+ #ifndef MPEG3DEMUX_H
+ #define MPEG3DEMUX_H
+
+-#include "mpeg3title.h"
++#include <libmpeg3/mpeg3title.h>
+ #include <stdio.h>
+
+ typedef struct
+diff -urN libmpeg3.orig/mpeg3io.h libmpeg3/mpeg3io.h
+--- libmpeg3.orig/mpeg3io.h Mon Dec 17 06:05:07 2001
++++ libmpeg3/mpeg3io.h Mon Apr 15 14:13:12 2002
+@@ -4,8 +4,8 @@
+
+ #include <stdio.h>
+ #include <stdint.h>
+-#include "mpeg3css.h"
+-#include "mpeg3private.inc"
++#include <libmpeg3/mpeg3css.h>
++#include <libmpeg3/mpeg3private.inc>
+
+ /* Filesystem structure */
+ /* We buffer in MPEG3_IO_SIZE buffers. Stream IO would require back */
+diff -urN libmpeg3.orig/mpeg3title.h libmpeg3/mpeg3title.h
+--- libmpeg3.orig/mpeg3title.h Wed Dec 19 06:28:25 2001
++++ libmpeg3/mpeg3title.h Mon Apr 15 14:13:12 2002
+@@ -1,7 +1,7 @@
+ #ifndef MPEG3TITLE_H
+ #define MPEG3TITLE_H
+
+-#include "mpeg3io.h"
++#include <libmpeg3/mpeg3io.h>
+
+ // May get rid of time values and rename to a cell offset table.
+ // May also get rid of end byte.
+diff -urN libmpeg3.orig/mpeg3vtrack.h libmpeg3/mpeg3vtrack.h
+--- libmpeg3.orig/mpeg3vtrack.h Thu Dec 20 08:19:18 2001
++++ libmpeg3/mpeg3vtrack.h Mon Apr 15 14:13:12 2002
+@@ -1,8 +1,8 @@
+ #ifndef MPEG3_VTRACK_H
+ #define MPEG3_VTRACK_H
+
+-#include "mpeg3demux.h"
+-#include "video/mpeg3video.h"
++#include <libmpeg3/mpeg3demux.h>
++#include <libmpeg3/video/mpeg3video.h>
+
+ typedef struct
+ {
+diff -urN libmpeg3.orig/video/mpeg3video.h libmpeg3/video/mpeg3video.h
+--- libmpeg3.orig/video/mpeg3video.h Sun Sep 30 20:18:31 2001
++++ libmpeg3/video/mpeg3video.h Mon Apr 15 14:13:12 2002
+@@ -1,9 +1,9 @@
+ #ifndef MPEGVIDEO_H
+ #define MPEGVIDEO_H
+
+-#include "../bitstream.h"
+-#include "../mpeg3private.inc"
+-#include "idct.h"
+-#include "slice.h"
+-#include "../timecode.h"
++#include <libmpeg3/bitstream.h>
++#include <libmpeg3/mpeg3private.inc>
++#include <libmpeg3/video/idct.h>
++#include <libmpeg3/video/slice.h>
++#include <libmpeg3/timecode.h>
+ #endif
+diff -urN libmpeg3.orig/mpeg3atrack.h libmpeg3/atrack.h
+--- libmpeg3.orig/mpeg3atrack.h 2003-07-26 17:31:58.000000000 -0400
++++ libmpeg3/mpeg3atrack.h 2003-07-26 17:32:27.000000000 -0400
+@@ -1,7 +1,7 @@
+ #ifndef MPEG3ATRACK_H
+ #define MPEG3ATRACK_H
+
+-#include "mpeg3demux.h"
+-#include "audio/mpeg3audio.h"
++#include <libmpeg3/mpeg3demux.h>
++#include <libmpeg3/audio/mpeg3audio.h>
+
+ #endif
diff --git a/media-libs/libmpeg3/files/1.5.2-largefile.patch b/media-libs/libmpeg3/files/1.5.2-largefile.patch
new file mode 100644
index 000000000000..229349115712
--- /dev/null
+++ b/media-libs/libmpeg3/files/1.5.2-largefile.patch
@@ -0,0 +1,11 @@
+--- Makefile.orig 2002-06-21 08:35:24.000000000 -0400
++++ Makefile 2003-07-28 09:15:44.000000000 -0400
+@@ -33,7 +33,7 @@
+
+
+ ifeq ($(USE_CSS), 1)
+- CFLAGS += -DHAVE_CSS
++ CFLAGS += -DHAVE_CSS -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
+ endif
+
+ ifeq ($(USE_MMX), 1)
diff --git a/media-libs/libmpeg3/files/1.5.2-proper-c.patch b/media-libs/libmpeg3/files/1.5.2-proper-c.patch
new file mode 100644
index 000000000000..135dfb633562
--- /dev/null
+++ b/media-libs/libmpeg3/files/1.5.2-proper-c.patch
@@ -0,0 +1,13 @@
+--- mpeg3toc.c.orig 2003-07-28 09:04:05.000000000 -0400
++++ mpeg3toc.c 2003-07-28 09:06:26.000000000 -0400
+@@ -196,9 +196,9 @@
+ if(!mpeg3_end_of_audio(input, j))
+ {
+ // Don't want to maintain separate vectors for offset and title.
+- title_number = mpeg3demux_tell_title(input->atrack[j]->demuxer);
+ int64_t position = mpeg3demux_tell(input->atrack[j]->demuxer);
+ int64_t result;
++ title_number = mpeg3demux_tell_title(input->atrack[j]->demuxer);
+ if(position < MPEG3_IO_SIZE) position = MPEG3_IO_SIZE;
+ result = (title_number << 56) | (position - MPEG3_IO_SIZE);
+
diff --git a/media-libs/libmpeg3/files/1.5.2-pthread.patch b/media-libs/libmpeg3/files/1.5.2-pthread.patch
new file mode 100644
index 000000000000..2adeed9bab8c
--- /dev/null
+++ b/media-libs/libmpeg3/files/1.5.2-pthread.patch
@@ -0,0 +1,11 @@
+--- mpeg3private.h.orig 2003-07-26 17:18:33.000000000 -0400
++++ mpeg3private.h 2003-07-26 17:18:40.000000000 -0400
+@@ -3,7 +3,7 @@
+
+ #include <stdint.h>
+ #include <stdio.h>
+-
++#include <pthread.h>
+
+
+
diff --git a/media-libs/libmpeg3/files/digest-libmpeg3-1.5.2 b/media-libs/libmpeg3/files/digest-libmpeg3-1.5.2
new file mode 100644
index 000000000000..f02917ce1539
--- /dev/null
+++ b/media-libs/libmpeg3/files/digest-libmpeg3-1.5.2
@@ -0,0 +1 @@
+MD5 d2b12624e8e2eed1a03c4f837f33a90f libmpeg3-1.5.2-src.tar.bz2 625682