summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe McCann <joem@gentoo.org>2005-11-29 04:58:11 +0000
committerJoe McCann <joem@gentoo.org>2005-11-29 04:58:11 +0000
commit04a17bee5e2bafd624858441c14ed48aca568cd8 (patch)
tree639b731a258cf970e42ee9d7102064505293c2f1 /media-libs/libgpod
parentAdded note about bug #112924 for the ModulePath removal decision. (diff)
downloadhistorical-04a17bee5e2bafd624858441c14ed48aca568cd8.tar.gz
historical-04a17bee5e2bafd624858441c14ed48aca568cd8.tar.bz2
historical-04a17bee5e2bafd624858441c14ed48aca568cd8.zip
eject dep
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'media-libs/libgpod')
-rw-r--r--media-libs/libgpod/ChangeLog5
-rw-r--r--media-libs/libgpod/Manifest4
-rw-r--r--media-libs/libgpod/libgpod-0.2.0.ebuild30
3 files changed, 32 insertions, 7 deletions
diff --git a/media-libs/libgpod/ChangeLog b/media-libs/libgpod/ChangeLog
index 6065906b8c99..8e4d137dfe9c 100644
--- a/media-libs/libgpod/ChangeLog
+++ b/media-libs/libgpod/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-libs/libgpod
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/ChangeLog,v 1.1 2005/11/29 03:10:22 joem Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/ChangeLog,v 1.2 2005/11/29 04:58:11 joem Exp $
+
+ 29 Nov 2005; Joe McCann <joem@gentoo.org> libgpod-0.2.0.ebuild:
+ Add sys-apps/eject app thanks to Spider
*libgpod-0.2.0 (29 Nov 2005)
diff --git a/media-libs/libgpod/Manifest b/media-libs/libgpod/Manifest
index 09774844e66f..c15f32cabcb4 100644
--- a/media-libs/libgpod/Manifest
+++ b/media-libs/libgpod/Manifest
@@ -1,4 +1,4 @@
-MD5 784d018e09a5cbe7bafc1249a21f7380 ChangeLog 381
+MD5 54ff1cef0e50c4f287c9b0df26e65058 ChangeLog 490
MD5 f263da0a6f7b7b2e32a4031f225b0931 files/digest-libgpod-0.2.0 65
-MD5 3d64bd5b8380ad50efcdf1f3c6476897 libgpod-0.2.0.ebuild 883
+MD5 02a8ec4013aeb130d80de858dfa895b9 libgpod-0.2.0.ebuild 1324
MD5 263e238ad2d029ebbee2e5ac213942fe metadata.xml 417
diff --git a/media-libs/libgpod/libgpod-0.2.0.ebuild b/media-libs/libgpod/libgpod-0.2.0.ebuild
index 5273b9d73e69..792b23e217ef 100644
--- a/media-libs/libgpod/libgpod-0.2.0.ebuild
+++ b/media-libs/libgpod/libgpod-0.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/libgpod-0.2.0.ebuild,v 1.1 2005/11/29 03:10:22 joem Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/libgpod-0.2.0.ebuild,v 1.2 2005/11/29 04:58:11 joem Exp $
DESCRIPTION="Shared library to access the contents of an iPod"
HOMEPAGE="http://www.gtkpod.org/libgpod.html"
@@ -15,14 +15,36 @@ RDEPEND=">=dev-libs/glib-2.4
gtk? ( >=x11-libs/gtk+-2 )
hal? ( >=sys-apps/dbus-0.5.2
>=sys-apps/hal-0.5
- >=sys-apps/pmount-0.9.6 )"
+ >=sys-apps/pmount-0.9.6 )
+ sys-apps/eject"
DEPEND="${RDEPEND}
>=dev-util/intltool-0.2.9"
+pkg_setup() {
+ local myconf=""
+ if use hal ; then
+ myconf="${myconf} --with-eject-comand=/usr/bin/eject \
+ --with-unmount-command=/usr/bin/pmount"
+ else
+ myconf="${myconf} --with-eject-command=/usr/bin/eject \
+ --with-unmount-command=/bin/umount"
+ fi
+
+}
src_compile() {
+
+ local myconf=""
+ if use hal ; then
+ myconf="${myconf} --with-eject-comand=/usr/bin/eject \
+ --with-unmount-command=/usr/bin/pumount"
+ else
+ myconf="${myconf}
+ --with-eject-command=/usr/bin/eject \
+ --with-unmount-command=/bin/umount"
+ fi
+
econf \
- $(use_with hal eject-command /usr/bin/eject) \
- $(use_with hal unmount-command /usr/bin/pumount) \
+ ${myconf} \
|| die "configure failed"
emake || die "make failed"
}