summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2009-04-26 16:02:08 +0000
committerOlivier Crête <tester@gentoo.org>2009-04-26 16:02:08 +0000
commitc4f869ac3b89c58054d4762b1e6c791cf48f49f1 (patch)
treee77ee56a801876e2a0b3424159070c83a80db759 /media-libs/libgpod/libgpod-0.7.2.ebuild
parentstable amd64/sparc, bug 267439 (diff)
downloadhistorical-c4f869ac3b89c58054d4762b1e6c791cf48f49f1.tar.gz
historical-c4f869ac3b89c58054d4762b1e6c791cf48f49f1.tar.bz2
historical-c4f869ac3b89c58054d4762b1e6c791cf48f49f1.zip
Version bump, always require hal (it does not build without it), recommend GTK+ (for artwork support)
Package-Manager: portage-2.1.6.7/cvs/Linux x86_64
Diffstat (limited to 'media-libs/libgpod/libgpod-0.7.2.ebuild')
-rw-r--r--media-libs/libgpod/libgpod-0.7.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-libs/libgpod/libgpod-0.7.2.ebuild b/media-libs/libgpod/libgpod-0.7.2.ebuild
new file mode 100644
index 000000000000..07d9922e5815
--- /dev/null
+++ b/media-libs/libgpod/libgpod-0.7.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/libgpod-0.7.2.ebuild,v 1.1 2009/04/26 16:02:08 tester Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Shared library to access the contents of an iPod"
+HOMEPAGE="http://www.gtkpod.org/libgpod.html"
+SRC_URI="mirror://sourceforge/gtkpod/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+gtk python test"
+
+RDEPEND=">=dev-libs/glib-2.16
+ sys-apps/sg3_utils
+ dev-libs/libxml2
+ =sys-apps/hal-0.5*
+ gtk? ( >=x11-libs/gtk+-2.6 )
+ python? ( >=dev-lang/python-2.3
+ >=media-libs/mutagen-1.8
+ >=dev-python/pygobject-2.8 )
+ test? ( media-libs/taglib )"
+DEPEND="${RDEPEND}
+ python? ( >=dev-lang/swig-1.3.24 )
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ --with-hal \
+ $(use_enable gtk gdk-pixbuf) \
+ $(use_enable python pygobject) \
+ $(use_with python) || die "configure failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc README TROUBLESHOOTING AUTHORS NEWS README.SysInfo
+}