summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-11 12:58:50 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-11 12:58:50 +0000
commitf0ca2fcd7fe801308829bc602cc68294079778b3 (patch)
treec5a0497a9f1174d3be26cf38bfd7da3d9c699c02 /media-libs/fontconfig
parentStable on alpha. (diff)
downloadhistorical-f0ca2fcd7fe801308829bc602cc68294079778b3.tar.gz
historical-f0ca2fcd7fe801308829bc602cc68294079778b3.tar.bz2
historical-f0ca2fcd7fe801308829bc602cc68294079778b3.zip
dont access $CC
Diffstat (limited to 'media-libs/fontconfig')
-rw-r--r--media-libs/fontconfig/Manifest18
-rw-r--r--media-libs/fontconfig/fontconfig-2.1-r1.ebuild25
-rw-r--r--media-libs/fontconfig/fontconfig-2.2.1.ebuild35
-rw-r--r--media-libs/fontconfig/fontconfig-2.2.2.ebuild19
4 files changed, 41 insertions, 56 deletions
diff --git a/media-libs/fontconfig/Manifest b/media-libs/fontconfig/Manifest
index 25238f662a69..ea751693a105 100644
--- a/media-libs/fontconfig/Manifest
+++ b/media-libs/fontconfig/Manifest
@@ -1,7 +1,10 @@
-MD5 4898850c8bd03fa4d5928545b005ff96 ChangeLog 7837
-MD5 c05cccfb182ab78707d61f65158ce764 fontconfig-2.1-r1.ebuild 2674
-MD5 2c446e637ed1fa6c2a41d1dd6dd8bd08 fontconfig-2.2.1.ebuild 3149
-MD5 ac45dc6a58349d778a559e4caea0754e fontconfig-2.2.2.ebuild 2867
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 25ab66787ddb03f37c53064001e8bffb ChangeLog 7838
+MD5 40d7bdb66fe2be1b0536d91b0edb080b fontconfig-2.1-r1.ebuild 2559
+MD5 e640a625308991c2710ae19521c21fa1 fontconfig-2.2.1.ebuild 2718
+MD5 c352f09586fd5f75b3c7d53bd8d1e1b3 fontconfig-2.2.2.ebuild 2768
MD5 ae7171ca850597a2455b8b10c72a8de1 metadata.xml 419
MD5 fd11506a1969709b4d447084344006ba files/digest-fontconfig-2.1-r1 140
MD5 88bdeed6518b90c6230b5ea155936c8f files/digest-fontconfig-2.2.1 68
@@ -10,3 +13,10 @@ MD5 37e60cdff43bf3f04e9db8931e0d1f47 files/patch/fontconfig-2.1-slighthint.patch
MD5 1636083efd15746d8f194aff41aa6e02 files/patch/fontconfig-2.2-blacklist.patch 1216
MD5 4b5453071b61ecef4bb530b0bca695e1 files/patch/fontconfig-2.2-local_fontdir-r1.patch 487
MD5 4d77167b56a7dff0d7c7b5b8168b85ba files/patch/fontconfig-2.2-remove_subpixel_test.patch 441
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.9.8 (GNU/Linux)
+
+iD8DBQFAyayUHTu7gpaalycRAl4EAKCSSTjXif/Jdo7FdPLGUjVlKS9CtgCg7boi
+mFJ4MWz2mlTQ1mFzZur1U3M=
+=pG9s
+-----END PGP SIGNATURE-----
diff --git a/media-libs/fontconfig/fontconfig-2.1-r1.ebuild b/media-libs/fontconfig/fontconfig-2.1-r1.ebuild
index c13997381c83..c1b171e39993 100644
--- a/media-libs/fontconfig/fontconfig-2.1-r1.ebuild
+++ b/media-libs/fontconfig/fontconfig-2.1-r1.ebuild
@@ -1,27 +1,27 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/fontconfig-2.1-r1.ebuild,v 1.22 2004/06/03 05:05:10 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/fontconfig-2.1-r1.ebuild,v 1.23 2004/06/11 12:58:50 vapier Exp $
-inherit debug eutils
+inherit debug eutils gcc
S="${WORKDIR}/fcpackage.${PV/\./_}/fontconfig"
-DESCRIPTION="A library for configuring and customizing font access."
+DESCRIPTION="A library for configuring and customizing font access"
HOMEPAGE="http://freedesktop.org/"
SRC_URI="http://pdx.freedesktop.org/software/fontconfig/releases/fcpackage.${PV/\./_}.tar.gz"
LICENSE="fontconfig"
SLOT="1.0"
-KEYWORDS="x86 alpha ppc sparc mips hppa amd64"
+KEYWORDS="x86 ppc sparc mips alpha hppa amd64"
+IUSE=""
# Seems like patches in freetype-2.1.2-r2 fixes bug #10028
DEPEND=">=media-libs/freetype-2.1.2-r2
>=dev-libs/expat-1.95.3
>=sys-apps/ed-0.2"
-
fc_setup() {
# Do not use 'cc' to compile
- [ ! -n "${CC}" ] && export CC="gcc" || :
+ export CC="$(gcc-getCC)"
}
src_unpack() {
@@ -69,15 +69,10 @@ src_install() {
cd ${S}
- mv fc-cache/fc-cache.man fc-cache/fc-cache.1
- mv fc-list/fc-list.man fc-list/fc-list.1
- mv src/fontconfig.man src/fontconfig.3
- for x in fc-cache/fc-cache.1 fc-list/fc-list.1 src/fontconfig.3
- do
- doman ${x}
- done
-
- dodoc AUTHORS COPYING ChangeLog NEWS README
+ newman fc-cache/fc-cache.man fc-cache.1
+ newman fc-list/fc-list.man fc-list.1
+ newman src/fontconfig.man fontconfig.3
+ dodoc AUTHORS ChangeLog NEWS README
}
pkg_postinst() {
diff --git a/media-libs/fontconfig/fontconfig-2.2.1.ebuild b/media-libs/fontconfig/fontconfig-2.2.1.ebuild
index 82f4b207cf6d..00a9ab9ac9e9 100644
--- a/media-libs/fontconfig/fontconfig-2.2.1.ebuild
+++ b/media-libs/fontconfig/fontconfig-2.2.1.ebuild
@@ -1,32 +1,23 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/fontconfig-2.2.1.ebuild,v 1.16 2004/06/02 12:44:03 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/fontconfig-2.2.1.ebuild,v 1.17 2004/06/11 12:58:50 vapier Exp $
-inherit eutils
+inherit eutils gcc
-S=${WORKDIR}/${P}
-DESCRIPTION="A library for configuring and customizing font access."
+DESCRIPTION="A library for configuring and customizing font access"
HOMEPAGE="http://freedesktop.org/Software/fontconfig"
SRC_URI="http://pdx.freedesktop.org/software/fontconfig/releases/${P}.tar.gz"
-IUSE=""
LICENSE="fontconfig"
SLOT="1.0"
-
-# Note about keywords here:
-# >=kde-base/kdebase-3.1.2 has a fix needed to work with fontconfig 2.2 and higher,
-# so don't mark this ebuild stable on archs where kde 3.1.2 is only ~.
-# this of course doesn't apply to archs where kde has no keywords at all :-)
-# -- danarmak@gentoo.org
-KEYWORDS="x86 alpha ppc sparc ~mips hppa ia64 amd64 ppc64"
+KEYWORDS="x86 ppc sparc ~mips alpha hppa amd64 ia64 ppc64"
+IUSE=""
DEPEND=">=sys-apps/sed-4
>=media-libs/freetype-2.1.4
>=dev-libs/expat-1.95.3
>=sys-apps/ed-0.2"
-MAKEOPTS="${MAKEOPTS} -j1"
-
src_unpack() {
unpack ${A}
cd ${S}
@@ -47,7 +38,6 @@ src_unpack() {
}
src_compile() {
-
[ "${ARCH}" == "alpha" -a "${CC}" == "ccc" ] && \
die "Dont compile fontconfig with ccc, it doesnt work very well"
@@ -61,7 +51,7 @@ src_compile() {
# this triggers sandbox, we do this ourselves
sed -i "s:fc-cache/fc-cache -f -v:sleep 0:" Makefile
- emake || die
+ emake -j1 || die
# remove Luxi TTF fonts from the list, the Type1 are much better
sed -i "s:<dir>/usr/X11R6/lib/X11/fonts/TTF</dir>::" fonts.conf
@@ -78,15 +68,10 @@ src_install() {
cd ${S}
- mv fc-cache/fc-cache.man fc-cache/fc-cache.1
- mv fc-list/fc-list.man fc-list/fc-list.1
- mv src/fontconfig.man src/fontconfig.3
- for x in fc-cache/fc-cache.1 fc-list/fc-list.1 src/fontconfig.3
- do
- doman ${x}
- done
-
- dodoc AUTHORS COPYING ChangeLog NEWS README
+ newman fc-cache/fc-cache.man fc-cache.1
+ newman fc-list/fc-list.man fc-list.1
+ newman src/fontconfig.man fontconfig.3
+ dodoc AUTHORS ChangeLog NEWS README
}
pkg_postinst() {
diff --git a/media-libs/fontconfig/fontconfig-2.2.2.ebuild b/media-libs/fontconfig/fontconfig-2.2.2.ebuild
index 6e70de468b25..fc7e64c249aa 100644
--- a/media-libs/fontconfig/fontconfig-2.2.2.ebuild
+++ b/media-libs/fontconfig/fontconfig-2.2.2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/fontconfig-2.2.2.ebuild,v 1.5 2004/06/02 12:44:03 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/fontconfig-2.2.2.ebuild,v 1.6 2004/06/11 12:58:50 vapier Exp $
inherit eutils
-DESCRIPTION="A library for configuring and customizing font access."
+DESCRIPTION="A library for configuring and customizing font access"
HOMEPAGE="http://freedesktop.org/Software/fontconfig"
#SRC_URI="http://pdx.freedesktop.org/software/fontconfig/releases/${P}.tar.gz"
SRC_URI="http://freedesktop.org/~fontconfig/release/${P}.tar.gz"
@@ -12,13 +12,13 @@ SRC_URI="http://freedesktop.org/~fontconfig/release/${P}.tar.gz"
LICENSE="fontconfig"
SLOT="1.0"
KEYWORDS="x86 ~ppc ~sparc ~mips ~alpha arm hppa amd64 ~ia64 ~ppc64"
+IUSE=""
DEPEND=">=sys-apps/sed-4
>=media-libs/freetype-2.1.4
>=dev-libs/expat-1.95.3"
src_unpack() {
-
unpack ${A}
cd ${S}
@@ -68,15 +68,10 @@ src_install() {
cd ${S}
- mv fc-cache/fc-cache.man fc-cache/fc-cache.1
- mv fc-list/fc-list.man fc-list/fc-list.1
- mv src/fontconfig.man src/fontconfig.3
- for x in fc-cache/fc-cache.1 fc-list/fc-list.1 src/fontconfig.3
- do
- doman ${x}
- done
-
- dodoc AUTHORS COPYING ChangeLog NEWS README
+ newman fc-cache/fc-cache.man fc-cache.1
+ newman fc-list/fc-list.man fc-list.1
+ newman src/fontconfig.man fontconfig.3
+ dodoc AUTHORS ChangeLog NEWS README
}
pkg_postinst() {