summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-05-03 20:24:01 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-05-03 20:24:01 +0000
commitd13b68943781af7949b14e6e37c416eb13ce900b (patch)
treee900d822bd8f7d783311b14def2c671548e792a4 /media-libs/flac/flac-1.1.0-r1.ebuild
parentStable on sparc (diff)
downloadhistorical-d13b68943781af7949b14e6e37c416eb13ce900b.tar.gz
historical-d13b68943781af7949b14e6e37c416eb13ce900b.tar.bz2
historical-d13b68943781af7949b14e6e37c416eb13ce900b.zip
Revbump to fix xmms bug. Closes bug #82622.
Package-Manager: portage-2.0.51.21
Diffstat (limited to 'media-libs/flac/flac-1.1.0-r1.ebuild')
-rw-r--r--media-libs/flac/flac-1.1.0-r1.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/media-libs/flac/flac-1.1.0-r1.ebuild b/media-libs/flac/flac-1.1.0-r1.ebuild
deleted file mode 100644
index 32a0941093a2..000000000000
--- a/media-libs/flac/flac-1.1.0-r1.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/flac/flac-1.1.0-r1.ebuild,v 1.14 2005/02/05 12:49:35 luckyduck Exp $
-
-inherit libtool
-
-DESCRIPTION="free lossless audio encoder which includes an XMMS plugin"
-HOMEPAGE="http://flac.sourceforge.net/"
-SRC_URI="mirror://sourceforge/flac/${P}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2"
-SLOT="0"
-KEYWORDS="x86 ppc sparc alpha hppa amd64 ~ia64 ~mips"
-IUSE="sse xmms X"
-
-RDEPEND=">=media-libs/libogg-1.0_rc2
- X? ( xmms? ( media-sound/xmms ) )"
-DEPEND="${RDEPEND}
- x86? ( dev-lang/nasm )
- sys-apps/gawk"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- #if X not in use, then don't build in xmms support
- #if xmms not in use, then don't do it either.
- #if both X and xmms in use, then do it.
- if ! use xmms || ! use X
- then
- cp src/Makefile.in src/Makefile.in.orig
- sed -e '/^@FLaC__HAS_XMMS_TRUE/d' src/Makefile.in.orig > src/Makefile.in || die
- fi
-
- elibtoolize --reverse-deps
-}
-
-src_compile() {
- # non-x86 need -fPIC for to compile when X and xmss are in USE
- # the --with-pic is not enough to fix this ... Makefiles probably
- # need to get patched :p
- if use xmms && use X; then
- export CFLAGS="${CFLAGS} -fPIC"
- fi
-
- econf \
- --with-pic \
- `use_enable sse` \
- || die
-
- #the man page ebuild requires docbook2man... yick!
- sed -i -e 's:include man:include:g' Makefile
- #emake seems to mess up the building of the xmms input plugin
- make || die
-}
-
-src_install() {
- make DESTDIR=${D} install || die
-}
-
-# see #59482
-src_test() { :; }