summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-05 19:43:20 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-05 19:43:20 +0000
commit53d1e0dc014be382b47bc5f15f0d17d7eab6d7d2 (patch)
treee60f463f55aa5aac16ff1a139d0cbf4a2e4d9128 /media-gfx
parent- bah. forgot digest. (diff)
downloadhistorical-53d1e0dc014be382b47bc5f15f0d17d7eab6d7d2.tar.gz
historical-53d1e0dc014be382b47bc5f15f0d17d7eab6d7d2.tar.bz2
historical-53d1e0dc014be382b47bc5f15f0d17d7eab6d7d2.zip
*** empty log message ***
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/eog/eog-0.6.ebuild31
-rw-r--r--media-gfx/gphoto/files/digest-gphoto-2.0_beta11
-rw-r--r--media-gfx/gphoto/gphoto-0.4.3.ebuild4
-rw-r--r--media-gfx/gphoto/gphoto-2.0_beta1.ebuild34
4 files changed, 56 insertions, 14 deletions
diff --git a/media-gfx/eog/eog-0.6.ebuild b/media-gfx/eog/eog-0.6.ebuild
index 6d11369fe3f7..49f713ab1abb 100644
--- a/media-gfx/eog/eog-0.6.ebuild
+++ b/media-gfx/eog/eog-0.6.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/eog-0.6.ebuild,v 1.2 2001/05/10 09:39:40 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/eog-0.6.ebuild,v 1.3 2001/06/05 19:43:20 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -9,20 +9,27 @@ DESCRIPTION="Eye of GNOME"
SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/eog/"${A}
HOMEPAGE="http://www.gnome.org/gnome-office/eog.shtml"
-DEPEND=">=gnome-base/bonobo-0.18
- >=gnome-base/gconf-0.8
- >=gnome-base/gnome-core-1.4
- >=gnome-base/libglade-0.16"
-
-src_compile() {
- try ./configure --host=${CHOST} --prefix=/opt/gnome \
- --with-bonobo
+DEPEND="virtual/glibc nls? ( sys-devel/gettext )
+ >=gnome-base/bonobo-1.0.4
+ >=gnome-base/gconf-1.0.1
+ >=dev-util/xml-i18n-tools-0.8.4"
+
+RDEPEND="virtual/glibc
+ >=gnome-base/gconf-1.0.1
+ >=gnome-base/bonobo-1.0.4"
+
+src_compile() {
+ local myconf
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+ try ./configure --host=${CHOST} --prefix=/opt/gnome --sysconfdir=/etc/opt/gnome $myconf
try make
}
-src_install() {
- try make prefix=${D}/opt/gnome \
- GCONG_CONFIG_SOURCE=xml=${D}/opt/gnome/etc/gconf/gconf.xml.defaults install
+src_install() {
+ try make prefix=${D}/opt/gnome sysconfdir=/etc/opt/gnome \
+ GCONG_CONFIG_SOURCE=xml=${D}/etc/opt/gnome/gconf/gconf.xml.defaults install
dodoc AUTHORS COPYING DEPENDS ChangeLog HACKING NEWS README TODO MAINTAINERS
}
diff --git a/media-gfx/gphoto/files/digest-gphoto-2.0_beta1 b/media-gfx/gphoto/files/digest-gphoto-2.0_beta1
new file mode 100644
index 000000000000..e83f03b94851
--- /dev/null
+++ b/media-gfx/gphoto/files/digest-gphoto-2.0_beta1
@@ -0,0 +1 @@
+MD5 a6c0ec7ac7ee34486440637ee48d09a7 gphoto-2.0beta1.tar.gz
diff --git a/media-gfx/gphoto/gphoto-0.4.3.ebuild b/media-gfx/gphoto/gphoto-0.4.3.ebuild
index bcb49f1bbe07..a2613a6d0363 100644
--- a/media-gfx/gphoto/gphoto-0.4.3.ebuild
+++ b/media-gfx/gphoto/gphoto-0.4.3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author AJ Lewis <aj@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gphoto/gphoto-0.4.3.ebuild,v 1.5 2001/06/04 10:34:15 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gphoto/gphoto-0.4.3.ebuild,v 1.6 2001/06/05 19:43:20 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -23,7 +23,7 @@ src_compile() {
}
src_install() {
- try make prefix=${D}/opt/gnome --sysconfdir=${D}/etc/opd/gnome install
+ try make prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome install
dodoc AUTHORS CONTACTS COPYING ChangeLog FAQ MANUAL NEWS* PROGRAMMERS \
README THANKS THEMES TODO
}
diff --git a/media-gfx/gphoto/gphoto-2.0_beta1.ebuild b/media-gfx/gphoto/gphoto-2.0_beta1.ebuild
new file mode 100644
index 000000000000..99c125485845
--- /dev/null
+++ b/media-gfx/gphoto/gphoto-2.0_beta1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author AJ Lewis <aj@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gphoto/gphoto-2.0_beta1.ebuild,v 1.1 2001/06/05 19:43:20 achim Exp $
+
+A=${PN}-2.0beta1.tar.gz
+S=${WORKDIR}/${PN}-2.0beta1
+DESCRIPTION="free, redistributable digital camera software application"
+SRC_URI="http://www.gphoto.net/dist/${A}"
+HOMEPAGE="http://www.gphoto.org"
+
+DEPEND="virtual/glibc >=dev-libs/libusb-0.1.3b >=dev-libs/glib-1.2.10 >=sys-libs/zlib-1.1.3"
+
+
+src_compile() {
+
+ # -pipe does no work
+ cd libgphoto2_port
+ try CFLAGS=\"${CFLAGS/-pipe/}\" ./configure --prefix=/usr --sysconfdir=/etc
+ cd ..
+ try CFLAGS=\"${CFLAGS/-pipe/}\" ./configure --prefix=/usr --sysconfdir=/etc
+ # -j does not work
+ try make
+}
+
+src_install() {
+ try make prefix=${D}/usr sysconfdir=${D}/etc install
+ dodoc ChangeLog NEWS* README
+ mv ${D}/usr/share/gphoto2/html ${D}/usr/share/doc/${PF}/sgml
+ mv ${D}/usr/doc/gphoto2/* ${D}/usr/share/doc/${PF}
+ rm -rf ${D}/usr/share/gphoto2 ${D}/usr/share/doc/${PF}/sgml/gphoto2 ${D}/usr/doc
+ prepalldocs
+}
+