summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-05-26 07:23:15 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-05-26 07:23:15 +0000
commit35b5b1bef3db6fbd9f7002c17a1c397ff48194c8 (patch)
tree2493711bb1a2a9172d25bf8ea523637fe7c0da81 /media-gfx/paint-mono
parentfix another think-o in append-flags unification #271141 by Sebastian Lechte (diff)
downloadhistorical-35b5b1bef3db6fbd9f7002c17a1c397ff48194c8.tar.gz
historical-35b5b1bef3db6fbd9f7002c17a1c397ff48194c8.tar.bz2
historical-35b5b1bef3db6fbd9f7002c17a1c397ff48194c8.zip
Initial import, bug 269377. Ebuild by Aleksandr Yakimov <yaleks@gentoo.ru> w/fixups by me.
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64
Diffstat (limited to 'media-gfx/paint-mono')
-rw-r--r--media-gfx/paint-mono/ChangeLog11
-rw-r--r--media-gfx/paint-mono/Manifest4
-rw-r--r--media-gfx/paint-mono/metadata.xml5
-rw-r--r--media-gfx/paint-mono/paint-mono-0.1.63.ebuild31
4 files changed, 51 insertions, 0 deletions
diff --git a/media-gfx/paint-mono/ChangeLog b/media-gfx/paint-mono/ChangeLog
new file mode 100644
index 000000000000..b9678f822dc5
--- /dev/null
+++ b/media-gfx/paint-mono/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for media-gfx/paint-mono
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/paint-mono/ChangeLog,v 1.1 2009/05/26 07:23:15 loki_val Exp $
+
+*paint-mono-0.1.63 (26 May 2009)
+
+ 26 May 2009; Peter Alfredsen <loki_val@gentoo.org>
+ +paint-mono-0.1.63.ebuild, +metadata.xml:
+ Initial import, bug 269377. Ebuild by Aleksandr Yakimov <yaleks@gentoo.ru>
+ w/fixups by me.
+
diff --git a/media-gfx/paint-mono/Manifest b/media-gfx/paint-mono/Manifest
new file mode 100644
index 000000000000..451d5009b574
--- /dev/null
+++ b/media-gfx/paint-mono/Manifest
@@ -0,0 +1,4 @@
+DIST paintdotnet-0.1.63.tar.gz 1318570 RMD160 15308f86ba1662c968602948b5a50a736de186cd SHA1 4e902b1bd2f37169f696bdf910e310d586cd8f4a SHA256 32273a51d1643ff6eb28186c732e91f70474ecf796bbba3fbebb3eee7e1b53a5
+EBUILD paint-mono-0.1.63.ebuild 852 RMD160 8b9ac504b37fa57d5f6392c59897c189cf8dafea SHA1 b29bd1c94e3f912aad3d39fc4e051b9860a34fe6 SHA256 539fcd3a3617ba1848754917d532c5f6ea6e4e68e980ef3fd41440cfbf8b1cd2
+MISC ChangeLog 442 RMD160 7d29547926d7429a4bcc9a4448f80f681254ef45 SHA1 629841623c420c37853fe9cba05845c05aecc91e SHA256 052a11443b6cca08e66848af32923442cdcd95219cc689bc3f0094b882cde8ff
+MISC metadata.xml 160 RMD160 cc10b170ad63a746d8bdfbe5bf1bd9f7065922b8 SHA1 49eaf4246f7502850064d3806cce65d3a404ce1b SHA256 1bc3e313a948415fff0dfa63a5610943327146bfe16bfeca603379bf9706a687
diff --git a/media-gfx/paint-mono/metadata.xml b/media-gfx/paint-mono/metadata.xml
new file mode 100644
index 000000000000..e01adbb307db
--- /dev/null
+++ b/media-gfx/paint-mono/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dotnet</herd>
+</pkgmetadata>
diff --git a/media-gfx/paint-mono/paint-mono-0.1.63.ebuild b/media-gfx/paint-mono/paint-mono-0.1.63.ebuild
new file mode 100644
index 000000000000..335f527dc217
--- /dev/null
+++ b/media-gfx/paint-mono/paint-mono-0.1.63.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/paint-mono/paint-mono-0.1.63.ebuild,v 1.1 2009/05/26 07:23:15 loki_val Exp $
+
+EAPI=2
+
+inherit mono multilib
+
+DESCRIPTION="An unofficial effort to port Paint.NET 3.0 to Linux using Mono."
+HOMEPAGE="http://code.google.com/p/paint-mono/"
+SRC_URI="http://${PN}.googlecode.com/files/paintdotnet-${PV}.tar.gz"
+
+LICENSE="MIT CCPL-Attribution-NonCommercial-NoDerivs-2.5"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/mono-2.4[-minimal]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/paintdotnet-${PV}"
+
+src_configure() {
+ ./configure --prefix=/usr
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ mono_multilib_comply
+ sed -i -e 's:usr/local:usr:' "${D}"/usr/$(get_libdir)/pkgconfig/* "${D}"/usr/bin/*
+}