summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-11-20 12:50:44 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-11-20 12:50:44 +0000
commit258a6bd22959817a7820a29aa649232c57b36113 (patch)
treedc2fb09cb851eed885f8384bb12458d69a61ae2c /kde-base
parentUnmask the USE=mtp use flag (libmtp verified to work by Willy Gardiol ). (diff)
downloadhistorical-258a6bd22959817a7820a29aa649232c57b36113.tar.gz
historical-258a6bd22959817a7820a29aa649232c57b36113.tar.bz2
historical-258a6bd22959817a7820a29aa649232c57b36113.zip
Added a patch to fix a problem with the XF86Audio* key handlers not working when there's no master channel (e. g. you have a mute key that stopped working in KDE). Fixes bug 198015. Thanks to Kelvie Wong for creating and submitting said patch.
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kmilo/ChangeLog11
-rw-r--r--kde-base/kmilo/files/digest-kmilo-3.5.8-r13
-rw-r--r--kde-base/kmilo/files/kmilo-3.5.8-198015_XF86Audio.patch84
-rw-r--r--kde-base/kmilo/kmilo-3.5.8-r1.ebuild23
-rw-r--r--kde-base/kmix/ChangeLog11
-rw-r--r--kde-base/kmix/files/digest-kmix-3.5.8-r13
-rw-r--r--kde-base/kmix/files/kmix-3.5.8-198015_XF86Audio.patch58
-rw-r--r--kde-base/kmix/kmix-3.5.8-r1.ebuild22
8 files changed, 213 insertions, 2 deletions
diff --git a/kde-base/kmilo/ChangeLog b/kde-base/kmilo/ChangeLog
index 29aaceebad58..2c141e8bd630 100644
--- a/kde-base/kmilo/ChangeLog
+++ b/kde-base/kmilo/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for kde-base/kmilo
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kmilo/ChangeLog,v 1.75 2007/10/19 23:08:00 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmilo/ChangeLog,v 1.76 2007/11/20 12:50:43 philantrop Exp $
+
+*kmilo-3.5.8-r1 (20 Nov 2007)
+
+ 20 Nov 2007; Wulf C. Krueger <philantrop@gentoo.org>
+ +files/kmilo-3.5.8-198015_XF86Audio.patch, +kmilo-3.5.8-r1.ebuild:
+ Added a patch to fix a problem with the XF86Audio* key handlers not working
+ when there's no master channel (e. g. you have a mute key that stopped
+ working in KDE). Fixes bug 198015. Thanks to Kelvie Wong for creating and
+ submitting said patch.
*kmilo-3.5.8 (19 Oct 2007)
diff --git a/kde-base/kmilo/files/digest-kmilo-3.5.8-r1 b/kde-base/kmilo/files/digest-kmilo-3.5.8-r1
new file mode 100644
index 000000000000..41ce46180134
--- /dev/null
+++ b/kde-base/kmilo/files/digest-kmilo-3.5.8-r1
@@ -0,0 +1,3 @@
+MD5 d1a0fcc83f35428a76cf7523a04ba19c kdeutils-3.5.8.tar.bz2 3059172
+RMD160 94267b9c08339c7310d65106110c9b9ef133d6f8 kdeutils-3.5.8.tar.bz2 3059172
+SHA256 7dcbe3361cc53f9dac4c1bf6f45952d3d2518bec56cd8c07b8e07b4c4f12d0ac kdeutils-3.5.8.tar.bz2 3059172
diff --git a/kde-base/kmilo/files/kmilo-3.5.8-198015_XF86Audio.patch b/kde-base/kmilo/files/kmilo-3.5.8-198015_XF86Audio.patch
new file mode 100644
index 000000000000..22d16983f88f
--- /dev/null
+++ b/kde-base/kmilo/files/kmilo-3.5.8-198015_XF86Audio.patch
@@ -0,0 +1,84 @@
+From 5ddf8e7f68098ebb86d0023653e540edf119291d Mon Sep 17 00:00:00 2001
+From: Kelvie Wong <kelvie@ieee.org>
+Date: Sat, 3 Nov 2007 21:42:27 -0700
+Subject: [PATCH] KMilo: reintroduced support for kmix's user-set master channel
+ * uses the new masterDeviceIndex dcop call in KMix (from other patch)
+
+---
+ kmilo/generic/generic_monitor.cpp | 18 +++++++++++++-----
+ kmilo/generic/generic_monitor.h | 1 +
+ 2 files changed, 14 insertions(+), 5 deletions(-)
+
+diff --git a/kmilo/generic/generic_monitor.cpp b/kmilo/generic/generic_monitor.cpp
+index 51b96b1..fd7a47f 100644
+--- a/kmilo/generic/generic_monitor.cpp
++++ b/kmilo/generic/generic_monitor.cpp
+@@ -50,6 +50,7 @@ GenericMonitor::GenericMonitor(QObject *parent, const char *name, const QStringL
+ m_minVolume = 0;
+ m_maxVolume = 100;
+ m_volume = 50;
++ m_deviceIdx = 0;
+ }
+
+ GenericMonitor::~GenericMonitor()
+@@ -92,7 +93,14 @@ bool GenericMonitor::retrieveVolume()
+ {
+ bool kmix_error = false;
+
+- DCOPReply reply = kmixClient->call("absoluteVolume", 0);
++ // Set it to the master, or 0 (from GenericMonitor()) if this dcop
++ // call doesn't exist or various other errors. It used to be
++ // hard-coded to 0 anyways.
++ DCOPReply reply = kmixClient->call("masterDeviceIndex");
++ if (reply.isValid())
++ m_deviceIdx = reply;
++
++ reply = kmixClient->call("absoluteVolume", m_deviceIdx);
+ if (reply.isValid())
+ m_volume = reply;
+ else
+@@ -104,7 +112,7 @@ bool GenericMonitor::retrieveVolume()
+ if (kapp->startServiceByDesktopName("kmix")==0) // trying to start kmix
+ {
+ // trying again
+- reply = kmixClient->call("absoluteVolume", 0);
++ reply = kmixClient->call("absoluteVolume", m_deviceIdx);
+ if (reply.isValid())
+ {
+ m_volume = reply;
+@@ -122,9 +130,9 @@ bool GenericMonitor::retrieveVolume()
+
+ return false;
+ } else {
+- reply = kmixClient->call("absoluteVolumeMax", 0);
++ reply = kmixClient->call("absoluteVolumeMax", m_deviceIdx);
+ m_maxVolume = reply;
+- reply = kmixClient->call("absoluteVolumeMin", 0);
++ reply = kmixClient->call("absoluteVolumeMin", m_deviceIdx);
+ m_minVolume = reply;
+ return true;
+ }
+@@ -165,7 +173,7 @@ void GenericMonitor::displayVolume()
+
+ // If we got this far, the DCOP communication with kmix works,
+ // so we don't have to test the result.
+- kmixClient->send("setAbsoluteVolume", 0, m_volume);
++ kmixClient->send("setAbsoluteVolume", m_deviceIdx, m_volume);
+
+ // if mute then unmute
+ if (m_mute)
+diff --git a/kmilo/generic/generic_monitor.h b/kmilo/generic/generic_monitor.h
+index 7a0ba51..d04274f 100644
+--- a/kmilo/generic/generic_monitor.h
++++ b/kmilo/generic/generic_monitor.h
+@@ -74,6 +74,7 @@ private:
+
+ DCOPRef *kmixClient, *kmixWindow;
+
++ int m_deviceIdx;
+ int m_progress;
+ long m_volume, m_oldVolume;
+ bool m_mute;
+--
+1.5.3.4
+
diff --git a/kde-base/kmilo/kmilo-3.5.8-r1.ebuild b/kde-base/kmilo/kmilo-3.5.8-r1.ebuild
new file mode 100644
index 000000000000..ce01f97c0be3
--- /dev/null
+++ b/kde-base/kmilo/kmilo-3.5.8-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmilo/kmilo-3.5.8-r1.ebuild,v 1.1 2007/11/20 12:50:43 philantrop Exp $
+
+KMNAME=kdeutils
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="kmilo - a kded module that can be extended to support various types of hardware
+input devices that exist, such as those on keyboards."
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="kdehiddenvisibility pbbuttonsd"
+DEPEND="pbbuttonsd? ( app-laptop/pbbuttonsd )"
+RDEPEND="${DEPEND}"
+
+PATCHES="${FILESDIR}/${P}-198015_XF86Audio.patch"
+
+src_compile() {
+ local myconf="$(use_with pbbuttonsd powerbook)"
+
+ kde-meta_src_compile
+}
diff --git a/kde-base/kmix/ChangeLog b/kde-base/kmix/ChangeLog
index e5c1d1e36681..4c79071c7f1f 100644
--- a/kde-base/kmix/ChangeLog
+++ b/kde-base/kmix/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for kde-base/kmix
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kmix/ChangeLog,v 1.74 2007/10/19 23:08:48 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmix/ChangeLog,v 1.75 2007/11/20 12:46:27 philantrop Exp $
+
+*kmix-3.5.8-r1 (20 Nov 2007)
+
+ 20 Nov 2007; Wulf C. Krueger <philantrop@gentoo.org>
+ +files/kmix-3.5.8-198015_XF86Audio.patch, +kmix-3.5.8-r1.ebuild:
+ Added a patch to fix a problem with the XF86Audio* key handlers not working
+ when there's no master channel (e. g. you have a mute key that stopped
+ working in KDE). Fixes bug 198015. Thanks to Kelvie Wong for creating and
+ submitting said patch.
*kmix-3.5.8 (19 Oct 2007)
diff --git a/kde-base/kmix/files/digest-kmix-3.5.8-r1 b/kde-base/kmix/files/digest-kmix-3.5.8-r1
new file mode 100644
index 000000000000..8038f4ee451d
--- /dev/null
+++ b/kde-base/kmix/files/digest-kmix-3.5.8-r1
@@ -0,0 +1,3 @@
+MD5 9f3c95231ea265b09f3010adb954ae30 kdemultimedia-3.5.8.tar.bz2 6316739
+RMD160 5fcb8d282e2d49baca4daa9fb4e24b5216df92ee kdemultimedia-3.5.8.tar.bz2 6316739
+SHA256 07fc79e38bd7d50a8e2b9910a5d78ef565557b2a746b31d5d440829e9f05b0c1 kdemultimedia-3.5.8.tar.bz2 6316739
diff --git a/kde-base/kmix/files/kmix-3.5.8-198015_XF86Audio.patch b/kde-base/kmix/files/kmix-3.5.8-198015_XF86Audio.patch
new file mode 100644
index 000000000000..1190e717ee01
--- /dev/null
+++ b/kde-base/kmix/files/kmix-3.5.8-198015_XF86Audio.patch
@@ -0,0 +1,58 @@
+From efbae8873fc7b2ffe366353a1bcd9623cf4975a3 Mon Sep 17 00:00:00 2001
+From: Kelvie Wong <kelvie@ieee.org>
+Date: Sat, 3 Nov 2007 21:39:49 -0700
+Subject: [PATCH] Added a masterDeviceIndex dcop call that returns the device index of the master channel
+
+---
+ kmix/mixer.cpp | 5 +++++
+ kmix/mixer.h | 1 +
+ kmix/mixerIface.h | 5 +++++
+ 3 files changed, 11 insertions(+), 0 deletions(-)
+
+diff --git a/kmix/mixer.cpp b/kmix/mixer.cpp
+index 2adb300..316625e 100644
+--- a/kmix/mixer.cpp
++++ b/kmix/mixer.cpp
+@@ -730,6 +730,11 @@ bool Mixer::masterMute()
+ return true;
+ }
+
++// @dcop only
++int Mixer::masterDeviceIndex()
++{
++ return masterDevice()->num();
++}
+
+ bool Mixer::isRecordSource( int deviceidx )
+ {
+diff --git a/kmix/mixer.h b/kmix/mixer.h
+index 14c8a65..b6d0917 100644
+--- a/kmix/mixer.h
++++ b/kmix/mixer.h
+@@ -123,6 +123,7 @@ class Mixer : public QObject, virtual public MixerIface
+ virtual long absoluteVolumeMax( int deviceidx );
+ virtual int volume( int deviceidx );
+ virtual int masterVolume();
++ virtual int masterDeviceIndex();
+
+ virtual void setMute( int deviceidx, bool on );
+ virtual void setMasterMute( bool on );
+diff --git a/kmix/mixerIface.h b/kmix/mixerIface.h
+index b2aafb2..6c8da9f 100644
+--- a/kmix/mixerIface.h
++++ b/kmix/mixerIface.h
+@@ -85,6 +85,11 @@ k_dcop:
+ virtual bool masterMute()=0;
+
+ /**
++ Returns the index of the master device
++ */
++ virtual int masterDeviceIndex()=0;
++
++ /**
+ Makes the given device a record source.
+ */
+ virtual void setRecordSource( int deviceidx, bool on )=0;
+--
+1.5.3.4
+
diff --git a/kde-base/kmix/kmix-3.5.8-r1.ebuild b/kde-base/kmix/kmix-3.5.8-r1.ebuild
new file mode 100644
index 000000000000..dfbb9770b5e5
--- /dev/null
+++ b/kde-base/kmix/kmix-3.5.8-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmix/kmix-3.5.8-r1.ebuild,v 1.1 2007/11/20 12:46:27 philantrop Exp $
+
+KMNAME=kdemultimedia
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="aRts mixer gui"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="alsa"
+DEPEND="alsa? ( media-libs/alsa-lib )"
+RDEPEND="${DEPEND}"
+
+PATCHES="${FILESDIR}/kmix-3.5.6-alsa-tests.patch
+ ${FILESDIR}/${P}-198015_XF86Audio.patch"
+
+src_compile() {
+ local myconf="$(use_with alsa)"
+ kde-meta_src_compile
+}