summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-10-06 20:45:06 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-10-06 20:45:06 +0000
commit6470f4ac5b472ee7d10da40dfb9b9166e181ef01 (patch)
tree8621e1eb122f523b48febd6a5d56a7203c5878da /kde-base/smoke
parentVersion bump. Completely rewritten. Now ship with mkl, and idb. Synchronize e... (diff)
downloadhistorical-6470f4ac5b472ee7d10da40dfb9b9166e181ef01.tar.gz
historical-6470f4ac5b472ee7d10da40dfb9b9166e181ef01.tar.bz2
historical-6470f4ac5b472ee7d10da40dfb9b9166e181ef01.zip
Version bump KDE 4.3.2
Package-Manager: portage-2.2_rc44/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/smoke')
-rw-r--r--kde-base/smoke/ChangeLog7
-rw-r--r--kde-base/smoke/smoke-4.3.2.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/kde-base/smoke/ChangeLog b/kde-base/smoke/ChangeLog
index 0ceab2dc8120..22a85f396668 100644
--- a/kde-base/smoke/ChangeLog
+++ b/kde-base/smoke/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/smoke
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/ChangeLog,v 1.71 2009/09/01 16:27:45 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/ChangeLog,v 1.72 2009/10/06 20:39:51 alexxy Exp $
+
+*smoke-4.3.2 (06 Oct 2009)
+
+ 06 Oct 2009; Alexey Shvetsov <alexxy@gentoo.org> +smoke-4.3.2.ebuild:
+ Version bump
*smoke-4.3.1 (01 Sep 2009)
diff --git a/kde-base/smoke/smoke-4.3.2.ebuild b/kde-base/smoke/smoke-4.3.2.ebuild
new file mode 100644
index 000000000000..8858dc0b7a9e
--- /dev/null
+++ b/kde-base/smoke/smoke-4.3.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smoke/smoke-4.3.2.ebuild,v 1.1 2009/10/06 20:39:51 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdebindings"
+WEBKIT_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="Scripting Meta Object Kompiler Engine"
+KEYWORDS="~amd64 ~x86"
+IUSE="akonadi kdevplatform +phonon qscintilla qwt +semantic-desktop"
+# okular
+
+COMMON_DEPEND="
+ >=kde-base/qimageblitz-0.0.4
+ akonadi? (
+ app-office/akonadi-server
+ >=kde-base/kdepimlibs-${PV}:${SLOT}[kdeprefix=]
+ )
+ kdevplatform? ( dev-util/kdevplatform:4 )
+ phonon? ( >=media-sound/phonon-4.4_pre[xcb] )
+ qscintilla? ( x11-libs/qscintilla[qt4] )
+ qwt? ( x11-libs/qwt:5 )
+ semantic-desktop? (
+ dev-libs/soprano
+ >=kde-base/nepomuk-${PV}:${SLOT}[kdeprefix=]
+ )
+"
+# okular? ( kde-base/okular) -- it can't find it anyway
+
+DEPEND="${COMMON_DEPEND}
+ dev-lang/perl
+"
+RDEPEND="${COMMON_DEPEND}"
+
+KMEXTRACTONLY="kalyptus/"
+
+PATCHES=( "${FILESDIR}"/${PN}-phonon-fix.patch )
+
+src_configure() {
+ local mycmakeargs="
+ $(cmake-utils_use_enable webkit QTWEBKIT_SMOKE)
+ $(cmake-utils_use_enable qwt QWT_SMOKE)
+ $(cmake-utils_use_enable qscintilla QSCI_SMOKE)
+ $(cmake-utils_use_enable phonon PHONON_SMOKE)
+ $(cmake-utils_use_enable kdevplatform KDEVPLATFORM_SMOKE)
+ $(cmake-utils_use_enable semantic-desktop Nepomuk)
+ $(cmake-utils_use_enable semantic-desktop Soprano)
+ $(cmake-utils_use_enable akonadi Kdepimlibs)
+ $(cmake-utils_use_enable akonadi)
+ -DENABLE_Okular=OFF
+ "
+ # $(cmake-utils_use_enable okular)
+ kde4-meta_src_configure
+}