summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-09-04 18:45:48 +0000
committerJohannes Huber <johu@gentoo.org>2012-09-04 18:45:48 +0000
commit96b2ccccbdb3a629585880f16ae065b3a046ecf8 (patch)
tree8614154608c173341cea9bbafdd085551b050be8 /kde-base/plasma-workspace
parentAdd net-misc/leechcraft-launchy, thanks to 0xd34df00d (diff)
downloadhistorical-96b2ccccbdb3a629585880f16ae065b3a046ecf8.tar.gz
historical-96b2ccccbdb3a629585880f16ae065b3a046ecf8.tar.bz2
historical-96b2ccccbdb3a629585880f16ae065b3a046ecf8.zip
Version bump KDE SC 4.9.1
Package-Manager: portage-2.2.0_alpha124/cvs/Linux x86_64
Diffstat (limited to 'kde-base/plasma-workspace')
-rw-r--r--kde-base/plasma-workspace/ChangeLog7
-rw-r--r--kde-base/plasma-workspace/plasma-workspace-4.9.1.ebuild130
2 files changed, 136 insertions, 1 deletions
diff --git a/kde-base/plasma-workspace/ChangeLog b/kde-base/plasma-workspace/ChangeLog
index 54f0a2731313..9a1a986e3133 100644
--- a/kde-base/plasma-workspace/ChangeLog
+++ b/kde-base/plasma-workspace/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/plasma-workspace
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/plasma-workspace/ChangeLog,v 1.173 2012/09/03 14:37:43 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/plasma-workspace/ChangeLog,v 1.174 2012/09/04 18:45:21 johu Exp $
+
+*plasma-workspace-4.9.1 (04 Sep 2012)
+
+ 04 Sep 2012; Johannes Huber <johu@gentoo.org> +plasma-workspace-4.9.1.ebuild:
+ Version bump KDE SC 4.9.1
03 Sep 2012; Johannes Huber <johu@gentoo.org>
-files/plasma-workspace-4.4.2-xinerama_cmake_automagic.patch:
diff --git a/kde-base/plasma-workspace/plasma-workspace-4.9.1.ebuild b/kde-base/plasma-workspace/plasma-workspace-4.9.1.ebuild
new file mode 100644
index 000000000000..153ea49128aa
--- /dev/null
+++ b/kde-base/plasma-workspace/plasma-workspace-4.9.1.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/plasma-workspace/plasma-workspace-4.9.1.ebuild,v 1.1 2012/09/04 18:45:21 johu Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kde-workspace"
+KMMODULE="plasma"
+PYTHON_DEPEND="python? 2"
+inherit python kde4-meta
+
+DESCRIPTION="Plasma: KDE desktop framework"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug google-gadgets gps python qalculate +rss semantic-desktop"
+
+COMMONDEPEND="
+ $(add_kdebase_dep kactivities)
+ $(add_kdebase_dep kdelibs 'semantic-desktop=')
+ $(add_kdebase_dep kephal)
+ $(add_kdebase_dep ksysguard)
+ $(add_kdebase_dep libkworkspace)
+ $(add_kdebase_dep libplasmagenericshell)
+ $(add_kdebase_dep libtaskmanager)
+ $(add_kdebase_dep solid)
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ x11-libs/libXrender
+ google-gadgets? ( >=x11-misc/google-gadgets-0.11.0[qt4] )
+ gps? ( >=sci-geosciences/gpsd-2.37 )
+ python? (
+ >=dev-python/PyQt4-4.4.0[X]
+ >=dev-python/sip-4.7.1
+ $(add_kdebase_dep pykde4)
+ )
+ qalculate? ( sci-libs/libqalculate )
+ rss? (
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop=')
+ $(add_kdebase_dep libplasmaclock 'holidays')
+ )
+ !rss? ( $(add_kdebase_dep libplasmaclock '-holidays') )
+"
+DEPEND="${COMMONDEPEND}
+ rss? ( dev-libs/boost )
+ x11-proto/compositeproto
+ x11-proto/damageproto
+ x11-proto/fixesproto
+ x11-proto/renderproto
+"
+RDEPEND="${COMMONDEPEND}
+ $(add_kdebase_dep plasma-runtime)
+"
+
+KMEXTRA="
+ statusnotifierwatcher/
+"
+KMEXTRACTONLY="
+ krunner/dbus/org.freedesktop.ScreenSaver.xml
+ krunner/dbus/org.kde.krunner.App.xml
+ ksmserver/org.kde.KSMServerInterface.xml
+ libs/kephal/
+ libs/kworkspace/
+ libs/taskmanager/
+ libs/plasmagenericshell/
+ libs/ksysguard/
+ ksysguard/
+"
+
+KMLOADLIBS="libkworkspace libplasmaclock libplasmagenericshell libtaskmanager"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+ kde4-meta_pkg_setup
+}
+
+src_unpack() {
+ if use handbook; then
+ KMEXTRA+=" doc/plasma-desktop"
+ fi
+
+ kde4-meta_src_unpack
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with google-gadgets Googlegadgets)
+ $(cmake-utils_use_with gps libgps)
+ $(cmake-utils_use_with python SIP)
+ $(cmake-utils_use_with python PyQt4)
+ $(cmake-utils_use_with python PyKDE4)
+ $(cmake-utils_use_with qalculate)
+ $(cmake-utils_use_with rss KdepimLibs)
+ $(cmake-utils_use_with semantic-desktop Akonadi)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ -DWITH_Xmms=OFF
+ )
+
+ kde4-meta_src_configure
+}
+
+src_install() {
+ kde4-meta_src_install
+
+ rm -f \
+ "${ED}$(python_get_sitedir)"/PyKDE4/*.py[co] \
+ "${ED}"/usr/share/apps/plasma_scriptengine_python/*.py[co]
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if use python; then
+ python_mod_optimize \
+ PyKDE4 \
+ /usr/share/apps/plasma_scriptengine_python
+ fi
+}
+
+pkg_postrm() {
+ kde4-meta_pkg_postrm
+
+ if [[ -d ${EPREFIX}/usr/share/apps/plasma_scriptengine_python ]]; then
+ python_mod_cleanup \
+ PyKDE4 \
+ /usr/share/apps/plasma_scriptengine_python
+ fi
+}