summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Heinlein <keytoaster@gentoo.org>2008-06-05 22:40:00 +0000
committerTobias Heinlein <keytoaster@gentoo.org>2008-06-05 22:40:00 +0000
commit9fafd5bafd3bd72375877eb3cfb780c3506a977d (patch)
tree93b51c0d7e085f72000dc62e5d120932e856d148 /kde-base/libplasma
parentAdded the KDE 4.0.5 version of libkworkspace. (diff)
downloadhistorical-9fafd5bafd3bd72375877eb3cfb780c3506a977d.tar.gz
historical-9fafd5bafd3bd72375877eb3cfb780c3506a977d.tar.bz2
historical-9fafd5bafd3bd72375877eb3cfb780c3506a977d.zip
Added the KDE 4.0.5 version of libplasma.
Package-Manager: portage-2.2_pre7/cvs/Linux 2.6.25-gentoo-r4 AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
Diffstat (limited to 'kde-base/libplasma')
-rw-r--r--kde-base/libplasma/ChangeLog8
-rw-r--r--kde-base/libplasma/libplasma-4.0.5.ebuild54
2 files changed, 61 insertions, 1 deletions
diff --git a/kde-base/libplasma/ChangeLog b/kde-base/libplasma/ChangeLog
index 7a7b4cdef3e1..db85717454f4 100644
--- a/kde-base/libplasma/ChangeLog
+++ b/kde-base/libplasma/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/libplasma
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/libplasma/ChangeLog,v 1.8 2008/05/30 09:12:50 zlin Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/libplasma/ChangeLog,v 1.9 2008/06/05 22:40:00 keytoaster Exp $
+
+*libplasma-4.0.5 (05 Jun 2008)
+
+ 05 Jun 2008; Tobias Heinlein <keytoaster@gentoo.org>
+ +libplasma-4.0.5.ebuild:
+ Added the KDE 4.0.5 version of libplasma.
30 May 2008; Bo Ørsted Andresen <zlin@gentoo.org> libplasma-4.0.4.ebuild:
KDE4_BUILT_WITH_USE_CHECK is now always an array. Bug #216863.
diff --git a/kde-base/libplasma/libplasma-4.0.5.ebuild b/kde-base/libplasma/libplasma-4.0.5.ebuild
new file mode 100644
index 000000000000..95b1be62ca88
--- /dev/null
+++ b/kde-base/libplasma/libplasma-4.0.5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/libplasma/libplasma-4.0.5.ebuild,v 1.1 2008/06/05 22:40:00 keytoaster Exp $
+
+EAPI="1"
+
+KMNAME=kdebase-workspace
+KMMODULE="libs/plasma"
+CPPUNIT_REQUIRED="optional"
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="Plasma: KDE desktop framework"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug opengl test xinerama"
+
+COMMONDEPEND="!<kde-base/plasma-3.96.0
+ >=kde-base/libkworkspace-${PV}:${SLOT}
+ >=kde-base/libtaskmanager-${PV}:${SLOT}
+ x11-libs/libXau
+ x11-libs/libXfixes
+ x11-libs/libXrender
+ x11-libs/libXtst
+ opengl? ( virtual/opengl )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${COMMONDEPEND}
+ xinerama? ( x11-proto/xineramaproto )"
+RDEPEND="${COMMONDEPEND}"
+
+KMEXTRACTONLY="krunner/org.freedesktop.ScreenSaver.xml
+ krunner/org.kde.krunner.Interface.xml
+ ksmserver/org.kde.KSMServerInterface.xml
+ libs/taskmanager/"
+KMSAVELIBS="true"
+
+KDE4_BUILT_WITH_USE_CHECK=("app-misc/strigi dbus qt4")
+
+# Disabling tests for now. 3 out of 3 broken now. last tested on 4.0.1.
+RESTRICT="test"
+
+src_compile() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with opengl OpenGL)
+ $(cmake-utils_use_with xinerama X11_Xinerama)"
+
+ kde4-meta_src_compile
+}
+
+src_install() {
+ kde4-meta_src_install
+
+ # Outsmart our doc-handling, to avoid a collision with plasma.
+ rm -rf "${D}"/${KDEDIR}/share/doc/
+}