summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-04-12 06:48:25 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-04-12 06:48:25 +0000
commita23836a100f24ca0b06a61c97e212cd1e6153439 (patch)
treebcbc2f814eb11cd7df6aaf4ace6c0abe1da2b29e /kde-base/kwin
parentKeep net-www moves in alphabetical order. Fix whitespace. (diff)
downloadhistorical-a23836a100f24ca0b06a61c97e212cd1e6153439.tar.gz
historical-a23836a100f24ca0b06a61c97e212cd1e6153439.tar.bz2
historical-a23836a100f24ca0b06a61c97e212cd1e6153439.zip
Add KDE 4.2.2
Package-Manager: portage-2.2_rc29/cvs/Linux x86_64
Diffstat (limited to 'kde-base/kwin')
-rw-r--r--kde-base/kwin/ChangeLog7
-rw-r--r--kde-base/kwin/kwin-4.2.2.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/kde-base/kwin/ChangeLog b/kde-base/kwin/ChangeLog
index 7bcd973a6fe4..582a8621429b 100644
--- a/kde-base/kwin/ChangeLog
+++ b/kde-base/kwin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kwin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.145 2009/04/11 18:35:26 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.146 2009/04/12 06:20:47 alexxy Exp $
+
+*kwin-4.2.2 (11 Apr 2009)
+
+ 11 Apr 2009; Alexey Shvetsov <alexxy@gentoo.org> +kwin-4.2.2.ebuild:
+ Add KDE 4.2.2
11 Apr 2009; Raúl Porcel <armin76@gentoo.org> kwin-4.2.1.ebuild:
Add ~alpha/~ia64 wrt #260777
diff --git a/kde-base/kwin/kwin-4.2.2.ebuild b/kde-base/kwin/kwin-4.2.2.ebuild
new file mode 100644
index 000000000000..cea05dae03d3
--- /dev/null
+++ b/kde-base/kwin/kwin-4.2.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/kwin-4.2.2.ebuild,v 1.1 2009/04/12 06:20:47 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdebase-workspace"
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KDE window manager"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug captury xcomposite xinerama"
+
+COMMONDEPEND="
+ >=kde-base/kephal-${PV}:${SLOT}[kdeprefix=]
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ >=x11-libs/libXrandr-1.2.1
+ x11-libs/libXrender
+ captury? ( media-libs/libcaptury )
+ opengl? ( virtual/opengl )
+ xcomposite? ( x11-libs/libXcomposite )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMONDEPEND}
+ x11-proto/damageproto
+ x11-proto/renderproto
+ xcomposite? ( x11-proto/compositeproto )
+ xinerama? ( x11-proto/xineramaproto )
+"
+RDEPEND="${COMMONDEPEND}"
+
+src_prepare() {
+ if ! use captury; then
+ sed -e 's:^PKGCONFIG..libcaptury:#DONOTFIND &:' \
+ -i "${S}"/kwin/effects/CMakeLists.txt || \
+ die "Making captury optional failed."
+ fi
+
+ kde4-meta_src_prepare
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with opengl OpenGL)"
+
+ kde4-meta_src_configure
+}