summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-10-06 09:17:37 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-10-06 09:17:37 +0000
commitb900c5b419baaf47bcd309ef6d8a932d630c79be (patch)
tree0ac77639648e73041ce5b313801ae2608e40ce15 /kde-base/ktux/ktux-4.5.2.ebuild
parentFix libpng SLOT depend wrt #339796 by "MaratIK". (diff)
downloadhistorical-b900c5b419baaf47bcd309ef6d8a932d630c79be.tar.gz
historical-b900c5b419baaf47bcd309ef6d8a932d630c79be.tar.bz2
historical-b900c5b419baaf47bcd309ef6d8a932d630c79be.zip
Add KDE SC 4.5.2 =)
Package-Manager: portage-2.2_rc88_p115/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/ktux/ktux-4.5.2.ebuild')
-rw-r--r--kde-base/ktux/ktux-4.5.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/kde-base/ktux/ktux-4.5.2.ebuild b/kde-base/ktux/ktux-4.5.2.ebuild
new file mode 100644
index 000000000000..13fd60f17bd0
--- /dev/null
+++ b/kde-base/ktux/ktux-4.5.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ktux/ktux-4.5.2.ebuild,v 1.1 2010/10/06 09:17:19 alexxy Exp $
+
+EAPI="3"
+
+KMNAME="kdetoys"
+inherit kde4-meta
+
+DESCRIPTION="KDE: screensaver featuring the Space-Faring Tux"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+# libkworkspace - only as a stub to provide KDE4Workspace config
+DEPEND="
+ $(add_kdebase_dep kscreensaver)
+ $(add_kdebase_dep libkworkspace)
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e's/${KDE4WORKSPACE_KSCREENSAVER_LIBRARY}/kscreensaver/' \
+ "${PN}"/src/CMakeLists.txt || die "Failed to patch CMakeLists.txt"
+
+ kde4-meta_src_prepare
+}