summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-09-04 18:45:48 +0000
committerJohannes Huber <johu@gentoo.org>2012-09-04 18:45:48 +0000
commit96b2ccccbdb3a629585880f16ae065b3a046ecf8 (patch)
tree8614154608c173341cea9bbafdd085551b050be8 /kde-base/ksysguard
parentAdd net-misc/leechcraft-launchy, thanks to 0xd34df00d (diff)
downloadhistorical-96b2ccccbdb3a629585880f16ae065b3a046ecf8.tar.gz
historical-96b2ccccbdb3a629585880f16ae065b3a046ecf8.tar.bz2
historical-96b2ccccbdb3a629585880f16ae065b3a046ecf8.zip
Version bump KDE SC 4.9.1
Package-Manager: portage-2.2.0_alpha124/cvs/Linux x86_64
Diffstat (limited to 'kde-base/ksysguard')
-rw-r--r--kde-base/ksysguard/ChangeLog7
-rw-r--r--kde-base/ksysguard/ksysguard-4.9.1.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/kde-base/ksysguard/ChangeLog b/kde-base/ksysguard/ChangeLog
index cf80e384b213..e8603e185f88 100644
--- a/kde-base/ksysguard/ChangeLog
+++ b/kde-base/ksysguard/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksysguard
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksysguard/ChangeLog,v 1.254 2012/09/03 13:29:50 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksysguard/ChangeLog,v 1.255 2012/09/04 18:45:06 johu Exp $
+
+*ksysguard-4.9.1 (04 Sep 2012)
+
+ 04 Sep 2012; Johannes Huber <johu@gentoo.org> +ksysguard-4.9.1.ebuild:
+ Version bump KDE SC 4.9.1
03 Sep 2012; Johannes Huber <johu@gentoo.org> -ksysguard-4.7.4.ebuild:
Remove KDE SC 4.7.4
diff --git a/kde-base/ksysguard/ksysguard-4.9.1.ebuild b/kde-base/ksysguard/ksysguard-4.9.1.ebuild
new file mode 100644
index 000000000000..831aacb708b6
--- /dev/null
+++ b/kde-base/ksysguard/ksysguard-4.9.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksysguard/ksysguard-4.9.1.ebuild,v 1.1 2012/09/04 18:45:06 johu Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kde-workspace"
+CPPUNIT_REQUIRED="optional"
+VIRTUALX_REQUIRED=test
+inherit kde4-meta
+
+DESCRIPTION="KSysguard is a network enabled task manager and system monitor application."
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug lm_sensors test"
+
+COMMONDEPEND="
+ x11-libs/libXrender
+ x11-libs/libXres
+ lm_sensors? ( sys-apps/lm_sensors )
+"
+DEPEND="${COMMONDEPEND}
+ x11-proto/renderproto
+"
+RDEPEND="${COMMONDEPEND}"
+
+RESTRICT="test"
+# bug 393091
+
+KMEXTRA="
+ libs/ksysguard/
+"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with lm_sensors Sensors)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+ ewarn "Note that ksysguard has powerful features; one of these is the executing of arbitrary"
+ ewarn "programs with elevated privileges (as data sources). So be careful opening worksheets"
+ ewarn "from untrusted sources!"
+}