summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-02-07 00:12:59 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-02-07 00:12:59 +0000
commit5dce68c9cc05b718532a522d45797435bc4d68b2 (patch)
tree3405da9ffcff7553acfd1a283d8344919ace829c /kde-base/kstars
parentrename check_apache_threads to has_apache_threads as suggested by dberkholz (diff)
downloadhistorical-5dce68c9cc05b718532a522d45797435bc4d68b2.tar.gz
historical-5dce68c9cc05b718532a522d45797435bc4d68b2.tar.bz2
historical-5dce68c9cc05b718532a522d45797435bc4d68b2.zip
Version bump to KDE 4.0.1.
Package-Manager: portage-2.1.4.1
Diffstat (limited to 'kde-base/kstars')
-rw-r--r--kde-base/kstars/ChangeLog7
-rw-r--r--kde-base/kstars/kstars-4.0.1.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/kde-base/kstars/ChangeLog b/kde-base/kstars/ChangeLog
index 3008a99f5d81..a9f4143fdf5f 100644
--- a/kde-base/kstars/ChangeLog
+++ b/kde-base/kstars/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kstars
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/ChangeLog,v 1.83 2008/01/31 15:30:16 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/ChangeLog,v 1.84 2008/02/07 00:11:17 philantrop Exp $
+
+*kstars-4.0.1 (06 Feb 2008)
+
+ 06 Feb 2008; Wulf C. Krueger <philantrop@gentoo.org> +kstars-4.0.1.ebuild:
+ Version bump to KDE 4.0.1.
31 Jan 2008; Brent Baude <ranger@gentoo.org> kstars-3.5.8.ebuild:
Marking kstars-3.5.8 ppc for bug 207634
diff --git a/kde-base/kstars/kstars-4.0.1.ebuild b/kde-base/kstars/kstars-4.0.1.ebuild
new file mode 100644
index 000000000000..0f0cd5d30582
--- /dev/null
+++ b/kde-base/kstars/kstars-4.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/kstars-4.0.1.ebuild,v 1.1 2008/02/07 00:11:17 philantrop Exp $
+
+EAPI="1"
+
+KMNAME=kdeedu
+inherit kde4-meta
+
+DESCRIPTION="KDE Desktop Planetarium"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug fits htmlhandbook nova sbig usb"
+
+COMMONDEPEND=">=kde-base/libkdeedu-${PV}:${SLOT}
+ fits? ( sci-libs/cfitsio )
+ nova? ( >=sci-libs/libnova-0.12.1 )
+ sbig? ( sci-libs/indilib
+ usb? ( dev-libs/libusb ) )"
+DEPEND="${DEPEND} ${COMMONDEPEND}"
+RDEPEND="${RDEPEND} ${COMMONDEPEND}"
+
+src_compile() {
+ epatch "${FILESDIR}/${PN}-4.0.0-destdir.patch"
+
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with fits CFitsio)
+ $(cmake-utils_use_with nova Nova)
+ $(cmake-utils_use_with sbig SBIG)
+ $(cmake-utils_use_with usb USB)"
+
+ kde4-meta_src_compile
+
+ # FIXME Unhandled arguments - added sbig but not sure about use descriptions or flag names...
+ # WITH_SBIG - Switch which controls the detection of the proprietary and binary only SBIG CCD universal library. No ebuild for this package
+ # are available at the moment.
+ # ssh_tunnel -> INDI Server binds locally. Remote clients may only connect
+ # via SSH Tunneling.
+}