summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2010-09-06 02:10:06 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2010-09-06 02:10:06 +0000
commit385ff8b2910e50bae3c5e4b04aab109640ba9bd0 (patch)
treed9033ecafa524717a40d45159d963ed5151a493d /kde-base/kstars
parentAutomated update of use.local.desc (diff)
downloadhistorical-385ff8b2910e50bae3c5e4b04aab109640ba9bd0.tar.gz
historical-385ff8b2910e50bae3c5e4b04aab109640ba9bd0.tar.bz2
historical-385ff8b2910e50bae3c5e4b04aab109640ba9bd0.zip
Version bump KDE SC 4.5.1
Package-Manager: portage-2.2_rc75/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/kstars')
-rw-r--r--kde-base/kstars/ChangeLog8
-rw-r--r--kde-base/kstars/files/kstars-4.4.65-solaris.patch13
-rw-r--r--kde-base/kstars/kstars-4.5.1.ebuild35
3 files changed, 55 insertions, 1 deletions
diff --git a/kde-base/kstars/ChangeLog b/kde-base/kstars/ChangeLog
index 93378670f6ef..4bed8f913720 100644
--- a/kde-base/kstars/ChangeLog
+++ b/kde-base/kstars/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kstars
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/ChangeLog,v 1.173 2010/08/10 13:21:50 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/ChangeLog,v 1.174 2010/09/06 01:18:06 tampakrap Exp $
+
+*kstars-4.5.1 (06 Sep 2010)
+
+ 06 Sep 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +files/kstars-4.4.65-solaris.patch, +kstars-4.5.1.ebuild:
+ Version bump
10 Aug 2010; Tomáš Chvátal <scarabeus@gentoo.org>
-files/kstars-4.3.2-solaris.patch:
diff --git a/kde-base/kstars/files/kstars-4.4.65-solaris.patch b/kde-base/kstars/files/kstars-4.4.65-solaris.patch
new file mode 100644
index 000000000000..0773f55f5f25
--- /dev/null
+++ b/kde-base/kstars/files/kstars-4.4.65-solaris.patch
@@ -0,0 +1,13 @@
+--- kstars-4.4.65.orig/kstars/kstars/skycomponents/starcomponent.cpp
++++ kstars-4.4.65/kstars/kstars/skycomponents/starcomponent.cpp
+@@ -40,6 +40,10 @@
+ #include <sys/endian.h>
+ #define bswap_16(x) bswap16(x)
+ #define bswap_32(x) bswap32(x)
++#elif defined(__sun)
++#include <sys/byteorder.h>
++#define bswap_16(x) BSWAP_16(x)
++#define bswap_32(x) BSWAP_32(x)
+ #else
+ #include "byteorder.h"
+ #endif
diff --git a/kde-base/kstars/kstars-4.5.1.ebuild b/kde-base/kstars/kstars-4.5.1.ebuild
new file mode 100644
index 000000000000..8371812eef55
--- /dev/null
+++ b/kde-base/kstars/kstars-4.5.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/kstars-4.5.1.ebuild,v 1.1 2010/09/06 01:18:06 tampakrap Exp $
+EAPI="3"
+
+KDE_HANDBOOK=1
+KMNAME="kdeedu"
+inherit kde4-meta
+
+DESCRIPTION="KDE Desktop Planetarium"
+KEYWORDS=""
+IUSE="debug fits indi"
+
+DEPEND="
+ $(add_kdebase_dep libkdeedu)
+ fits? ( >=sci-libs/cfitsio-0.390 )
+ indi? ( >=sci-libs/indilib-0.6.2[fits?] )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.4.65-solaris.patch
+)
+
+src_configure() {
+ # Bug 308903
+ use ppc64 && append-flags -mminimal-toc
+
+ mycmakeargs=(
+ $(cmake-utils_use_with fits CFitsio)
+ $(cmake-utils_use_with indi)
+ )
+
+ kde4-meta_src_configure
+}