summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-02-07 00:12:59 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-02-07 00:12:59 +0000
commit5dce68c9cc05b718532a522d45797435bc4d68b2 (patch)
tree3405da9ffcff7553acfd1a283d8344919ace829c /kde-base/ksplash
parentrename check_apache_threads to has_apache_threads as suggested by dberkholz (diff)
downloadhistorical-5dce68c9cc05b718532a522d45797435bc4d68b2.tar.gz
historical-5dce68c9cc05b718532a522d45797435bc4d68b2.tar.bz2
historical-5dce68c9cc05b718532a522d45797435bc4d68b2.zip
Version bump to KDE 4.0.1.
Package-Manager: portage-2.1.4.1
Diffstat (limited to 'kde-base/ksplash')
-rw-r--r--kde-base/ksplash/ChangeLog5
-rw-r--r--kde-base/ksplash/ksplash-4.0.1.ebuild29
2 files changed, 33 insertions, 1 deletions
diff --git a/kde-base/ksplash/ChangeLog b/kde-base/ksplash/ChangeLog
index b7bd7fac28e2..40a1c8327c99 100644
--- a/kde-base/ksplash/ChangeLog
+++ b/kde-base/ksplash/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for kde-base/ksplash
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.1 2008/01/18 00:42:07 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.2 2008/02/07 00:11:35 philantrop Exp $
+
+ 06 Feb 2008; Wulf C. Krueger <philantrop@gentoo.org> ChangeLog:
+ Version bump to KDE 4.0.1.
*ksplash-4.0.0 (18 Jan 2008)
diff --git a/kde-base/ksplash/ksplash-4.0.1.ebuild b/kde-base/ksplash/ksplash-4.0.1.ebuild
new file mode 100644
index 000000000000..1155ed98a876
--- /dev/null
+++ b/kde-base/ksplash/ksplash-4.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ksplash-4.0.1.ebuild,v 1.1 2008/02/07 00:11:35 philantrop Exp $
+
+EAPI="1"
+
+KMNAME=kdebase-workspace
+inherit kde4-meta
+
+DESCRIPTION="KDE splashscreen framework (the splashscreen of KDE itself, not of individual apps)"
+KEYWORDS="~amd64 ~x86"
+IUSE="3dnow altivec debug mmx sse sse2 xinerama"
+
+RDEPEND="
+ media-libs/libpng
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ xinerama? ( x11-proto/xineramaproto )"
+
+src_compile() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_has 3dnow X86_3DNOW)
+ $(cmake-utils_has altivec PPC_ALTIVEC)
+ $(cmake-utils_has mmx X86_MMX)
+ $(cmake-utils_has sse X86_SSE)
+ $(cmake-utils_has sse2 X86_SSE2)
+ $(cmake-utils_with xinerama X11_Xinerama)"
+ kde4-meta_src_compile
+}