summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-03 13:23:06 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-03 13:23:06 +0000
commitfb6446ec2ae71d8604a2605b5e0a7741800234b9 (patch)
treef541678afd1386deac67794ab2dccf4e07d2e82c /kde-base/korundum/korundum-3.5.5.ebuild
parentVersion bump to 009, imported from breakmygentoo.net (Thanks Peter Hyman!). ... (diff)
downloadhistorical-fb6446ec2ae71d8604a2605b5e0a7741800234b9.tar.gz
historical-fb6446ec2ae71d8604a2605b5e0a7741800234b9.tar.bz2
historical-fb6446ec2ae71d8604a2605b5e0a7741800234b9.zip
Bump to 3.5.5 (pre-release).
Package-Manager: portage-2.1.2_pre2-r1
Diffstat (limited to 'kde-base/korundum/korundum-3.5.5.ebuild')
-rw-r--r--kde-base/korundum/korundum-3.5.5.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/kde-base/korundum/korundum-3.5.5.ebuild b/kde-base/korundum/korundum-3.5.5.ebuild
new file mode 100644
index 000000000000..d96c68285c90
--- /dev/null
+++ b/kde-base/korundum/korundum-3.5.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/korundum-3.5.5.ebuild,v 1.1 2006/10/03 11:42:48 flameeyes Exp $
+
+KMNAME=kdebindings
+KMCOPYLIB="libsmokeqt smoke/qt libsmokekde smoke/kde"
+KMCOMPILEONLY="qtruby"
+KM_MAKEFILESREV=1
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta
+
+DESCRIPTION="KDE ruby bindings"
+HOMEPAGE="http://developer.kde.org/language-bindings/ruby/"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+OLDDEPEND=">=virtual/ruby-1.8 ~kde-base/qtruby-$PV ~kde-base/smoke-3.3.1"
+DEPEND=" >=virtual/ruby-1.8
+$(deprange $PV $MAXKDEVER kde-base/qtruby)
+$(deprange 3.5.2 $MAXKDEVER kde-base/smoke)"
+RDEPEND="${DEPEND}"
+
+PATCHES="$FILESDIR/no-gtk-glib-check.diff $FILESDIR/qtruby-3.5.4-more.patch $FILESDIR/korundum-3.5.4-more.patch"
+
+# Because this installs into /usr/lib/ruby/..., it doesn't have SLOT=X.Y like the rest of KDE,
+# and it installs into /usr entirely.
+# Note that it still depends on a specific range of (slotted) smoke and qtruby versions.
+SLOT="0"
+src_compile() {
+ kde_src_compile myconf
+ myconf="$myconf --prefix=/usr"
+ kde_src_compile configure make
+}
+