summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-07-30 09:54:46 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-07-30 09:54:46 +0000
commitc6026105d3ed405bf4d4a01ec1cf81fa49d85a43 (patch)
tree13be5572453bbcfaff4a9e4853b87d55e966adbf /kde-base/kmilo/files
parentversion bump. +3.242 x86 stable (diff)
downloadhistorical-c6026105d3ed405bf4d4a01ec1cf81fa49d85a43.tar.gz
historical-c6026105d3ed405bf4d4a01ec1cf81fa49d85a43.tar.bz2
historical-c6026105d3ed405bf4d4a01ec1cf81fa49d85a43.zip
Add configure patch for pbbuttonsd detection (#94731).
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'kde-base/kmilo/files')
-rw-r--r--kde-base/kmilo/files/configure-fix-kdeutils-powerbook.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/kde-base/kmilo/files/configure-fix-kdeutils-powerbook.patch b/kde-base/kmilo/files/configure-fix-kdeutils-powerbook.patch
new file mode 100644
index 000000000000..a54c727876ea
--- /dev/null
+++ b/kde-base/kmilo/files/configure-fix-kdeutils-powerbook.patch
@@ -0,0 +1,31 @@
+Index: kmilo/configure.in.in
+===================================================================
+--- kmilo/configure.in.in (revision 433553)
++++ kmilo/configure.in.in (working copy)
+@@ -9,6 +9,15 @@
+ dnl ---------------------------------------------------------------------
+ dnl PowerBook IPC Library
+
++AC_ARG_WITH(powerbook,
++ [AS_HELP_STRING(--with-powerbook,
++ [enable support for PPC PowerBook @<:@default=check@:>@])],
++ [], with_powerbook=check)
++
++have_pbbipc=""
++have_pbb=""
++if test "x$with_powerbook" != xno; then
++
+ KDE_CHECK_LIB(pbbipc, create_msgport,
+ [
+ KEYBOARD_LIBS="-lpbbipc $KEYBOARD_LIBS"
+@@ -23,6 +32,10 @@
+ have_pbb=true
+ ])
+
++if test "x$with_powerbook" != xcheck && test -z "$have_pbbipc$have_pbb"; then
++ AC_MSG_FAILURE([--with-powerbook was given, but test for libpbb failed])
++fi
++fi
+
+ AM_CONDITIONAL(include_kmilo_powerbook, test x$have_pbbipc = xtrue)
+ AM_CONDITIONAL(include_kmilo_pbb, test x$have_pbb = xtrue)