summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-10-02 19:20:10 +0000
committerDan Armak <danarmak@gentoo.org>2002-10-02 19:20:10 +0000
commit19453f052668dde02a44dd2af202f2a65bc8f5c9 (patch)
tree327de0fbbc86413ae3dec6d15e86dd590a1a9f3d /kde-base/kdebindings
parentFixed typo. (diff)
downloadhistorical-19453f052668dde02a44dd2af202f2a65bc8f5c9.tar.gz
historical-19453f052668dde02a44dd2af202f2a65bc8f5c9.tar.bz2
historical-19453f052668dde02a44dd2af202f2a65bc8f5c9.zip
kde 3.1 beta2 ebuilds. permanently masked as usual.
Diffstat (limited to 'kde-base/kdebindings')
-rw-r--r--kde-base/kdebindings/files/digest-kdebindings-3.1_beta21
-rw-r--r--kde-base/kdebindings/kdebindings-3.1_beta2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/kde-base/kdebindings/files/digest-kdebindings-3.1_beta2 b/kde-base/kdebindings/files/digest-kdebindings-3.1_beta2
new file mode 100644
index 000000000000..411b453b8789
--- /dev/null
+++ b/kde-base/kdebindings/files/digest-kdebindings-3.1_beta2
@@ -0,0 +1 @@
+MD5 18d089d9cc200a856b3a77a6c30b0432 kdebindings-3.0.8.tar.bz2 6122905
diff --git a/kde-base/kdebindings/kdebindings-3.1_beta2.ebuild b/kde-base/kdebindings/kdebindings-3.1_beta2.ebuild
new file mode 100644
index 000000000000..7c85b95f7d24
--- /dev/null
+++ b/kde-base/kdebindings/kdebindings-3.1_beta2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings/kdebindings-3.1_beta2.ebuild,v 1.1 2002/10/02 19:20:10 danarmak Exp $
+# TODO: add gnustep, objc bindings
+inherit kde-dist
+
+DESCRIPTION="KDE $PV - kde library bindings for languages other than c++"
+
+KEYWORDS="x86"
+
+newdepend "~kde-base/kdebase-${PV}
+ =x11-libs/gtk+-1.2*
+ sys-devel/perl
+ python? ( dev-lang/python )
+ java? ( virtual/jdk )
+ =x11-libs/gtk+-1.2*
+ =dev-libs/glib-1.2*
+ ~kde-base/kdenetwork-${PV}
+ mozilla? ( net-www/mozilla )"
+
+use python || myconf="$myconf --without-python"
+use java && myconf="$myconf --with-java=$(java-config --jdk-home)" || myconf="$myconf --without-java"
+#myconf="$myconf --enable-objc"
+
+export LIBPYTHON="`python-config`"
+
+#src_unpack()
+#{
+# base_src_unpack
+#
+# if [ -z "`use mozilla`" ]; then
+# # disable mozilla bindings/xpart
+# cd ${S}
+# cp configure configure.orig
+# sed -e 's:mozilla_incldirs=:# mozilla_incldirs=:' configure.orig > configure
+# chmod +x configure
+# fi
+#}
+