summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannes Mehnert <hannes@gentoo.org>2002-12-21 13:48:19 +0000
committerHannes Mehnert <hannes@gentoo.org>2002-12-21 13:48:19 +0000
commitad4e6b0fb4126efa20fee2a8fffa158c22b5f3af (patch)
tree1149b3a5c1f704c7dade65a5977f85f507631631 /kde-base/kdebase
parentToo much python... (diff)
downloadhistorical-ad4e6b0fb4126efa20fee2a8fffa158c22b5f3af.tar.gz
historical-ad4e6b0fb4126efa20fee2a8fffa158c22b5f3af.tar.bz2
historical-ad4e6b0fb4126efa20fee2a8fffa158c22b5f3af.zip
kde-3.0.5a release.
Diffstat (limited to 'kde-base/kdebase')
-rw-r--r--kde-base/kdebase/files/3.0.5a/kdebase-3.0.5a-nspluginviewer-qt31.diff.gzbin0 -> 36346 bytes
-rw-r--r--kde-base/kdebase/files/3.0.5a/kdebase-3.0.5a-xft1.1-fix.diff76
-rw-r--r--kde-base/kdebase/files/3.0.5a/kdebase-3.0.5a-xft_h-fix.diff11
-rw-r--r--kde-base/kdebase/files/3.0.5a/startkde-3.0.5a-gentoo.diff55
-rw-r--r--kde-base/kdebase/files/digest-kdebase-3.0.5a1
-rw-r--r--kde-base/kdebase/kdebase-3.0.5a.ebuild131
6 files changed, 274 insertions, 0 deletions
diff --git a/kde-base/kdebase/files/3.0.5a/kdebase-3.0.5a-nspluginviewer-qt31.diff.gz b/kde-base/kdebase/files/3.0.5a/kdebase-3.0.5a-nspluginviewer-qt31.diff.gz
new file mode 100644
index 000000000000..281ca5298fb2
--- /dev/null
+++ b/kde-base/kdebase/files/3.0.5a/kdebase-3.0.5a-nspluginviewer-qt31.diff.gz
Binary files differ
diff --git a/kde-base/kdebase/files/3.0.5a/kdebase-3.0.5a-xft1.1-fix.diff b/kde-base/kdebase/files/3.0.5a/kdebase-3.0.5a-xft1.1-fix.diff
new file mode 100644
index 000000000000..2a6000dca8a0
--- /dev/null
+++ b/kde-base/kdebase/files/3.0.5a/kdebase-3.0.5a-xft1.1-fix.diff
@@ -0,0 +1,76 @@
+--- kdebase-3.0.4/kcontrol/kfontinst/kfontinst/XftConfig.cpp.orig 2002-10-30 00:53:18.000000000 +0200
++++ kdebase-3.0.4/kcontrol/kfontinst/kfontinst/XftConfig.cpp 2002-10-30 01:01:49.000000000 +0200
+@@ -276,7 +276,7 @@
+ }
+ case XftTypeString:
+ str+="\"";
+- str+=test->value.u.s;
++ str+=(QCString &)test->value.u.s;
+ str+="\"";
+ break;
+ case XftTypeBool:
+@@ -554,7 +554,7 @@
+ XftValue value;
+ CXftConfig::TEntry *entry=new CXftConfig::TEntry;
+
+- value.u.s=sval;
++ (char *)value.u.s=sval;
+ value.type=XftTypeString;
+ entry->test=XftTestCreate(XftQualAny, "family", XftOpEqual, value);
+
+@@ -780,7 +780,7 @@
+
+ for(entry=itsList.first(); entry; entry=itsList.next())
+ if(entry->test && 0==CMisc::stricmp(entry->test->field, "family") && XftTypeString==entry->test->value.type &&
+- 0==CMisc::stricmp(entry->test->value.u.s, family.latin1()) && entry->edit &&
++ 0==CMisc::stricmp((char *)entry->test->value.u.s, family.latin1()) && entry->edit &&
+ 0==CMisc::stricmp(entry->edit->field, field) && XftOpAssign==entry->edit->op && entry->edit->expr)
+ break;
+
+@@ -798,7 +798,7 @@
+ free(test->field);
+
+ if(XftTypeString==test->value.type)
+- free(test->value.u.s);
++ free((void *)test->value.u.s);
+ }
+ }
+
+--- kdebase-3.0.4/kcontrol/kfontinst/kfontinst/XftConfigEditor.cpp.orig 2002-10-30 01:03:25.000000000 +0200
++++ kdebase-3.0.4/kcontrol/kfontinst/kfontinst/XftConfigEditor.cpp 2002-10-30 01:07:27.000000000 +0200
+@@ -469,7 +469,7 @@
+ break;
+ case XftTypeString:
+ expr->op=XftOpString;
+- expr->u.sval=val.u.s;
++ expr->u.sval=(char *)val.u.s;
+ break;
+ case XftTypeBool:
+ default:
+@@ -655,12 +655,12 @@
+ if("foundry"==field || "family"==field || "encoding"==field || "style"==field)
+ {
+ val.type=XftTypeString;
+- val.u.s=(char *)malloc(edit ? strVal.length()+1 : strVal.length()-1);
++ (char *)val.u.s=(char *)malloc(edit ? strVal.length()+1 : strVal.length()-1);
+
+ if(edit)
+- strcpy(val.u.s, strVal.local8Bit());
++ strcpy((char *)val.u.s, strVal.local8Bit());
+ else
+- strcpy(val.u.s, strVal.mid(1, strVal.length()-2).local8Bit()); // Need to remove quotes from each end of the string...
++ strcpy((char *)val.u.s, strVal.mid(1, strVal.length()-2).local8Bit()); // Need to remove quotes from each end of the string...
+ }
+ else if("spacing"==field)
+ {
+@@ -747,8 +747,8 @@
+ {
+ // Not sure about this...
+ val.type=XftTypeString;
+- val.u.s=(char *)malloc(strVal.length()+1);
+- strcpy(val.u.s, strVal.local8Bit());
++ (char *)val.u.s=(char *)malloc(strVal.length()+1);
++ strcpy((char *)val.u.s, strVal.local8Bit());
+ }
+ else if("rgba"==field)
+ {
diff --git a/kde-base/kdebase/files/3.0.5a/kdebase-3.0.5a-xft_h-fix.diff b/kde-base/kdebase/files/3.0.5a/kdebase-3.0.5a-xft_h-fix.diff
new file mode 100644
index 000000000000..0971b0d039c3
--- /dev/null
+++ b/kde-base/kdebase/files/3.0.5a/kdebase-3.0.5a-xft_h-fix.diff
@@ -0,0 +1,11 @@
+--- Xft.h.orig 2002-10-30 00:48:12.000000000 +0200
++++ Xft.h 2002-10-30 00:47:28.000000000 +0200
+@@ -150,6 +150,8 @@
+ int ref;
+ };
+
++typedef FcValueList XftValueList;
++
+ /*
+ * End of Gentoo hack
+ */
diff --git a/kde-base/kdebase/files/3.0.5a/startkde-3.0.5a-gentoo.diff b/kde-base/kdebase/files/3.0.5a/startkde-3.0.5a-gentoo.diff
new file mode 100644
index 000000000000..413af205de77
--- /dev/null
+++ b/kde-base/kdebase/files/3.0.5a/startkde-3.0.5a-gentoo.diff
@@ -0,0 +1,55 @@
+--- startkde~ 2002-12-20 14:34:51.000000000 +0100
++++ startkde 2002-12-20 14:24:38.000000000 +0100
+@@ -1,8 +1,21 @@
+-#!/bin/sh
++#!/bin/sh --login
+ #
+-# DEFAULT KDE STARTUP SCRIPT ( KDE-3.0.5a )
++# GENTOO CUSTOMIZED KDE STARTUP SCRIPT ( KDE-3.0.5a )
+ #
+
++# Gentoo part:
++export PATH="_KDEDIR_/bin:${PATH}"
++export KDEDIR="_KDEDIR_"
++export KDEDIRS="_KDEDIR_:/usr" # do NOT include env.d's $KDEDIRS
++
++cd ~
++[ -d .kde ] && mv .kde .kde.backup
++[ -e .kde3 ] || mkdir .kde3
++ln -sf .kde3 .kde
++export KDEHOME="${HOME}/.kde3"
++
++# Gentoo part ends
++
+ # Boot sequence:
+ #
+ # kdeinit is used to fork off processes which improves memory usage
+@@ -25,12 +38,12 @@
+ # especially necessary on slow machines, where starting KDE takes one or two
+ # minutes until anything appears on the screen.
+ #
+-# Set the background to plain grey.
++# Set the background to cyan (Gentoo version change).
+ # The standard X background is nasty, causing moire effects and exploding
+ # people's heads. We use colours from the standard KDE palette for those with
+ # palettised displays.
+
+-test "$XDM_MANAGED" || bkg="-solid #C0C0C0"
++test "$XDM_MANAGED" || bkg="-solid #5477A0"
+ xsetroot -cursor_name left_ptr $bkg
+
+ # The user's personal KDE directory is usually ~/.kde, but this setting
+@@ -131,7 +144,12 @@
+ fi
+
+ # the splashscreen and progress indicator
+-ksplash
++# Gentoo addition: run $KSPLASH if set, otherwise just the default 'ksplash'
++if [ -n "$KSPLASH" ]; then
++ $KSPLASH
++else
++ ksplash
++fi
+
+ # We set LD_BIND_NOW to increase the efficiency of kdeinit.
+ # kdeinit unsets this variable before loading applications.
diff --git a/kde-base/kdebase/files/digest-kdebase-3.0.5a b/kde-base/kdebase/files/digest-kdebase-3.0.5a
new file mode 100644
index 000000000000..0c472115576e
--- /dev/null
+++ b/kde-base/kdebase/files/digest-kdebase-3.0.5a
@@ -0,0 +1 @@
+MD5 16c53e754e866f112797f695ba84c3a4 kdebase-3.0.5a.tar.bz2 13117676
diff --git a/kde-base/kdebase/kdebase-3.0.5a.ebuild b/kde-base/kdebase/kdebase-3.0.5a.ebuild
new file mode 100644
index 000000000000..c6809ecfd877
--- /dev/null
+++ b/kde-base/kdebase/kdebase-3.0.5a.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-3.0.5a.ebuild,v 1.1 2002/12/21 13:48:19 hannes Exp $
+inherit kde-dist
+
+IUSE="ldap pam motif encode oggvorbis cups ssl opengl samba"
+
+DESCRIPTION="KDE $PV - base packages: the desktop, panel, window manager, konqueror..."
+
+KEYWORDS="x86 ~ppc ~alpha"
+
+newdepend ">=media-sound/cdparanoia-3.9.8
+ ldap? ( >=net-nds/openldap-1.2 )
+ pam? ( >=sys-libs/pam-0.73 )
+ motif? ( >=x11-libs/openmotif-2.1.30 )
+ encode? ( >=media-sound/lame-3.89b )
+ oggvorbis? ( >=media-libs/libvorbis-1.0_beta1 )
+ cups? ( net-print/cups )
+ ssl? ( >=dev-libs/openssl-0.9.6b )
+ opengl? ( virtual/opengl )
+ samba? ( net-fs/samba )"
+# lm_sensors? ( ?/lm_sensors ) # ebuild doesn't exist yet
+
+DEPEND="$DEPEND sys-apps/gzip"
+
+myconf="$myconf --with-dpms --with-cdparanoia"
+
+use ldap && myconf="$myconf --with-ldap" || myconf="$myconf --without-ldap"
+use pam && myconf="$myconf --with-pam" || myconf="$myconf --with-shadow"
+use motif && myconf="$myconf --with-motif" || myconf="$myconf --without-motif"
+use encode && myconf="$myconf --with-lame" || myconf="$myconf --without-lame"
+use cups && myconf="$myconf --with-cups" || myconf="$myconf --disable-cups"
+use oggvorbis && myconf="$myconf --with-vorbis" || myconf="$myconf --without-vorbis"
+use opengl && myconf="$myconf --with-gl" || myconf="$myconf --without-gl"
+use ssl && myconf="$myconf --with-ssl" || myconf="$myconf --without-ssl"
+use pam && myconf="$myconf --with-pam=yes" || myconf="$myconf --with-pam=no --with-shadow"
+
+pkg_setup() {
+
+ # It should generally be considered bad form to touch files in the
+ # live filesystem, but we had a broken Xft.h out there, and to expect
+ # all users to update X because of it is harsh. Also, there is no
+ # official fix to xfree for this issue as of writing. See bug #9423
+ # for more info.
+ cd /usr/X11R6/include/X11/Xft
+ if patch --dry-run -p0 < ${FILESDIR}/${PVR}/${P}-xft_h-fix.diff > /dev/null
+ then
+ einfo "Patching Xft.h to fix missing defines..."
+ patch -p0 < ${FILESDIR}/${PVR}/${P}-xft_h-fix.diff > /dev/null || die
+ fi
+}
+
+src_unpack() {
+
+ base_src_unpack
+
+ cd ${S}
+ /bin/zcat "$FILESDIR/${PVR}/$P-nspluginviewer-qt31.diff.gz" | patch -p1 --
+
+ # Apply this only if we are using a hacked Xft-1.1 Xft.h.
+ if [ -n "`grep "End of Gentoo hack" /usr/X11R6/include/X11/Xft/Xft.h`" ]
+ then
+ cd ${S}; patch -p1 < ${FILESDIR}/${PVR}/${P}-xft1.1-fix.diff || die
+ fi
+}
+
+src_compile() {
+
+ kde_src_compile myconf configure
+ kde_remove_flag kdm/kfrontend -fomit-frame-pointer
+ kde_src_compile make
+
+}
+
+src_install() {
+
+ kde_src_install
+
+ # cf bug #5953
+ insinto /etc/pam.d
+ newins ${FILESDIR}/kscreensaver.pam kscreensaver
+ newins ${FILESDIR}/kde.pam kde
+
+ # startkde script
+ cd ${D}/${KDEDIR}/bin
+ patch -p0 < ${FILESDIR}/${PVR}/startkde-${PVR}-gentoo.diff || die
+ mv startkde startkde.orig
+ sed -e "s:_KDEDIR_:${KDEDIR}:" startkde.orig > startkde
+ rm startkde.orig
+ chmod a+x startkde
+
+ # x11 session script
+ cd ${T}
+ echo "#!/bin/sh
+${KDEDIR}/bin/startkde" > kde-${PV}
+ chmod a+x kde-${PV}
+ # old scheme - compatibility
+ exeinto /usr/X11R6/bin/wm
+ doexe kde-${PV}
+ # new scheme - for now >=xfree-4.2-r3 only
+ exeinto /etc/X11/Sessions
+ doexe kde-${PV}
+
+ cd ${D}/${PREFIX}/share/config/kdm || die
+ mv kdmrc kdmrc.orig
+ sed -e "s:SessionTypes=:SessionTypes=kde-${PV},:" \
+ -e "s:Session=${PREFIX}/share/config/kdm/Xsession:Session=/etc/X11/xdm/Xsession:" kdmrc.orig > kdmrc
+ rm kdmrc.orig
+
+ #backup splashscreen images, so they can be put back when unmerging
+ #mosfet or so.
+ if [ ! -d ${KDEDIR}/share/apps/ksplash.default ]
+ then
+ cd ${D}/${KDEDIR}/share/apps
+ cp -rf ksplash/ ksplash.default
+ fi
+
+ # Show gnome icons when choosing new icon for desktop shortcut
+ dodir /usr/share/pixmaps
+ mv ${D}/${KDEDIR}/share/apps/kdesktop/pics/* ${D}/usr/share/pixmaps/
+ rm -rf ${D}/${KDEDIR}/share/apps/kdesktop/pics/
+ cd ${D}/${KDEDIR}/share/apps/kdesktop/
+ ln -sf /usr/share/pixmaps/ pics
+
+ rmdir ${D}/${KDEDIR}/share/templates/.source/emptydir
+
+}
+
+pkg_postinst() {
+ mkdir -p ${KDEDIR}/share/templates/.source/emptydir
+}