summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-04-03 21:49:41 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-04-03 21:49:41 +0000
commitc720f79a21ec6fc47b92109987daca264d416bff (patch)
tree1b6bd65f854b288e82f20100a5ed85c008e3511e /kde-base/kalzium
parentadded ~amd64 (diff)
downloadhistorical-c720f79a21ec6fc47b92109987daca264d416bff.tar.gz
historical-c720f79a21ec6fc47b92109987daca264d416bff.tar.bz2
historical-c720f79a21ec6fc47b92109987daca264d416bff.zip
Version bump to KDE 4.0.3. This is still not intended for mainstream so DO NOT KEYWORD IT without talking to the KDE herd first.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'kde-base/kalzium')
-rw-r--r--kde-base/kalzium/ChangeLog9
-rw-r--r--kde-base/kalzium/kalzium-4.0.3.ebuild66
2 files changed, 74 insertions, 1 deletions
diff --git a/kde-base/kalzium/ChangeLog b/kde-base/kalzium/ChangeLog
index 2ca52d817aa3..e67baff61221 100644
--- a/kde-base/kalzium/ChangeLog
+++ b/kde-base/kalzium/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/kalzium
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.89 2008/03/20 16:21:25 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.90 2008/04/03 20:38:41 philantrop Exp $
+
+*kalzium-4.0.3 (03 Apr 2008)
+
+ 03 Apr 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +kalzium-4.0.3.ebuild:
+ Version bump to KDE 4.0.3. This is still not intended for mainstream so DO
+ NOT KEYWORD IT without talking to the KDE herd first.
20 Mar 2008; Ingmar Vanhassel <ingmar@gentoo.org> -kalzium-4.0.1.ebuild:
Old.
diff --git a/kde-base/kalzium/kalzium-4.0.3.ebuild b/kde-base/kalzium/kalzium-4.0.3.ebuild
new file mode 100644
index 000000000000..bd411260f4c6
--- /dev/null
+++ b/kde-base/kalzium/kalzium-4.0.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/kalzium-4.0.3.ebuild,v 1.1 2008/04/03 20:38:41 philantrop Exp $
+
+EAPI="1"
+
+KMNAME=kdeedu
+CPPUNIT_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KDE: periodic table of the elements."
+KEYWORDS="~amd64 ~x86"
+IUSE="${IUSE} cviewer debug htmlhandbook solver"
+
+COMMONDEPEND=">=kde-base/libkdeedu-${PV}:${SLOT}
+ cviewer? ( >=dev-cpp/eigen-1.0.5
+ >=sci-chemistry/openbabel-2.1
+ || ( x11-libs/qt-opengl:4
+ >=x11-libs/qt-4.3.3:4 )
+ virtual/opengl )"
+DEPEND="${DEPEND} ${COMMONDEPEND}
+ solver? ( dev-ml/facile )"
+RDEPEND="${RDEPEND} ${COMMONDEPEND}"
+
+KMEXTRACTONLY="libkdeedu/kdeeduui libkdeedu/libscience"
+
+pkg_setup() {
+ if use cviewer && has_version '<x11-libs/qt-4.4.0_alpha:4'; then
+ QT4_BUILT_WITH_USE_CHECK="${QT4_BUILT_WITH_USE_CHECK} opengl"
+ fi
+
+ if use solver && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build the solver for ${PN}, you first need"
+ eerror "to have dev-lang/ocaml built with the ocamlopt useflag"
+ eerror "in order to get a native code ocaml compiler"
+ die "Please install dev-lang/ocaml with ocamlopt support"
+ fi
+ if use solver && ! built_with_use --missing true dev-ml/facile ocamlopt; then
+ eerror "In order to build the solver for ${PN}, you first need"
+ eerror "to have dev-ml/facile built with the ocamlopt useflag"
+ eerror "in order to get the native code library"
+ die "Please install dev-ml/facile with ocamlopt support"
+ fi
+
+ kde4-meta_pkg_setup
+}
+
+src_compile() {
+ if use solver ; then
+ # Compile the solver on its own as the cmake-based build is
+ # currently broken. Fixes bug 206620.
+ cd "${S}/${PN}/src/solver"
+ emake || die "compiling the ocaml resolver failed"
+ mkdir -p "${WORKDIR}/${PN}_build/${PN}/src/"
+ cp * "${WORKDIR}/${PN}_build/${PN}/src/"
+ fi
+
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with cviewer Eigen)
+ $(cmake-utils_use_with cviewer OpenBabel2)
+ $(cmake-utils_use_with cviewer OpenGL)
+ $(cmake-utils_use_with solver OCaml)
+ $(cmake-utils_use_with solver Libfacile)"
+
+ kde4-meta_src_compile
+}