summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2005-11-22 22:14:16 +0000
committerDan Armak <danarmak@gentoo.org>2005-11-22 22:14:16 +0000
commitec50b1ccda877b635377e8dc5b79019eb1859906 (patch)
tree155d2c4d6c4be39c89ebb4baf7a5ebc2096a2c82 /kde-base/kalyptus/kalyptus-3.5.0.ebuild
parentversion bump (diff)
downloadhistorical-ec50b1ccda877b635377e8dc5b79019eb1859906.tar.gz
historical-ec50b1ccda877b635377e8dc5b79019eb1859906.tar.bz2
historical-ec50b1ccda877b635377e8dc5b79019eb1859906.zip
KDE 3.5.0 (not yet released, p.masked)
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'kde-base/kalyptus/kalyptus-3.5.0.ebuild')
-rw-r--r--kde-base/kalyptus/kalyptus-3.5.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/kde-base/kalyptus/kalyptus-3.5.0.ebuild b/kde-base/kalyptus/kalyptus-3.5.0.ebuild
new file mode 100644
index 000000000000..d53723985220
--- /dev/null
+++ b/kde-base/kalyptus/kalyptus-3.5.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalyptus/kalyptus-3.5.0.ebuild,v 1.1 2005/11/22 22:13:57 danarmak Exp $
+
+KMNAME=kdebindings
+KM_MAKEFILESREV=1
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta
+
+DESCRIPTION="KDE bindings generator for C, ObjC and Java"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="dev-lang/perl"
+PATCHES="$FILESDIR/no-gtk-glib-check.diff"
+
+# Weird build system, weirder errors.
+# You're welcome to fix this in a better way --danarmak
+src_compile () {
+ export S=$S/kalyptus
+ kde-meta_src_compile
+}
+
+src_install() {
+ cd $S/kalyptus
+ make install DESTDIR=$D
+} \ No newline at end of file