summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Hüttel <dilfridge@gentoo.org>2012-08-01 22:54:54 +0000
committerAndreas Hüttel <dilfridge@gentoo.org>2012-08-01 22:54:54 +0000
commit3d8d79cdb3424ad8eb0aca66377a5d658c274380 (patch)
tree22dd4b515e93b30450d5c7a8888c84964bf5f900 /kde-base/kaddressbook/kaddressbook-4.4.11.1-r1.ebuild
parentVersion bump; remove old. (diff)
downloadhistorical-3d8d79cdb3424ad8eb0aca66377a5d658c274380.tar.gz
historical-3d8d79cdb3424ad8eb0aca66377a5d658c274380.tar.bz2
historical-3d8d79cdb3424ad8eb0aca66377a5d658c274380.zip
Add upstream bugfixes
Package-Manager: portage-2.2.0_alpha120/cvs/Linux x86_64
Diffstat (limited to 'kde-base/kaddressbook/kaddressbook-4.4.11.1-r1.ebuild')
-rw-r--r--kde-base/kaddressbook/kaddressbook-4.4.11.1-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/kde-base/kaddressbook/kaddressbook-4.4.11.1-r1.ebuild b/kde-base/kaddressbook/kaddressbook-4.4.11.1-r1.ebuild
new file mode 100644
index 000000000000..2e213f744448
--- /dev/null
+++ b/kde-base/kaddressbook/kaddressbook-4.4.11.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kaddressbook/kaddressbook-4.4.11.1-r1.ebuild,v 1.1 2012/08/01 22:52:26 dilfridge Exp $
+
+EAPI=4
+
+KMNAME="kdepim"
+KDE_HANDBOOK=optional
+inherit kde4-meta
+
+DESCRIPTION="The KDE Address Book"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop' 4.6)
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop' 4.6)
+ $(add_kdebase_dep libkdepim)
+ $(add_kdebase_dep libkleo)
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kdepim-runtime)
+"
+
+KMEXTRA="
+ plugins/kaddressbook/
+ plugins/ktexteditor/
+"
+KMEXTRACTONLY="
+ libkleo/
+"
+
+KMLOADLIBS="libkdepim"
+
+PATCHES=( "${FILESDIR}/4.4/"0002-*.patch )
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kdepim-kresources:${SLOT}; then
+ echo
+ elog "For groupware functionality, please install kde-base/kdepim-kresources:${SLOT}"
+ echo
+ fi
+}