summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-11-03 16:31:05 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-11-03 16:31:05 +0000
commit6e9827de00edc0bb0a6fe077b16b9694ac2726f5 (patch)
treea0314490ab642a367b0f8019fb62003898871e78 /kde-base/cantor
parentKeyword ~ppc64 wrt #337385 (diff)
downloadhistorical-6e9827de00edc0bb0a6fe077b16b9694ac2726f5.tar.gz
historical-6e9827de00edc0bb0a6fe077b16b9694ac2726f5.tar.bz2
historical-6e9827de00edc0bb0a6fe077b16b9694ac2726f5.zip
KDE SC 4.5.3 Version bump
Package-Manager: portage-2.2.0_alpha3/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/cantor')
-rw-r--r--kde-base/cantor/ChangeLog7
-rw-r--r--kde-base/cantor/cantor-4.5.3.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/kde-base/cantor/ChangeLog b/kde-base/cantor/ChangeLog
index 06dd174791e8..ddfb4a4b29d6 100644
--- a/kde-base/cantor/ChangeLog
+++ b/kde-base/cantor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/cantor
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/ChangeLog,v 1.19 2010/10/06 09:17:32 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/ChangeLog,v 1.20 2010/11/03 16:30:58 scarabeus Exp $
+
+*cantor-4.5.3 (03 Nov 2010)
+
+ 03 Nov 2010; Tomáš Chvátal <scarabeus@gentoo.org> +cantor-4.5.3.ebuild:
+ Version bump
*cantor-4.5.2 (05 Oct 2010)
diff --git a/kde-base/cantor/cantor-4.5.3.ebuild b/kde-base/cantor/cantor-4.5.3.ebuild
new file mode 100644
index 000000000000..ad79b4dcbba3
--- /dev/null
+++ b/kde-base/cantor/cantor-4.5.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/cantor-4.5.3.ebuild,v 1.1 2010/11/03 16:30:58 scarabeus Exp $
+
+EAPI="3"
+
+KDE_HANDBOOK="optional"
+KMNAME="kdeedu"
+inherit kde4-meta
+
+DESCRIPTION="KDE4 interface for doing mathematics and scientific computing"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug ps +R"
+
+# TODO Add Sage Mathematics Software backend (http://www.sagemath.org)
+RDEPEND="
+ ps? ( app-text/libspectre )
+ R? ( dev-lang/R )
+"
+DEPEND="${RDEPEND}
+ >=dev-cpp/eigen-2.0.3:2
+"
+
+src_configure() {
+ mycmakeargs+="
+ $(cmake-utils_use_with ps LibSpectre)
+ $(cmake-utils_use_with R)
+ "
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! use R; then
+ echo
+ ewarn "You have decided to build ${PN} with no backend."
+ ewarn "To have this application functional, please do one of below:"
+ ewarn " # emerge -va1 '='${CATEGORY}/${P} with 'R' USE flag enabled"
+ ewarn " # emerge -vaDu sci-mathematics/maxima"
+ echo
+ fi
+}