summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-12-01 11:36:37 +0000
committerAlex Alexander <wired@gentoo.org>2009-12-01 11:36:37 +0000
commite8f7743cd87a04b2c8e2d338f60b317b4d872b85 (patch)
tree2604dccb1524e9817015e7953d113765901e603e /kde-base/ark
parentFix dependencies over cups to avoid downgrades to 1.3 for users with zeroconf... (diff)
downloadhistorical-e8f7743cd87a04b2c8e2d338f60b317b4d872b85.tar.gz
historical-e8f7743cd87a04b2c8e2d338f60b317b4d872b85.tar.bz2
historical-e8f7743cd87a04b2c8e2d338f60b317b4d872b85.zip
Version bump KDE 4.3.4
Package-Manager: portage-2.2_rc54/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/ark')
-rw-r--r--kde-base/ark/ChangeLog7
-rw-r--r--kde-base/ark/ark-4.3.4.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/kde-base/ark/ChangeLog b/kde-base/ark/ChangeLog
index 8b732e2df411..2fa715fcf467 100644
--- a/kde-base/ark/ChangeLog
+++ b/kde-base/ark/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ark
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ChangeLog,v 1.138 2009/11/30 11:50:28 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ChangeLog,v 1.139 2009/12/01 09:56:25 wired Exp $
+
+*ark-4.3.4 (01 Dec 2009)
+
+ 01 Dec 2009; Alex Alexander <wired@gentoo.org> +ark-4.3.4.ebuild:
+ Version bump
30 Nov 2009; Tomáš Chvátal <scarabeus@gentoo.org> ark-4.3.3-r1.ebuild:
Add back dropped sparc keyword.
diff --git a/kde-base/ark/ark-4.3.4.ebuild b/kde-base/ark/ark-4.3.4.ebuild
new file mode 100644
index 000000000000..f63eef47fcf6
--- /dev/null
+++ b/kde-base/ark/ark-4.3.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ark-4.3.4.ebuild,v 1.1 2009/12/01 09:56:25 wired Exp $
+
+EAPI="2"
+
+KMNAME="kdeutils"
+inherit kde4-meta
+
+DESCRIPTION="KDE Archiving tool"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+archive +bzip2 debug +handbook lzma zip"
+
+DEPEND="
+ $(add_kdebase_dep libkonq)
+ archive? ( >=app-arch/libarchive-2.6.1[bzip2?,lzma?,zlib] )
+ lzma? ( app-arch/xz-utils )
+ zip? ( >=dev-libs/libzip-0.8 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with archive LibArchive)
+ $(cmake-utils_use_with bzip2 BZip2)
+ $(cmake-utils_use_with lzma LibLZMA)
+ $(cmake-utils_use_with zip LibZip)
+ "
+ kde4-meta_src_configure
+}