summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-02-28 14:27:17 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-02-28 14:27:17 +0000
commitb8beccb7b1647aded3bb2b802b3af97a742b9f70 (patch)
tree36baad5b4de5d30c63064677a5f4dd50c480263a /kde-base/akode/akode-3.4.0_rc1.ebuild
parentAdd optional support for python scripting. (diff)
downloadhistorical-b8beccb7b1647aded3bb2b802b3af97a742b9f70.tar.gz
historical-b8beccb7b1647aded3bb2b802b3af97a742b9f70.tar.bz2
historical-b8beccb7b1647aded3bb2b802b3af97a742b9f70.zip
Remove redundant libsamplerate dependency. Pass --with-speex option.
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'kde-base/akode/akode-3.4.0_rc1.ebuild')
-rw-r--r--kde-base/akode/akode-3.4.0_rc1.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/kde-base/akode/akode-3.4.0_rc1.ebuild b/kde-base/akode/akode-3.4.0_rc1.ebuild
index f9e0c6172fb9..c3814bc85b62 100644
--- a/kde-base/akode/akode-3.4.0_rc1.ebuild
+++ b/kde-base/akode/akode-3.4.0_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/akode/akode-3.4.0_rc1.ebuild,v 1.1 2005/02/27 20:21:29 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/akode/akode-3.4.0_rc1.ebuild,v 1.2 2005/02/28 14:27:17 greg_g Exp $
KMNAME=kdemultimedia
MAXKDEVER=$PV
@@ -9,7 +9,7 @@ inherit kde-meta
DESCRIPTION="aRts plugins for various formats"
KEYWORDS="~x86"
-IUSE="flac oggvorbis speex mad arts alsa libsamplerate jack"
+IUSE="flac oggvorbis speex mad arts alsa jack"
DEPEND="arts? ( $(deprange $PV $MAXKDEVER kde-base/arts) )
flac? ( media-libs/flac )
oggvorbis? ( media-sound/vorbis-tools )
@@ -17,7 +17,6 @@ DEPEND="arts? ( $(deprange $PV $MAXKDEVER kde-base/arts) )
!=media-libs/speex-1.1.4
media-libs/libsamplerate
mad? ( media-libs/libmad )
- libsamplerate? ( media-libs/libsamplerate )
alsa? ( media-libs/alsa-lib )
jack? ( media-sound/jack-audio-connection-kit )"
@@ -26,7 +25,7 @@ DEPEND="arts? ( $(deprange $PV $MAXKDEVER kde-base/arts) )
src_compile() {
use speex && myconf="$myconf --with-extra-includes=/usr/include/speex"
- myconf="$myconf $(use_with mad libmad) $(use_with flac) $(use_with libsamplerate)
+ myconf="$myconf $(use_with mad libmad) $(use_with flac) $(use_with speex)
$(use_with alsa) $(use_with jack) $(use_with oggvorbis vorbis)"
kde-meta_src_compile