summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2006-03-26 07:55:25 +0000
committerFabian Groffen <grobian@gentoo.org>2006-03-26 07:55:25 +0000
commitb8362ad72cfa56b7d4d7463870ada186df19295c (patch)
treeaee1ab0f83bcd08fd7a32f4032649c92805f4d35 /gnustep-base/gnustep-make/files
parentversion bump (diff)
downloadhistorical-b8362ad72cfa56b7d4d7463870ada186df19295c.tar.gz
historical-b8362ad72cfa56b7d4d7463870ada186df19295c.tar.bz2
historical-b8362ad72cfa56b7d4d7463870ada186df19295c.zip
Adding a config file and profile.d profiles (thanks to Dmitry S. Kulyabov, bug #117187)
Package-Manager: portage-2.1_pre6-r5
Diffstat (limited to 'gnustep-base/gnustep-make/files')
-rw-r--r--gnustep-base/gnustep-make/files/digest-gnustep-make-1.12.0-r1 (renamed from gnustep-base/gnustep-make/files/digest-gnustep-make-1.12.0)0
-rw-r--r--gnustep-base/gnustep-make/files/gnustep.csh21
-rw-r--r--gnustep-base/gnustep-make/files/gnustep.sh23
3 files changed, 44 insertions, 0 deletions
diff --git a/gnustep-base/gnustep-make/files/digest-gnustep-make-1.12.0 b/gnustep-base/gnustep-make/files/digest-gnustep-make-1.12.0-r1
index 6cd41c3e7143..6cd41c3e7143 100644
--- a/gnustep-base/gnustep-make/files/digest-gnustep-make-1.12.0
+++ b/gnustep-base/gnustep-make/files/digest-gnustep-make-1.12.0-r1
diff --git a/gnustep-base/gnustep-make/files/gnustep.csh b/gnustep-base/gnustep-make/files/gnustep.csh
new file mode 100644
index 000000000000..fbb176a23734
--- /dev/null
+++ b/gnustep-base/gnustep-make/files/gnustep.csh
@@ -0,0 +1,21 @@
+#!/bin/csh
+
+if ( -e /etc/GNUstep/GNUstep.conf ) then
+ eval `sed -e '/^[^#=][^#=]*=.*$/\\!d' -e 's/^\([^#=][^#=]*\)=\(.*\)$/setenv \1 \2;/' /etc/GNUstep/GNUstep.conf`
+else
+ GNUSTEP_SYSTEM_ROOT="/usr/GNUstep/System"
+endif
+
+source $GNUSTEP_SYSTEM_ROOT/Library/Makefiles/GNUstep.csh
+
+if ( -z "$GNUSTEP_FLATTENED" ) then
+ set TDIR=${GNUSTEP_SYSTEM_ROOT}/Tools/${GNUSTEP_HOST_CPU}/${GNUSTEP_HOST_OS}/${LIBRARY_COMBO}
+else
+ set TDIR=${GNUSTEP_SYSTEM_ROOT}/Tools
+endif
+
+if ( -x $TDIR/make_services ) then
+ $TDIR/make_services
+endif
+
+unset TDIR \ No newline at end of file
diff --git a/gnustep-base/gnustep-make/files/gnustep.sh b/gnustep-base/gnustep-make/files/gnustep.sh
new file mode 100644
index 000000000000..7ffe0b692965
--- /dev/null
+++ b/gnustep-base/gnustep-make/files/gnustep.sh
@@ -0,0 +1,23 @@
+#!/bin/sh
+
+if [ -e /etc/GNUstep/GNUstep.conf ]
+ then
+ . /etc/GNUstep/GNUstep.conf
+else
+ GNUSTEP_SYSTEM_ROOT="/usr/GNUstep/System"
+fi
+
+. $GNUSTEP_SYSTEM_ROOT/Library/Makefiles/GNUstep.sh
+
+if [ -z "$GNUSTEP_FLATTENED" ]
+ then
+ TDIR=${GNUSTEP_SYSTEM_ROOT}/Tools/${GNUSTEP_HOST_CPU}/${GNUSTEP_HOST_OS}/${LIBRARY_COMBO}
+else
+ TDIR=${GNUSTEP_SYSTEM_ROOT}/Tools
+fi
+
+if [ -x $TDIR/make_services ]
+ then
+ $TDIR/make_services
+fi
+