summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-10 01:55:17 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-10 01:55:17 +0000
commitcfe6e2417e164151eafb07c9ee03ddaf37309e6b (patch)
tree30dc2740fbe9de241394765fde75c7f4a1ff746c /gnome-office
parentDependencie fixes, build most allways with -j1, missing digests and diffs (diff)
downloadhistorical-cfe6e2417e164151eafb07c9ee03ddaf37309e6b.tar.gz
historical-cfe6e2417e164151eafb07c9ee03ddaf37309e6b.tar.bz2
historical-cfe6e2417e164151eafb07c9ee03ddaf37309e6b.zip
*** empty log message ***
Diffstat (limited to 'gnome-office')
-rw-r--r--gnome-office/dia/dia-0.87.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnome-office/dia/dia-0.87.ebuild b/gnome-office/dia/dia-0.87.ebuild
new file mode 100644
index 000000000000..fc8d0c883848
--- /dev/null
+++ b/gnome-office/dia/dia-0.87.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-office/dia/dia-0.87.ebuild,v 1.1 2001/05/10 01:55:17 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Diagram Creation Program"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${A}"
+HOMEPAGE="http://www.gnome.org/gnome-office/dia.shtml"
+
+DEPEND=">=gnome-base/gnome-print-0.24
+ >=app-arch/rpm-3.0.5"
+
+
+src_compile() {
+
+ local myconf
+ if [ "`use bonobo`" ]
+ then
+ myconf="--enable-bonobo"
+ fi
+ try ./configure --host=${CHOST} --prefix=/opt/gnome \
+ --sysconfdir=/etc/opt/gnome \
+ --enable-gnome --enable-gnome-print ${myconf}
+ # bonobo support does not work yet
+ try make
+
+}
+
+src_install () {
+
+ try make prefix=${D}/opt/gnome sysconfdir=${D}7etc/opt/gnome install
+ dodoc AUTHORS COPYING ChangeLog README NEWS TODO KNOWN_BUGS
+
+}
+
+
+
+
+