summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-08-25 12:21:37 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-08-25 12:21:37 +0000
commit05f76ccc824cd6ba9bdde33c849a595235cba6c7 (patch)
treeb1983bf6cd7f453e2c031d94feb52e3e0cf415c9 /gnome-extra/mc
parentadded new howtos, removed old howtos. note: the new ones won't be available u... (diff)
downloadhistorical-05f76ccc824cd6ba9bdde33c849a595235cba6c7.tar.gz
historical-05f76ccc824cd6ba9bdde33c849a595235cba6c7.tar.bz2
historical-05f76ccc824cd6ba9bdde33c849a595235cba6c7.zip
added 4.5.55, for changes see: http://mail.gnome.org/archives/gnome-announce-list/2001-August/msg00035.html
Diffstat (limited to 'gnome-extra/mc')
-rw-r--r--gnome-extra/mc/files/digest-mc-4.5.551
-rw-r--r--gnome-extra/mc/mc-4.5.55.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/gnome-extra/mc/files/digest-mc-4.5.55 b/gnome-extra/mc/files/digest-mc-4.5.55
new file mode 100644
index 000000000000..a1937360c601
--- /dev/null
+++ b/gnome-extra/mc/files/digest-mc-4.5.55
@@ -0,0 +1 @@
+MD5 bb670d48589f26f00b7fce8d25f66bd6 mc-4.5.55.tar.gz
diff --git a/gnome-extra/mc/mc-4.5.55.ebuild b/gnome-extra/mc/mc-4.5.55.ebuild
new file mode 100644
index 000000000000..157249b483f6
--- /dev/null
+++ b/gnome-extra/mc/mc-4.5.55.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/mc/mc-4.5.55.ebuild,v 1.1 2001/08/25 12:21:37 hallski Exp $
+
+#P=
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="GNOME Midnight Commander"
+SRC_URI="http://www.gnome.org/projects/${PN}/${A}"
+HOMEPAGE="http://www.gnome.org/projects/mc/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/gpm-1.19.3
+ pam? ( >=sys-libs/pam-0.72 )
+ slang? ( >=sys-libs/slang-1.4.2 )
+ >=sys-apps/e2fsprogs-1.19
+ >=dev-libs/glib-1.2.0
+ gnome? ( >=gnome-base/gnome-libs-1.2.4 )"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/vfs
+ cp smbfs.c smbfs.c.orig
+ sed -e "s:/etc/smb\.conf:/etc/smb/smb\.conf:" smbfs.c.orig > smbfs.c
+}
+
+src_compile() {
+ local myconf
+ if [ "`use pam`" ] ; then
+ myconf="--with-pam"
+ else
+ myconf="--without-pam"
+ fi
+ if [ "`use slang`" ] ; then
+ myconf="$myconf --with-slang"
+ else
+ myconf="$myconf --with-included-slang"
+ fi
+ if [ "`use gnome`" ] ; then
+ myconf="$myconf --with-gnome --prefix=/opt/gnome"
+ else
+ myconf="$myconf --without-gnome --prefix=/usr"
+ fi
+ LDFLAGS="-lcrypt -lncurses" try ./configure --host=${CHOST} \
+ --with-samba --with-vfs --with-netrc $myconf
+ try make # Doesn't work with -j 4 (hallski)
+}
+
+src_install() {
+
+ if [ "`use gnome`" ] ; then
+ try make prefix=${D}/opt/gnome install
+ else
+ try make prefix=${D}/usr install
+ fi
+
+ dodoc ABOUT-NLS COPYING* FAQ INSTALL* NEWS
+ dodoc README*
+}
+
+
+
+
+
+