summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-03-27 01:23:46 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-03-27 01:23:46 +0000
commitf47a4afc972531cc12210e07929512a541f462b2 (patch)
tree858544e810ec8574b22e89f363a948a06d243636 /gnome-base
parentclean out ancient version (diff)
downloadhistorical-f47a4afc972531cc12210e07929512a541f462b2.tar.gz
historical-f47a4afc972531cc12210e07929512a541f462b2.tar.bz2
historical-f47a4afc972531cc12210e07929512a541f462b2.zip
gconf dir fixes
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gconf/ChangeLog6
-rw-r--r--gnome-base/gconf/gconf-1.0.8-r4.ebuild5
-rw-r--r--gnome-base/gconf/gconf-2.2.0.ebuild21
3 files changed, 23 insertions, 9 deletions
diff --git a/gnome-base/gconf/ChangeLog b/gnome-base/gconf/ChangeLog
index 080693c71b65..640caad2d000 100644
--- a/gnome-base/gconf/ChangeLog
+++ b/gnome-base/gconf/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for gnome-base/gconf
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.34 2003/03/11 12:32:23 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.35 2003/03/27 01:23:46 liquidx Exp $
07 Feb 2003; Aron Griffis <agriffis@gentoo.org> gconf-2.2.0.ebuild :
Add ~alpha to KEYWORDS
@@ -10,6 +10,10 @@
*gconf-2.2.0 (30 Jan 2003)
+ 27 Mar 2003; Alastair Tse <liquidx@gentoo.org> gconf-1.0.8-r4.ebuild,
+ gconf-2.2.0.ebuild:
+ fix keepdir problems with gconf.xml.mandatory and others. bug #17645.
+
11 Mar 2003; Jason Wever <weeve@gentoo.org> gconf-2.2.0.ebuild:
Added ~sparc to keywords.
diff --git a/gnome-base/gconf/gconf-1.0.8-r4.ebuild b/gnome-base/gconf/gconf-1.0.8-r4.ebuild
index 95ad2bf467ef..1a2fa1379e9a 100644
--- a/gnome-base/gconf/gconf-1.0.8-r4.ebuild
+++ b/gnome-base/gconf/gconf-1.0.8-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-1.0.8-r4.ebuild,v 1.6 2003/02/13 12:05:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-1.0.8-r4.ebuild,v 1.7 2003/03/27 01:23:46 liquidx Exp $
IUSE="nls"
@@ -54,8 +54,11 @@ src_install() {
install || die
# gconf 1.0.8 seems to gets the perms wrong on this dir.
chmod 0755 ${D}/etc/gconf/gconf.xml.mandatory
+ # keep this mandatory dir
+ touch ${D}/etc/gconf/gconf.xml.mandatory/.keep${SLOT}
# this fix closes bug #803
dodoc AUTHORS COPYING ChangeLog NEWS README* TODO
+
}
pkg_postinst() {
diff --git a/gnome-base/gconf/gconf-2.2.0.ebuild b/gnome-base/gconf/gconf-2.2.0.ebuild
index 64c4e324e20d..504005b379ac 100644
--- a/gnome-base/gconf/gconf-2.2.0.ebuild
+++ b/gnome-base/gconf/gconf-2.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.2.0.ebuild,v 1.8 2003/03/11 12:32:23 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.2.0.ebuild,v 1.9 2003/03/27 01:23:46 liquidx Exp $
IUSE="doc"
@@ -30,6 +30,18 @@ DEPEND="${RDEPEND}
MAKEOPTS="-j1"
+src_install() {
+
+ gnome2_src_install
+
+ # hack hack
+ dodir /etc/gconf/gconf.xml.mandatory
+ dodir /etc/gconf/gconf.xml.defaults
+ touch ${D}/etc/gconf/gconf.xml.mandatory/.keep${SLOT}
+ touch ${D}/etc/gconf/gconf.xml.defaults/.keep${SLOT}
+
+}
+
kill_gconf () {
# this function will kill all running gconfd that could be causing troubles
if [ -x /usr/bin/gconftool ]
@@ -50,16 +62,11 @@ kill_gconf () {
}
pkg_setup () {
- kill_gconf
+ kill_gconf
}
pkg_preinst () {
kill_gconf
- # hack hack
- dodir /etc/gconf/gconf.xml.mandatory
- dodir /etc/gconf/gconf.xml.defaults
- touch ${D}/etc/gconf/gconf.xml.mandatory/.keep
- touch ${D}/etc/gconf/gconf.xml.defaults/.keep
dodir /etc/env.d
echo 'CONFIG_PROTECT_MASK="/etc/gconf"' >${D}/etc/env.d/50gconf